Jump to content

Marionette Stair Run Fails in VW 2021

Recommended Posts

My Marionette "Stair Run" object has been working fine for a year or two or three.  Welcome to Vectorworks 2021.  I placed the object into a very new VW file, created in VW 2021, from a brand new VW 2021 template and... it failed.  See attached.  I'm an ever-increasingly unhappy Vectorworks user.  All the time I've invested in Vectorworks and Marionette seems to be going to waste.  *Sigh*  VWIS209   (In a brand new blank VW file, at least I don't get that warning.  But, even with all classes on, the Marionette object is entirely invisible.  I only know it's there if I do a "Select All."  Then it's in the OIP.  But most of its fields are missing.  It's a downward spiral.)

01-Stair Run Marionette Failure VW 2021 SP2.1.png

Link to comment

Hi Marissa,


Evidently this fails in VW 2020 as well (guess I haven't used it in a while).  I do know that another Marionette object or two also failed in VW 2020 when I tried to use them a few months ago.


The attached "02-VW2020 Stair Run.vwx" file has the Stair Run object in its Resource Manager.  When I place it on the design layer, it's invisible.  It can be selected using "Select All."  But it only appears in the OIP, with just one or two of its many fields.  After saving and reopening the file, "Select All" finds nothing.  The Stair Run was imported from my Marionette Library file.


Going back in time to VW 2018 (I skipped 2019) I get similar results... although I was very much expecting it to work.  Why would Marionette work fine in VW 2018 back in the year 2018, but not here in 2021?!?!...  Anyway, in File "03-VW2018 Stair Run.vwx" there's at least some progress: the Stair Run at least exists as a single Locus, which you should be able to select and see in the OIP (where it's gained an additional field...).


In File "05-VW2018-Project Stair-1801-047W.vwx" I have imported a stair symbol from a 2018 project in which the Stair Run worked fine.  In this file that stair is a 3D symbol in which there is a solid, and that solid includes four instances of the Stair Run.  If you work your way down to the Stair Run, it should exist as expected, with its many fields in the OIP.  When I changed the number of Risers for one of the Stair Run objects in the OIP, it farted.  I didn't do that in this file because the previous file I did that in now immediately crashes VW 2018 when I try to open it.


In File 05, and in the original project file, there's no Marionette plug-in object in the Resource Manager; only just the Network symbol.  I can't recall how one otherwise goes from a network symbol to a Marionette object...  In any case...


File "06-VW2018-Stair Run-05.vwx" is a copy of File 05.  In this file, I imported the "44-Stair Run" Marionette plug-in object from my Marionette Library file.  When asked if I wanted to replace the "Network Symbol-Stair Run" I selected no; use the existing one.  When I then placed an instance of the Stair Run in this file, it worked as expected.  (I changed the Floor to Floor to 12' and changed the No. of Risers to 21).  Hopefully you can similarly make changes; let's call this the "original" file that you're asking for...


Last but not least, File "07-VW2021 Stair Run.vwx" is a VW 2021 file.  Like File 02 it's a brand new blank file into which I imported the Stair Run from my Marionette Library.  It seems to behave exactly like File 02.  Let's call this the "file created upon conversion" that you're looking for.   VWIS209


Thanks!   -Will

02-VW2020 Stair Run.vwx 03-VW2018 Stair Run.vwx 05-VW2018-Project Stair-1801-047W.vwx 06-VW2018-Stair Run-05.vwx 07-VW2021 Stair Run.vwx

Edited by willofmaine
Link to comment


On 3/3/2021 at 9:40 PM, willofmaine said:

Why would Marionette work fine in VW 2018 back in the year 2018, but not here in 2021?!?!...


i do have the same problem.
I have a lot of Marionette-Objects, saved as red symbols. Since I installed VW2021 i have a huge load of issues and VW crashes.

If i want to reconstruct this, VW2020 crashes to. demotivating


any idea? some changes in python?

Link to comment

Hi @Marissa Farrell, have you had a chance to look at this?  As you know, I wholeheartedly embraced Marionette when it was first introduced, and I struggled with it for a year or two, repeatedly rejecting it because of its apparently insurmountable issues.  Then, I think with Vectorworks 2018, it finally started working, mostly really well.  And now this.  It's beyond discouraging.  I've tried to import just my network symbol into a blank file to see if I can figure something out.  But I don't get far... no matter what I do, the wires are disconnected.  Is there a "solder wires to nodes" box I've neglected to check?  My recollection is that its first year, maybe two, wires stayed connected, and scale wasn't an issue.  Now, even if I'm careful to always work at the same scale, wires are all over the place anyway (and if I don't stick with the same scale, the nodes are either stacked on top of each other or spread really far apart... in which case the wires don't stand a chance).  Is my use of symbols for networks a problem?  What am I missing??  Thanks!   

  • Like 1
Link to comment
  • 2 weeks later...

@Marissa Farrell Hello?...  I recently found that when I remove network symbols from my Marionette objects, they then seem to work.  But symbols have their benefits, and I'm pretty sure they were recommended when Marionette was first introduced; hopefully I didn't misunderstand something.  Looking at a couple of @DomC files ("Wonderful Marionette Door" and  "3D Window with 2D content, wall hole and stone curb") it looks like he uses symbols with few issues.  I finally got one instance of his window to fail, but, initially when I edited the script and symbol, everything was a mess - not only were wires entirely disconnected - but nodes were even different sizes/different scales - yet the Marionette window object appeared to keep right on working as expected.  Today, when I tried to import one of my newly "de-symbolized" Marionettes into a blank file, again, it failed.  Eventually, and for at least a couple of different Marionettes, I found that I could successfully import them into a blank file if I did it directly from an open copy of my Library file, rather than through the Resource Manager "Favorites" file.  So I don't know.  Are symbols the problem?  The Resource Manager?  A library file created in an earlier version of Vectorworks?  The phenomenal potential and promise of Marionette make this all the more frustrating...  Thanks.

Link to comment

I think, there is an issue, that red symbol or symbols cotains Marionette networks and the symbol was edited last in another layer scale then it well be interted the network ist disconnected. Not looked deeper in this but this seems that this could be the issue in this situations. It seems already reported as a bug.

Link to comment

Thank you ( @DomC ); good to know it's not just me, then.  Seems like this has been an issue for a very long time...


Your "Basic Reshape SolidScale" node ( https://forum.vectorworks.net/index.php?/files/file/106-basic-reshape-solidscale-in-xyz/ ) is absolutely fantastic!  Thank you for sharing that!  I have a couple of very complicated (and now dysfunctional...) networks for creating (much simpler...) door and window trims.  I appreciate that there's a tremendous amount of code in that node of yours, but it sure does make for a far simpler and far more capable Marionette object.  And I just found that I can use a 3D symbol as the control geometry, which is major.  Thanks!


Edited by willofmaine
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...