Jump to content

Problems with Lightwright Data Exchange


Recommended Posts



It's been a while since I've drafted anything - since there are no shows.  This is my first time working with 2021.  I'm trying to create a new file that can talk to Lightwright.  But I can't get VW2021 to make the .xml file that Lightwright is looking for.  In the past, I would create the .xml file using the Spotlight Preferences.  But the file has not appeared.  I tried giving it a custom location - nothing.  So what's going on?

Link to comment
  • Vectorworks, Inc Employee

Start with the basics.

Make sure the file is saved to your local machine that is not a shared folder like Dropbox. (Use a simple name for the Vectorworks file.)

Make sure there are lighting devices placed in the document with data.

In the Spotlight Preferences make sure "Use automatic Lightwright data exchange" is turned on.

File Path is "Same location as the file"

Check, "Perform a complete export on exit"

Make sure there are field shown in the "Export Fields" list.

Click OK.

Select a light and change one of the fields that you are exporting. (Should not be necessary but it's another way to make sure it exports.)


You should see an xml next to the Vectorworks file.

If you still don't see it it would be useful to know the full path and file name of the Vectorworks file.

Link to comment

Nope.  Didn't work.  I'm starting from a new file.  I created a light just to get it started (I usually start in Lightwright and import the info into VW).  The file is stored on my hard drive.  


The File name is Megs Demo.  The file path?  Desktop>Megs Demo>File



Link to comment
  • 4 weeks later...

I was having a similar problem with Vectorworks 2020 not creating the xml file. I would go to spotlight preferences, click on export on exit....and nothing. Your hint about the slash in the folder name made me decide to save the file in a new location (just in Documents) and presto! created the xml, linked right to LW6. The folder I was saving in was inside a folder with a / in the name! Never had that problem before, but I can change the folder names to prevent in future. Thank you!!

Link to comment
  • 1 year later...
  • 5 months later...
On 2/24/2021 at 1:56 PM, jarnold2 said:

Never mind - I think I found the problem.  I forgot that Vectorworks freaks out when the file is located in a folder with a name that includes non alphanumeric characters - the file was originally in a folder with a / in the name.

Thank you SO much for this. I couldn't get an .xml file to generate for my file in VW2022, and eliminating "/" fixed it for me.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...