Jump to content
MrPilot

line types applied to solids / 3D objects

Recommended Posts

Hi everyone, did any of you manage to assign and display a dashed line on a 3D solid (except for hidden edges)?

 

The line type selection seems to be ignored by 3D solids (working in VW 2021) – in the attached screenshot, both objects have the same attributes; the solid is simply an extrusion of a copy of the rectangle:

 

Screenshot 2021-01-13 at 12.40.44.png

Edited by MrPilot

Share this post


Link to post

Here are some more tests: simple extrusions display properly (here shown in all sides mode), wheareas e.g. a subtraction looses the ability to display line types:

 

Screenshot 2021-01-13 at 16.41.16.png

Share this post


Link to post

Hi MrPilot,

 

at first I could not reproduce your picture in wireframe, but I guess you used hidden line or dashed hidden line rendering. In Hidden Line the dashed lines  mix up as they are either on the backside of the objects, or they use the Line Type of the extrude.

As far as I know, there is no "regular" way at all to show 3D objects with a Line Style. Extrudes seem to be an exception.

But you are right, it is not logical that extrudes can have Line Styles in hidden line rendering, while solid additions or subtractions can't. I'm not shure, but I think this problem exists since VW 2020.

Share this post


Link to post

Hi halfcoupler,

 

thanks for your reply and checking this on your side!

 

Yes, indeed this worked for me in a shaded / hidden / dashed hidden view... in both examples, the bottom case is the intended result, whereas the top is the incorrectly displayed object after a subtraction has been carried out.

 

Quote

As far as I know, there is no "regular" way at all to show 3D objects with a Line Style. Extrudes seem to be an exception.

 

Hm, this seems strange. Logically, if the extrude is displayed in a [correct] manner, then so should be other solids, especially that line type selection is available for these objects as well. I thence consider this to be a bug.

 

Quote

 I'm not shure, but I think this problem exists since VW 2020.

 

Meaning solids would also display line types correctly in earlier versions?

Share this post


Link to post

 

On 1/14/2021 at 12:04 PM, MrPilot said:

Meaning solids would also display line types correctly in earlier versions?

 

Just checked it on my old laptop with a VW 2018 version:

 

It seems to be the other way around: In VW 2018 neither extrudes nor other solids could have a linetype. It seems that the possibility for extrudes to have linetypes appeared later, in one of the last 3 Versions. So indeed, for this time it's not a bug, it's a feature.  🙃

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...