Jump to content

Devices holding unselectable socket information in transition from 2020 to 2021


Recommended Posts

Hey there, wondering if anyone else has experienced this, or has a better workaround than rebuilding all the blocks. I submitted this to Service Select portal, but haven't heard of a workaround yet, so we've been sticking on Vectorworks 2020. 

We've switched to ConnectCAD this past year and have built a pretty extensive schematic block library of our own, to add a bit more of a polished look. However, the blocks we've built, when opened in Vectorworks 2021 from 2020 seem to hold extra information in the 3d layer that is not selectable nor deletable. Screenshots below to explain it a bit better and a couple example files.

Would love any help, and also to know if there's any cautionary thoughts to consider with the roadmap of ConnectCAD and not losing, or having to redo all the work we've put in to our own custom blocks. 

Screen Shot 2020-12-14 at 7.46.48 AM.png

Screen Shot 2020-12-14 at 7.46.36 AM.png

Screen Shot 2020-12-14 at 7.46.17 AM.png

Test File 2021.vwx Test File 2020.vwx

Edited by TLeatherman
Link to comment
  • Vectorworks, Inc Employee

Hello @TLeatherman,


I was able to reproduce your issue with Test File 2021. I cannot tell what exactly is happening. The devices that cannot be selected appear twice in the drawing, which is strange. The way to fix this is to select all objects using Ctrl+A or Select all sockets using the select similar tool and make some change to the objects, such as setting of layer plane to Layer, so that the objects reset and get fixed by themselves.


I have tried reproducing this by opening the 2020 file in VW 2021 and was not able to. What is more, I have tried opening the 2020 file in VW 2020, saving it and opening it in VW 2021 and the issue was not there again. So it seems like you might have done some additional steps to get to here? Do you remember anything additional or can you try to reproduce this starting from the 2020 file?


Best Regards,

Nikolay Zhelyazkov

Link to comment

Thanks a lot for the response Nikolay. 

So after your response I tried opening up the 'Test 2020' file in 2021 and I still get the extra socket information. I tried clearing preferences and reinstalling 2021 to see if that may have been a factor and it still opens up the file with the extra sockets in 2021. I also didn't experience the changing layer reset as you described. When I changed layers on the design or device layers neither reset the sockets. 

However, after the reinstall - whether it was the newest service pack or the fresh install, the sockets are selectable and are able to be deleted in the 3D device layer. After deleting and re-saving the symbol all seems to work well. Still strange, but I'm just thankful to have a workaround. 

Thanks a lot,

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...