Jump to content

Hidden line render mode issues with window IDs & surface hatches

Recommended Posts



I'm having trouble with a few display issues in my hidden line elevations. These seem to only show up in hidden line render mode, not in OpenGL (I've attached a PDF of both to illustrate the issues).


  • Issue #1 The surface hatch of the  siding is missing on part of the elevation (PDF attached). The wall itself is continuous, but the texture is getting interrupted for some reason (shown in pink in attached PDF)
  • Issue #2: window IDs - the window ID text is missing from the East and some South windows. The ID hexagon is there, but the text is missing (shown in green in attached PDF). I checked and the ID text class is turned on. The second window ID issue is that some window IDs from the opposite side of the building "ghosts" through the building  (shown in cyan in attached PDF).


Any idea what might be causing these issues in hidden line render mode?



Elevation window ID issue_OpenGL.pdf Elevation window ID issue.pdf

Share this post

Link to post

No responses yet... Could someone please help me out here? I have the same issue in multiple files, and I'm stumped as to why it is occurring. I just installed the latest service pack, but the problem persists (VWX 2021 SP 2.1)


Any help would be much appreciated!


Share this post

Link to post

@EvelyneB  Not sure why but the hidden line hatch works in an elevation (front, back, left, right) view.  Not sure why it fails in a section view.  But if you try that viewport as a back view rather than a section it works.


You might also want to check "Use World Z for Origin" in the render tabs for the walls to make sure the texture bridges the first and second floors.

  • Like 1

Share this post

Link to post

Are there any solutions to this that have been shared?


I have a similar problem - one wall type shows the surface hatch in hidden line elevation VP - other different walls do not.


settings seem to be the same for the various walls -ie in OIP - render by component.


wall components seem to have same types of settings appropriate to their surface/material...


display surface hatch on in background settings.


classes are on....what to try next?


Share this post

Link to post

@niagara designer can you post the file and some screenshots showing where the problem is?


@EvelyneB Can you reveal how you resolved your issue? I also recently noticed some issues with window ID not displaying correctly in Elevations created from section viewports. The problem went away when I used a standard viewports in Front, Back, Left and Right views.

Share this post

Link to post

To fix the window IDs, I check the box for "Display 2D fills" in the viewport's OIP.


Unfortunately I haven't found a solution to fix the triangulated interruptions in the textures. A Vectorworks employee contacted me and this seems to be a glitch. The workaround is to draw in the missing patches in annotation with a polyline with a hatch fill and carefully align it to the rest of the wall's texture. Needless to say, it's a huge pain and does not update automatically if anything changes in the model, but it's all I've found for now.

Share this post

Link to post

Thanks, I hadn't noticed the "Display 2d Fills" check box.


I had a play with your file and found that if you delete the wall bottom peaks it seems to resolve the issue:





Edit: I see though you want a bottom offset. So instead of using a bottom offset, with the wall selected, use the reshape tool to drag the bottom of the all down. This gives the same look but no "bottom offset". Alternatively something else that might work is use another wall style that has the btm offset as part of the actual style. This way might be better as just the cladding can have the bottom offset rather than the whole wall.


Edited by Boh
  • Like 2

Share this post

Link to post

thanks everyone - I found the problem with the hidden line surface hatch not showing .

feel like a dummy - I had to edit the actual wall styles in the RM - the siding components had a default setting for the class material of steel for some reason...

I was sure I had checked that, but...guess not.

thanks again

  • Like 1

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...