Jump to content
  • 0

3D disappears when switching from 2D

Sebastiaan Devos


Recommended Posts

  • 0

Still a bit difficult to tell from the video... Here are some things to try, but these are just guesses:


-Go to the View menu and make sure "Clip Cube" is off. The Clip Cube is a way to hide portions of a model in order to focus on whatever geometry is within the Clip Cube. I sometimes don't realize it's on which can make it seem like everything disappears in 3D views, when actually the Clip Cube is on and is outside of my screen somewhere.


-Does the issue only occur with the Flyover tool? What happens if you use the Views dropdown and go to Front, Side, Right Isometric, etc.?


-Have you tried doing "Zoom ob objected" in the 3D view once everything seems to disappear?


-Is there actually true 3D geometry in the file? Or are you simply expecting to see planar objects on the ground plane as you orbit around? If it's just planar geometry, it's possible that the objects are on Screen Plane and the Unified View options are set to hide Screen Plane objects in 3D views. This can be checked by going to the View menu > Unified View options. Make sure Display Screen Plane Objects is checked. They still won't behave as 3D objects, but at least they won't disappear. You'd still have to select the geometry and change the plane to Layer Plane for each object (there's a script somewhere on this forum to help with this if it's indeed your issue...). If you know the file is an actual three-dimensional model, ignore this paragraph completely.


-Have you had success viewing 3D objects in other files?

  • Like 2
Link to comment
  • 0
  • Vectorworks, Inc Employee

The object sin the file appear to be located at four very different z-heights.  I think Vectorworks is trying to center the view on all of these objects but they're location is so far apart that the view is somewhere in between all of the objects.  Here's all selected objects in Front view.  Notice the current zoom is WAY out showing at 0.0000%.  Moving these objects to the same z-height will probably correct the problem.



Link to comment
  • 0
  • Vectorworks, Inc Employee

I threw together a quick script to try to fix the file.  It acts on all selected objects and sets their z-heght to zero.  Try importing the DWG file into a blank file, Select All, then run the script.  Things should then work as expected.

DISCLAIMER:  Please do make sure the results are as you expect since this script has not been throughly tested.


Set Sel Obj Z-Height to Zero.vs

Link to comment
  • 0
  • Vectorworks, Inc Employee
14 hours ago, Christian Fekete said:

@Matt Panzer Matt, here is a simple file with a fridge provided by VW. It shows in plan but i no other views. Can you explain how to change that?

Thank you

SPACE PLANNING.vwx 21.7 MB · 2 downloads


Hi @Christian Fekete,


I don't know how the objects in the symbol got into the state of being invisible, but the following steps bring them back for me:

  1. Edit the 3D Component of the symbol
  2. Select All
  3. Use the Move command to move then by (0, 0).  This is an old trick I use that triggers a reset in most (but not all) objects.
    Note:  The objects will still be invisible.
  4. Exit the symbol and everything should show as expected (even when editing the symbol again).
Link to comment
  • 0

I'm not sure I know what's going on.


I copied and pasted it into a blank document.  It worked normally.


I copied and pasted it back into your document.  It didn't work.


I went back to the new document, edited the 3D part, copied.


Back in your document, I edited the 3D part, select all, delete.  Paste in place.


It worked.


Can't explain it.

Link to comment
  • 0
  • Vectorworks, Inc Employee
1 minute ago, Christian Fekete said:

@Matt Panzer this is an ongoing issue with my latest 2021 drawings. Should I reinstall?



Do you mean the object later disappears again?

If so, can you reliably reproduce the problem?  If so, know the steps to reproduce will help us fix the issue.


I'm not sure reinstalling will help (but it's possible).


Before reinstalling, I usually try this:

  1. Quit Vectorworks
  2. Rename your Vectorworks User folder (eg:  Rename the Vectorworks user folder "2021" to "2021-BAK").
  3. Run Vectorworks and see if the problem is gone.
    Note:  A fresh VW User folder will be created.
  4. If the problem is gone, if you have files (workspaces, thrive party plug-ins, etc.) you want to move back from the renamed user folder, try moving them one at a time and restart VW to see if the problem returns.  If it does return, this will give you a good idea what file is causing the problem.
Link to comment
  • 0
  • Vectorworks, Inc Employee
1 hour ago, Christian Fekete said:

This happens on different files, this is not always the same process I go through but in both cases when I change views from VP to design layer or from floor plan to 3D open GL. Generally looking at 3D


Unfortunately, there's not much we can do until we find a way to reproduce the issue.  However, I'll keep an eye out for this issue and see if I can come up with a reproducible case.

Link to comment
  • 0

@Matt Panzer Here is another simplified model for you to look at. When you open the drawing you will find selected, a ghosted piece of lumber, but this item and others will show up in wireframe mode. This ghosted lumber piece shows as a solid addition. When you open it and try to close it that there is a message indicating an impossible addition. This may be an issue but what about the other missing items, 

I have other files with entire parts of drawings showing the same (or rather not showing ). Could it be an issue with OpenGL rendering?Untitled 1.vwx


Edited by Christian Fekete
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...