Jump to content

Roof Style Glitch


genie

Recommended Posts

I built my roof with roof faces as I can't figure out how to manipulate the roof to be the way I want it with "Create Roof".  As I assigned one of VW roof styles to my roof,  a random roof face would be missing a component.  See highlighted roof face image. All the roof faces are of the same roof style, all rendered by components. I tried changing all to "unstyled", and another roof face would lose its component. Not sure what went wrong.  TIA!

image.thumb.png.2b928799c2b1f020281be685c00e0d70.png

Link to comment

Go to top/plan.  Double click the roof face that is causing problems.

 

Inside you should find (hopefully only) one polygon.  Double click that polygon or invoke the reshape tool.  Check to see if there are extra vertices you don't need.  Especially any vertices that double back on themselves.  Remove any extra vertices.

 

If that doesn't work try drawing a new polygon over the existing polygon and deleting the original.

 

If you don't see one polygon but instead see a ghost polygon and another roof face (I haven't seen this happen yet in 2021, but it used to happen to me in older versions).  Then copy the polygon if you can, delete the roof face, paste the polygon, and start over :-).

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...