Jump to content
  • 0
Stéphane

Surface hatch only in black ?

Question

Hello, 

 

My surfaces hatches (associated to a texture) in "lines only" (edit: "Line" in foreground render) are shown and printed in black, but they are in fact colored. Why ? 

Edited by Stéphane

Share this post


Link to post

21 answers to this question

Recommended Posts

  • 0

If I have openGL as a background render and Hidden Line as a foreground render setting I am seeing colored hatches fine. Are you seeing any colored hatches using Hidden Line at all in any Background/foreground configuration?

 

 

Share this post


Link to post
  • 0

I believe surfaces hatches associated to a texture are generated in "Line" and "Hidden Line". So it must not depend to the background render you are using. 

My other hatches show up fine (for instance the ones I am using for my slabs and walls). 

Edited by Stéphane

Share this post


Link to post
  • 0

Surface Hatches can only be seen in Hidden Line render style. When you say "Line", do you mean "Wireframe"?

Share this post


Link to post
  • 0

To elaborate a bit

 

There are two types of hatches

- Regular hatches 

- Surface hatches that are regular hatches associated to a texture 

 

In my VP I have only a Foreground render which is "Line". No background render. 

In it, my regular hatches are fine and colored, but my surface hatches are always black. The textures itselves don't show up which is the normal behavior.

Share this post


Link to post
  • 0
1 minute ago, markdd said:

Surface Hatches can only be seen in Hidden Line render style. When you say "Line", do you mean "Wireframe"?

 

No, Surface hatches can also be seen in Line render style. When I say "Line", I don't say "Hidden line" which is another Foreground option. 

Share this post


Link to post
  • 0
Just now, Stéphane said:

No, Surface hatches can also be seen in Line render style. When I say "Line", I don't say "Hidden line" which is another Foreground option. 

Not in my experience. I think you may be mistaken. Happy to be proved wrong though.

Share this post


Link to post
  • 0
2 hours ago, Stéphane said:

In my VP I have only a Foreground render which is "Line". No background render. 

In it, my regular hatches are fine and colored, but my surface hatches are always black. The textures itselves don't show up which is the normal behavior.

@Stéphane I'm not sure what you mean by 'Line' render mode either can you post a screen shot? Surface Hatches only come into play with Hidden Line rendering. I'm not sure why you'd specify a Foreground Render but no Background Render. In my understanding Background Render is the default + Foreground Render only comes into play when you want to do something like overlay Hidden Line over Open GL as in @markdd 's example - no? 

 

Share this post


Link to post
  • 0

 

Ok, there might be a huge translation issue, since I'm using the French version. Sorry for that, I should have checked this before. 

In my version, I have three Foreground render options : 

 

- "Sans" : None 

- "Lignes visibles uniquement" : literally "Visible lines only" which must have been badly translated since it is actually "Hidden lines" in your version. 

- "Lignes cachées en pointillé" : literally "Dashed hidden lines". 

In other words when you spoke about "Hidden lines" I thought you were speaking about "Dashed hidden lines" and when I spoke about "Lines" I actually wanted to speak about "Hidden Line". 

 

So, now we know that we speak about "Hidden lines".... 

 

To clarify and to answer to @Tom W. and @markdd

"Hidden lines" can be used as foreground or background render. Of course, when no foreground render is used, then I use "Hidden lines" as a background render. In both cases, my surface hatch is black. Why ? 

 

Please, see below a screenshot. 

 

 

 

525589547_Capturedcran2020-11-1214_59_14.thumb.png.1c611d9ebadd16d4b455e7c1319de435.png

 

Share this post


Link to post
  • 0

Ok that makes more sense thanks for explaining.

Is the issue not simply the fact that Hidden Line rendering is black + white by default? So whilst a hatch may have a line or fill colour, once it's assigned as a Surface Hatch it will by definition only show as black + white?

Share this post


Link to post
  • 0
37 minutes ago, Tom W. said:

Is the issue not simply the fact that Hidden Line rendering is black + white by default?

 

If you speak about "Black and White Only" found in Advanced Section Viewport Properties, sadly not; I checked it. 

Share this post


Link to post
  • 0

As I said. I am not getting this issue. I have a slab object with a Red Surface hatch. It is rendered in Hidden Line.

 

Here is a screen shot:

 

868583215_Screenshot2020-11-12at16_42_13.thumb.png.b41b25c4fb6e6c51f2cbed428a169876.png

 

Here is the file.

Hidden Line Surface Hatch.vwx

 

If you can share file then I could take a look for you....

Share this post


Link to post
  • 0

Stéphane

Vous parlez très bien anglais! :-)

Yeah, I created that same scenario and used a hatch with sort of an orange color, and it seemed to work fine, associating that colored hatch to the texture, when rendering in hidden line, on a design layer, as well as a viewport on a sheet layer.

Do be mindful that you do NOT need to select 'hidden line' as a 'foreground render' but only using the 'background render' option.

 

58819862_ScreenShot2020-11-12at7_04_10AM.thumb.png.019139e07b06f5586598ba5058ac3dc5.png

 

Share this post


Link to post
  • 0

Perhaps, if the file is not too big, you could send it to one of us and see how it appears on our end.

Or, just create a new blank file and copy and paste the items(s) that are causing the problems which would be a much smaller file size.

Share this post


Link to post
  • 0

It looks like you're viewing a Section Viewport with the Advanced Properties>Attributes>Line Style set to something other than 'Use Original'

  • Like 2

Share this post


Link to post
  • 0
32 minutes ago, bcd said:

It looks like you're viewing a Section Viewport with the Advanced Properties>Attributes>Line Style set to something other than 'Use Original'

 

That was it ! Well done @bcd

For Objects Beyond Section Plane in Advanced Properties>Attributes, I used "Use Class". 

 

But I have now another issue...

 

My class attributes are set to have their section style. So I need the "Use Class" option in order to lighten the line weight of objects that are beyond my section plane. This is a super nice way to have an accurate control of section line weight class by class. If I choose "Use Original"  for Objects Beyond Section Plane, off course they will appear too thick. So here is my question : What is the best practice ? 

 

I find the other options not very handy to control section line weight. 

I know there is the option "Create Structural and Nonstructural Groups" but that get me two line weight. I need at least three different section line weight. One for structural elements. One for non-structural elements. And one for small or thin elements, like frames/glass/tiles. Plus, it removes the components hatches, if Im not doing it wrong. 

Edited by Stéphane

Share this post


Link to post
  • 0

Stéphane

I found the problem....

You need to select 'use original' NOT 'use class' in the advanced properties, attributes options.

Try it in your file....

 

Screen Shot 2020-11-12 at 7.54.04 AM.png

  • Like 1

Share this post


Link to post
  • 0
4 minutes ago, Kevin K said:

Stéphane

I found the problem....

You need to select 'use original' NOT 'use class' in the advanced properties, attributes options.

Try it in your file....

 

Screen Shot 2020-11-12 at 7.54.04 AM.png

 

Yes, that was it, thank you !

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...