Jump to content

DMX viewer does not work with sACN

Recommended Posts

The DMX viewer does not display sACN levels. The model works fine; all fixtures are controllable via DMX; the diagnostic DMX Viewer does not display levels.


DMX provider correctly selected:



Here is the DMX viewer window compared to sACNView window:



Anyone else seeing this?


VWX2021, Vision2021, MA3 Light







Link to comment

@TomWhiteLight  Vision 2021 on Windows 10. Perhaps I'll try on a Mac if the licensing scheme allows it... I know i can install my E-license of VWX on two machines but haven't tried that with Vision yet.



34 minutes ago, klinzey said:

Try setting the Vision DMX provider to sACN, quitting Vision and then relaunching, then opening the DMX viewer.

I think I have seen issues where the DMX viewer doesn't work when you change DMX providers.



Quitting Vision does not quit the DMX viewer; it runs in a separate process. Each time the DMX viewer is launched from within Vision, it opens up another DMX viewer window and they all stay open when you quit Vision.


Each and every time DMX viewer is called, the DMX provider menu defaults to Artnet and changing it does not seem to have any effect.


Again, the model is receiving sACN DMX as is an independent app (sACNViewer). Just can't get the Vision DMX viewer to work over here...






Link to comment
  • Vectorworks, Inc Employee

Hey AJ,

Could you try setting vision to artnet, and then launching the DMX viewer with sACN? So, you'll have Vision set to artnet, the DMX viewer set to sACN, and the MA sending sACN as you have been. I'm wondering if something is causing Vision and the DMX viewer to be looking at different things. In the past I'm seen Vision not be able to pick up an interface because a third party software had taken exclusive control of it. Essentially, I'm wondering if something is blocking, and/or not sharing with, the DMX viewer, and the easiest place to start is by getting Vision out of the way.


If you still don't see any DMX in the viewer, then it's either a third party blocking the viewer or something funky with the way MA3 is sending sACN. If you switch everything to use artnet, that should probably give us a better idea of what's going on. If the viewer is still not showing anything, it's most likely a third party issue. Antivirus, firewall, windows UAC, or maybe some other DMX monitoring software you have. Windows loves to block things without notification. If it operates normally, it's probably something with the MA. Sorry if this is kind of all over the place. These kinds of issues are the worst to troubleshoot, because there's so many variables.

Link to comment

@Mark Eli Hi Mark, and thanks for looking in to this for me!


I haven't had a chance to try Artnet... honestly it's a bit harder to configure than sACN which just lives in the same network and IP range as MA3net. Too much to do on a current project... i can dig in to that after Thanksgiving. I use the DMX viewer to verify signal if the model isn't working quite right, however it doesn't seem to fulfil that role now...


I just have to question that the MA3 is doing something "funky" with a standard protocol. The Vision model sees the DMX. The app sACNView sees the DMX. The Pathport that receives the sACN and relays it to the fixtures just loves that yummy data from the MA3. In this case, DMX viewer is the only part of the system that seems not to be listening. 


It is also interesting that the DMX viewer does not default to the selected DMX provider when launched, nor does that option come up first in the drop-down menu. Of course that's probably an alphabetical thing?


sACNView is a useful little tool: https://www.sacnview.org



Link to comment
  • Vectorworks, Inc Employee

Yeah, Artnet has always been a bit of a pain to set up. If it's not something you want to deal with, I wouldn't blame you. My thought process is always to try to narrow down possible causes. If Artnet works as expected, at least we know it's specific to sACN. If it doesn't, then we're probably dealing with some outside cause. At least that's the idea. Whether or not it's worth the effort to do that, is entirely up to you.


One thing you may try, the DMX Viewer is in the Vision Program folder. It's a standalone application, so you can launch it without starting Vision. That's why it doesn't default to the DMX provider that Vision is set to. The two programs are essentially unaware that the other exists. By starting the viewer without Vision, it should do two things for us. If Vision is somehow causing the issue, Vision isn't running to cause it and the viewer should see the sACN stream. If Windows is blocking the viewer from working because it's being launched by another application, starting the DMX viewer directly should stop that. If it still doesn't work, then the only real possibility is some kind of third party interference, or the MA3.


Yes, I agree the idea of the MA having weirdness sounds crazy. It's far from likely, but it is a possibility. MA3 is still very new, and new things love to do unexpected things. I've actually had a similar situation in a personal project several months ago. I was using sACN in a program I was writing, and Vision wasn't seeing the stream and neither was the viewer. I did the exact same thing you did, and fired up sACNView, which saw the stream without issue. Unfortunately, it's been long enough ago I can't remember the exact cause. From what I remember I had set one of the bits high when it should have been low or something similar. Either way it was enough that the DMX Viewer had decided it wasn't an sACN packet and ignored it, but sACNView had no issue. Obviously, the MA engineers do a way better job than I do, when I'm goofing around on the weekends but, anything is possible.


One of our guys should have an MA3 now. Hopefully he will be able to either reproduce the issue, or give us a different perspective on things.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...