Jump to content
WANA

Hatch Rotation in Top/Plan

Recommended Posts

See attached three images of the same geometry - two roof faces and one roof object with two different textures on for reference. The images are in Top/Plan, Hidden Line and Open GL rendering mode. 

 

Can anyone tell me why on earth in Top/Plan the surface hatch won't behave in the same way as in the other two modes? The other two modes show clearly that the geometry, texture and surface hatch is working how I want it to so it just baffles me and messes with our viewports which would usually be in Top/Plan. 

 

Any help gratefully received before I pull what remains of my greying hair out... 

Screenshot 2020-11-04 at 14.39.07.png

Screenshot 2020-11-04 at 14.39.16.png

Screenshot 2020-11-04 at 14.42.39.png

Share this post


Link to post

A surface hatch only displays in 3D. In OpenGL you see the texture; in Hidden Line you see the surface hatch. The surface hatch is like a black + white line version of the texture.

Top/Plan is a 2D view so here you see whatever 2D attributes you've assigned to the objects. In your case hatch fills.

So in your images the top row is Top/Plan view (2D) + the other two rows are Top View (3D).

What's confusing is the surface hatch displayed on the middle left hand object: you should check the paving texture you used on the bottom LH object + see what surface hatch is assigned to it as it looks like you need to change it from the clay tile one to a brick one.

If i've understood your images correctly

  • Like 1

Share this post


Link to post

Hi tom

 

Thanks for that - makes perfect sense. 

 

Follow up question, without showing plan viewports in 3D I assume there is no way of getting those roof hatches to show correctly without doing a bit of invisible mending within the viewports? 

 

PS The left object is confusing things as its showing material by component on a roof face and the component didn't match... I rushed out an example but you got the gist and helped anyway! 

Share this post


Link to post

Hi @WANA what you can do is start off with a Top/Plan VP then stack a second one on top: the second VP would be in Hidden Line + just have the roofs on it. So the roofs will display with the hatches but everything else will be 2D.

  • Like 1

Share this post


Link to post

This is one of those little things that has an annoying but easy workaround, so it never gets a fix.

 

But there is another way around this, which is to not use Top/Plan view and instead opt for a Horizontal Section. That way you can utilise the surface hatch in you roof texture.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...