Jump to content
  • 0
SamIWas

Phantom old lines showing up randomly

Question

I had imported a pdf, which I ungrouped to get normal lines.  It brought in hundreds of thousands of lines, which of course bogged down the machine.  I deleted all of it.  Weeks later, I'm working on the drawing, and periodically when zooming or performing a move command, these phantom lines reappear for a few seconds before going away.  Being that it's 100,000 of them, it causes a long pause on my MacBook Pro.  I have turned on every class and layer, and the lines are not actually in the drawing.  They are just phantoms showing up randomly.  Any idea how to get rid of these...it's absolutely draining my workflow speed.  I'm starting to think I will have to manually copy each and every existing thing to a new document...

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

How complicated is your drawing? You might try exporting back on version to a VW file and then updating that back to your current version.

 

Is there any specific action that causes the lines to show?

 

Have you tried to Purge unused objects?

Share this post


Link to post
  • 0
11 minutes ago, Pat Stanford said:

How complicated is your drawing? You might try exporting back on version to a VW file and then updating that back to your current version.

 

Is there any specific action that causes the lines to show?

 

Have you tried to Purge unused objects?

 

I just opened this back up to say that I found the issue.  The lines were there, but were covered with a white rectangle, thus not appearing when I showed everything.  I was sure I had deleted them, but apparently I had not.

Share this post


Link to post
  • 0

When you Ungroup a PDF you typically end up with 3 items. A bitmap of the PDF on top. A white rectangle (we think it represents the paper). And finally at the bottom a Group containing all of the vector linework and text that VW can extract from the file.

 

It sounds like you had ungrouped the PDF and deleted the bitmap but not the rest.

 

Glad you found the problem.

Share this post


Link to post
  • 0
3 hours ago, Pat Stanford said:

When you Ungroup a PDF you typically end up with 3 items. A bitmap of the PDF on top. A white rectangle (we think it represents the paper). And finally at the bottom a Group containing all of the vector linework and text that VW can extract from the file.

 

It sounds like you had ungrouped the PDF and deleted the bitmap but not the rest.

 

Glad you found the problem.

Yeah...I've done the deal with PDFs for many years, ungrouping then dealing with the resultant parts.  For some reason, I just missed that they were there since they were hidden and weren't selecting.  

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...