Jump to content
  • 0
jay_coke

Light illumination not Rendering, but does in Open GL

Question

I made a space with lx fixtures in it. In open GL I can see the spotlight on the wall illuminating, but when I render in a renderworks style, custom, final quality, or otherwise, there is no illumination in the space. How can I fix this? 

Light gone cutsom renderworks.png

Light open GL.png

Edited by jay_coke

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

Could be many things, can you post the file or a sample?
The first place I would look are your texture, all Renderworks modes use the cast & receive shadow options set by the texture.

The lighting devices supplied by Vectorworks have the Default Instrument texture applied to the geometry with the cast shadows option unchecked to allow light to come out of the fixture.

Also look for objects in the path of the light that do not have a texture applied, I've seen them act differently in OpenGL and Renderworks when casting shadows.

Share this post


Link to post
  • 0

Thank you for this! Unchecking "cast shadows" fixed the issue. However, I'm only getting soft shadows... I've tried turning off indirect light in the Renderworks style and turning the Soft Shadows option to low but neither are helping. Is there an option for that that I am missing?

Pink Clouds.vwx

Edited by jay_coke

Share this post


Link to post
  • 0

There is a Soft Shadows option for each light source.

If you are using Spotlight run the Set Spotlight Rendering Options command and you can turn off soft shadows for all the Lighting Devices at once.

Share this post


Link to post
  • 0

So Soft Shadows is unchecked... but if I need to Uncheck Cast Shadows to even get light to emit from the fixtures at all in renderings and Soft Shadows is a subgroup of that... then how can I get the shadows at all?

Share this post


Link to post
  • 0

You can leave cast shadows/soft shadows on for the light but adjust the shadows option for the texture(s) applied to the objects.

Fair warning, soft shadows are very soft.

 

Screen Shot 2020-10-20 at 1.26.55 PM.png

You need to use the settings on both the light and the texture to achieve the desired results.  This also means you need to apply a texture to an object, if there is no texture applied the object will be rendered with cast and receive shadows on.

 

Share this post


Link to post
  • 0

All of my objects have an applied texture to them... I would honestly love hard shadows more than anything. As soon as I turn on "cast shadow" for the fixtures I loose all light emitting from the fixtures once I render. Here is a 2021 version

Pink Clouds v2021.vwx

Share this post


Link to post
  • 0

@jay_coke It is what I originally suspected and probably the most common mistake people make when building symbols. The geometry in the lighting device symbol did not have a texture applied so the geometry of the lighting device was casting a complete shadow, not allowing the light to escape from the lighting device geometry. I edited the symbol and applied the default instrument texture to all the geometry in the symbol and then rendered.

Pink Clouds v2021.vwx

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...