Jump to content
rexwexford

what determines a DLVP's position in the design layer

Recommended Posts

hi all me again, design layer viewports, again.. origins again! 

 

2d user here. i'd like to know what determines a DLVPs position within the model space when a user origin is active.

 

the reason for this is because my DLVPs keep flying into strange locations. With traditional referencing when this happens i can make sure my user origin is set correctly, and this normally pulls everything back into alignment. There is also the 'ignore source user origin' to stop the two origins 'adding together' which is often the problem i encounter in other members of staffs files. 

 

with DLVPs you can physically drag the viewport around in the design layer . Is there a way to set it to essentially 'where it should be' ? there seems to be no way of anchoring them. (you an lock them but they move when the origins change) 

 

im really trying to understand the quirks of vectorworks but getting very frustrated everytime the DLVP moves with seemingly no explanation.  

 

many thanks 

Share this post


Link to post

hi all, more fuel to the fire to explain the scenario. 

 

- I have a building plan with a user origin (File 1) ( - 405001813 , - 287134229) this has the building drawn to world coordaintes. 
- I want to reference this via a design layer viewport into another file so i can draw my details over it.  (File 2) This file also has a user origin ( - 405001813 , - 287134229) 

 

File 2 has been working for a few months with several reference updates. When i created the DLVP, it was in automatically in position and i thought all was well. 

 

Now, however when I updated the dlvp the last time it moved position. (screen shot A . It is appearing correctly except its location and is  deliberately pixelated for uploading to this forum)

 

If i select the DLVP, the properties panel shows its x & y as matching the user origin numbers but does not have the negative value infront of it numbers. if you look at the cross hairs it is clearly nowhere near the origin. This is the crux my problem. 

 

If i manually move it back into correct position (re the crosshairs) it becomes correct again in the properties box but this doesnt seem very scientific. 

 

To me, it seems to be the issue of the two origins adding up. On a traditional reference you can set it to 'ignore source user origin' but i dont have that option here. 

 

What i would like to establish is 

1) what controls /overides a DLVP's position

2) what would cause it to move in the first place?

3) what determines where a DLVP is positioned when you first create one. 

 

Im hesitant to physical move the viewport as i have several files like this and dont want the same fate to happen to them, and end up moving all my viewports manually each time this happens

 

many thanks for your time and sticking with me

 

 

 a.jpg

b.jpg

Share this post


Link to post

bump. 

can i clarify any more? anyone else had this issue? 

sorry to be persistent. its really troublesome at present and i dont know how to correct. 

thanks again 

 

Share this post


Link to post

bump. 

if ive encountered an issue that nobody else has come across before, can anyone please suggest my next port of call?

 

thanks

Share this post


Link to post

I will try to answer your questions. I am assuming you are concerned with referenced DLVPs, so I my answer will be for referenced DLVPs.

 

1) What controls its position is the position of the original objects in the source file, any movement done to the DLVP (by dragging or by setting the x,y,z values on the OIP) and user origin changes.

2) I assume when you ask what would cause it to move, that you mean after you update the reference, it is in a different position. I think there are two possible causes. Obviously if the original objects in the source file were moved, it would move. Secondly if the user origin of DLVP's file was changed. For an example of the second case, I had a referenced DLVP and its center was at -100', 0 (xy). The user origin of the file was offset from the internal origin by 100', 0. I edited the user origin so it was offset from the internal origin by 120', 0. The DLVP did not move with respect to the page, but now its center was at -120',0. Then I updated the reference. The DLVP moved with respect to the page, so its center was back at -100', 0.

3) When you first create a referenced DLVP, the coordinates of its location should be the same as that of the original objects in the source file. For example, in the source file, I had some walls centered around -50', 0. The user origin of the file was offset from the internal origin by 50', 0, and the walls were at the center of the page. I created a referenced DLVP in another file, where the user origin of the file was offset from the internal origin by 100', 0. The center of the reference DLVP was at -50', 0, but it was 50' from the center of the page.

  • Like 1

Share this post


Link to post
13 hours ago, Bruce Ferguson said:

 

3) When you first create a referenced DLVP, the coordinates of its location should be the same as that of the original objects in the source file. 

 

hi bruce thanks for taking the time to respond in such a detail manner. 

a lot of what you have said made sense to me, and i suppose has also made me realise that i could have stated somethings in my original post better. 

the DLVP is moving in the reference file when i update the reference, but the origin of both files is staying the same, and im not physically moving the DLVP around in space the design layer of the reference file or the source file. The point you make (highlighted bold above) is how i understood DLVPS to work and that is how i set up my file so it was originally 'correct' and this is what i have formed the basis of my drawing around - when it then moves it becomes problematic.  

strangely, sometimes it is located correctly when i open the file, and other times its not in the correct location but im not moving it in either instance. does this sound like a glitch? 

Share this post


Link to post

after confirming that the DLVP's position is determined by 

- origin in source file + object positions
- origin in reference file 

 

i need a strategy (other than dragging the DLVP) to make it return to its correct location. 

 

is there a way to tell the DLVP to return to its original position, or resetting the dlvp without re-creating it? If it is glitching or has somehow been moved unknowingly it would give me a method to implement to correct it 

 

thanks

Share this post


Link to post

If the source file and the target file have the same user origin, then I believe you would want to set it to the opposite of the user origin. So if the user origin was offset from the internal origin by 50', 25' (XY), then the location of the DLVP should be -50',-25'.

For VW 2020, the OIP for the DLVP has offset X, offset Y, and offset Z instead of X, Y, Z. Also the offset is not affected by the user origin, so to set it back to its original position, you would always set offset X, Y, Z to 0,0,0.

  • Like 1

Share this post


Link to post

To add to observed issues with DLVP's lining up - I regularly reference external files while drawing lighting designs. Both venue and set plans are external so I always have the most up to date version in my plan. Previously I just had to make sure the internal origin's lined up, set the user origin to the internal origin and everything works. Now with VW2021 this is no longer the case which has me pulling my hair out. Which I don't have much of. Happy to lose it if it means my DLVP's line up again.

 

Correction - It seems my user origins are drifting when updating the file to 2021. Resetting the user origin the internal origin has fixed the problem and I get to keep some hair.

Edited by MattLXdesign
I was incorrect about the user origin and internal origin being lined up. Which was unexpected as when the files were last saved using VW2020 this was true

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...