Jump to content
  • 2

Invisible truss in VW2021



20 answers to this question

Recommended Posts

  • 0
3 minutes ago, Mark Aceto said:

@MartinBlomberg  What about None class? If I turn off the None class, I lose all my truss objects (kind of like the 0 class in ACAD). As a troubleshooting step, I would turn on every class. I've been working with a ton (pardon the pun) of truss in my test file with no issues.


OK, I see that None is turned on 😄


Tried that one too 😃 I tried to edit all the trusses and assign them to another class then "None" but no change...

Link to comment
  • 0

Have you tried quitting and restarting VW? This is exactly the sort of unexpected behavior warning sign of "I'm about to crash" that I would heed.


BTW SP1 is out now (I don't see that issue logged though):




Not for nothing but my test file was created in VW21. I also didn't migrate anything from VW20 to my VW21 install, so everything is so fresh and so clean clean.


Edited by Mark Aceto
Link to comment
  • 0
18 hours ago, Mark Aceto said:

Does it behave this way when using the Insert Truss tool vs alt-dragging the object?

Yes, the same either way


18 hours ago, Mark Aceto said:

What are the modes selected of that tool?

Just the standard insertion. Although, it works with some trusses, and some doesn't.


18 hours ago, Mark Aceto said:

Is the truss object flying away to auto-connect to something somewhere else in the drawing?

Nope, just floating in mid air 😃


  • Like 1
Link to comment
  • 0

Hello All,


I am having the exact same issues, but I have some added info. When I go to edit the 3D elements of the truss symbols that are invisible, I find they are inside some sort of bounding box. When you select the 3D elements the object type is generic sold. I believe this is normal because the truss objects that are working correctly are also generic solids. However, the truss symbols that are working do not have any bounding box around them. They just highlight the edges and geometry of the solid instead of being inside a box. I do not know what these bounding boxes might mean, but I would bet they are somehow connected to the problem. 


Please respond if anyone finds solutions. I would greatly appreciate it.

Bounding Box.PNG

No Bounding Box.PNG

Link to comment
  • 0

@JustinVH @MartinBlomberg 


I believe I fixed the problem. Go into your resource manager and right click the truss to edit 3D components. Then select the object. In the OIP go to the render tab. Set the texture field to "texture" and map any old texture in the file to that truss. Now exit the symbol and BOOM, your truss object should be visible. If you don't like the look or color of the texture you chose that is fine, just go straight back into the 3D components and this time set the texture to "None." when you exit editing that symbol your truss should be grey and still visible.


Explanation/Theory: It appears that these truss objects are linked to an a aluminum texture file that is either no longer present, or it is not functioning properly. So when the truss tries to call upon the aluminum texture and use it for its visualization it literally gets nothingness; a transparency. So by manually mapping the thing to a random texture and then remapping it to "nothing" you have manually reset the system and now its no longer searching for some aluminum texture that is not present.


Also keep in mind that truss objects come in as 2D/3D symbols. If you want truss objects that are just 3D you will have to apply this fix to its original part straight out of the truss library, then delete the 3D only symbol in resource manager, then check the little check box in the OIP that says "Draw 3D only" and then go to top/Plan view. That process will regenerate your 3D only truss symbols with the applied fix. 


So far this little dance has fixed all my invisible truss. I hope the information doesn't come too late for your project and I hope its effective for you as well.


Cheers all, and happy holidays. 

  • Like 2
Link to comment
  • 0

Hey Hey,


I've been having this issue with truss since I upgraded to 2021, I've just updated to SP1 and I'm still having the same problem.

The issue is fairly random, sometimes truss is visible in 3D, sometimes I just get internal bracing, sometimes just the main chords, sometimes I see nothing at all.

I can copy and paste everything to a new file, sometimes It will show, sometimes it will make no difference.


Truss objects (at least for me) are saying the have no Edit behavior, so I cannot apply the texture fix mentioned above.

I'm tearing my hair out. It has to be something simple if not everyone is having the same issue.


Please help!



Link to comment
  • 0

@Roy Wimpenny Just for clarity sake, I did not mean right clicking on the truss object in the model space and clicking edit. That will not get you what you need. It will throw the error you described because no truss object is "editable" in that sense of the word. That method is trying to edit values that are directly attached to the truss, and truss only really has position information. 


Rather, open up your resource manager and navigate in there to the truss symbol you are trying to use. Right click on the symbol in the resource manager there and in the drop down menu one of your options should be to "edit 3D components." That is how you access the fix I descried earlier. If you already knew that, ignore me.  

Link to comment
  • 0

@Roy Wimpenny Yes, that is expected behavior. Ya see, there you are right clicking on the truss objects in the VWX library. Those items can never be edited because they act as a sort of default. Any time you click on one of those objects and use it in your drawing there is an automatic import process which pulls a copy of that symbol into your drawing. The objects in your model space then reference to the symbol as it is in your drawing, not to the symbol as it is in the VWX library. That is the point of resource manager, is to allow you to have edited symbols and other objects on a per drawing basis. Notice in my image below that I am in the resource manager and that I have selected the file I am currently working on (untitled 1). Since I have used that specific truss symbol in my drawing it now shows up under this file name and I can edit it to suit my needs. 

Screenshot (2).png

Link to comment
  • 0

Ah ok. 

I should have known that, sorry.


So the texture change did work. Once. But didn't work subsequent times

If we're not reassigning the default texture assigned to the VWX library, this is just a temporary workaround for each object in each file and not a long term solution.

Are there any ideas for a permanent fix? 


Also I'm a little skeptical of this solution as  it doesn't explain why sometimes objects show and sometimes don't (As in above illustrations)


Thanks for all your help so far chaps!





Link to comment
  • 0

@Roy Wimpenny The long term solution is for Vectorworks to fix the bugs in there code. This is absolutely a bug and needs to be addressed. For now, you can import symbols and other objects from one VWX file to another. All you have to do is have both of them open at the same time, or to have one of the files saved under your favorites tab. Then you can pluck those symbols that are already fixed from your earlier file. 


Also, as for this not working subsequent times, can you elaborate? I never got this to work on 3D only truss, I had to delete those symbols and reimport the 2D/3D symbols from the library and then regenerate the 3D only truss. That got it fixed. Further, try playing around with the objects rotation inside 3D components. I saw on other posts some people had success with that. 

Link to comment
  • 0

From experimenting in different instances of 2021


Sometimes truss objects show in 3D, it's more than likely they do not.

Sometimes the texture fix works, sometimes it does not. Same with rotating the object in 3D components. 


I'm reverting back to 2020 for new projects at the moment, I value my sanity too much.

Do the VW monitor this forum at all?

I've submitted this issue to support in the past and they've got the file working, but not fixed the underlying issues.





Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...