Jump to content

2021 Import Errors for External Python Packages


Recommended Posts

So I just moved all my plugins across to VW 2021, and I'm now getting Import Errors for Plug ins that use the External Package PyOpenSSL.


The error i'm getting is: 

DLL load failed while importing _openssl: The specified module could not be found.

I've tried both deleting and reinstalling PyOpenSSL via VerifyOrGetLib, aswell as simply copying the working "Python Externals" from 2020 Plug in folder, neither seems to solve the issue.


Pip does seem to be successfully installing PyOpenSSL, with the most up to date versions of it's dependents. 


I'm aware that with 2021 the Python distribution has been upgraded to 3.8, so I'm wondering if something to do with that could be causing this? Checking the docs here  it is compatible with 3.5+


I don't believe it's an issue with the package itself as if I install it, and run from my local copy of Python 3.8 via IDLE it imports fine. 


Any thoughts would be greatly appreciated! This is rather where my knowledge reaches it's limit!

Link to comment
  • 3 weeks later...

Same issue here. I think the installation of Python Moduls via VerifyOrGetLib still works. I had not much time to go deeper into that problem. Spontaneously I would say, Vectorworks 2021 uses "Python Externals" as the installation Path and "PythonExternals" as the search Path or "Python Externals" do not work anymore for the Script Engine. Also it is confusing, I cant set the Folder "Python Externals" as a search Path of a Python Script. 



As a short fix I was able to Install all Moduls with the Marionette nodes. After That renaming "Python Externals" to "PythonExternals" and it worked. Tried this on Mac, Installed new Pillow Fork with the Node. Then Renamed the Python Externals Folder and all my old "Pillow" Examples worked here.

Beside that here I have an issue, that Marionette Scripts do not "Alert" Errors. I had to thest with Text-Scripts.

Hope that Workaround is able to fix it also for your Scripts.




import numpy scipy pillow etc v2021.vwx

Link to comment

Just tried on Mac (10.14.6 Mojave)
Did again some test with a blank user folder and  Build 571107. I did the following:

1. Installed PIL with the attached Marionette Node
2. Tested to import PIL by Script or Marionette Node > Failed Module not found
3. Tried to set search-Path to "Python Externals" > Failed
4. Tried running Marionette Node with this Module > Failed
5. Renamed folder to "PythonExternals"
6. Setting search Path to that Folder in a Script > OK
7. Tested import of the Module in Script > OK

8. Running Marionette Example with PIL > OK

9. Renamed back "PythonExternals" to "Python Externals" run again Marionette Example > OK

(now I am confused, maybe a caching thing)

Movie attached
  Edited by DomC
Link to comment

I looked into the Scripts from Marissa and Sarah and their .whl Installers are Working. So I think it is just an issue of the correct Library Installer. The .whl Installer I used, creates an error because of PIP incompatibility. And then I think the issue is, that not immediately the library can be imported.

I will try Update this Stand-Allon-Installation-Nodes  ca. middle next week. 


Link to comment
On 10/27/2020 at 3:15 PM, K.Lalkovski said:

Where do you receive this behavior om Mac OS or Windows?

I'm running Windows


@domC Following you're suggested process, I got the same results. Strangely when I look at the environment paths within the VW Python environment, using sys.path(), "Python Externals" is in there. 


I'm still having issues with my specific package (pyOpenSSL) 


DLL load failed while importing _openssl: The specified module could not be found.

If I try running with a clean 3.8 interpreter outside of VW it runs fine, same as within 2020.

Link to comment
  • 1 month later...

Hi all,


I'm trying to install numpy in Vectorworks 2021 with no success - I've updated the install nodes from @DomC with the 3.8 version of numpy (see attached), and tried renaming External Packages to ExternalPackages. Don't quite understand the bit about PIP incompatibility - any help appreciated!





Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...