Jump to content
  • 0
Spittelo

Very Slow 2D File

Question

My Vectorworks file is really slow. I can work normally for a while, but about every 10min, the spinning pinwheel appears (after using a simple command like "select") and I have to wait for ±2min before I can resume drawing. My file is almost only composed of 2D surfaces and the only 3D Model it contains is really small. This happens even if I close all the other programs on my computer and I have about 40Go of storage left. 

Anyone has an idea what the problem could be? 

Share this post


Link to post

2 answers to this question

Recommended Posts

  • 0

Go to Vectorworks Preferences:Autosave pane. Do you have it set to automatically save every 10 minutes? Is it saving to a very slow drive and/or to the cloud so the save it taking a long time?

 

I normally recommend that you set the autosave to a certain number of Operations rather than minutes. That way the Autosave kicks in between operations and not in the middle of your doing a single operation.

 

While you are there, also make sure you set it to Autosave a Backup Copy instead of Overwrite Original. I have all of my backups go to a single folder on my local hard disk and I save the most recent 12 backups. But that was something I picked a long time ago. Considering that I am currently only using 700Gig on a 2TB drive, I should probably bump that number up.

 

I don't use VW that heavily, but my backup folder is only 9.3GB for 353 backup files running back to April of 2020. The nice thing about having all the backups in one place is you can easily go in and purge the backups for a file when you are done with the project and have made proper backups and archive copies. These autosave copies are really only there as snapshots in case you crash or the occasional time when you run out of undos after making a big boo boo.

 

HTH

Share this post


Link to post
  • 0

Apart from the save location and autosave settings that Pat mentioned you may also want to look at your 2D surfaces if you are not saving to a network location or slow drive.

 

You didn't mention the file size nor the number of 2D surfaces and how these surfaces were created.

If there are a lot of those 2 surfaces and they are made of polygons and the polygons have a very high vertex count then this can increase your file size as well, e.g. because it is an imported dwg file with hatches (hatches may get converted into triangulated polygons depending on VW and dwg version used). That could also explain the slow autosave because of the file size being large.

In that case you could try to replace the hatches and run the simplify polygons/lines command to see if it makes a difference.

 

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...