Jump to content
  • 0
MartinBlomberg

Is this really the performance one could expect?

Question

Honestly, is this what one can expect from VW? Please have a look at the video attached. 

 

LINK TO VIDEO:

https://photos.app.goo.gl/vCbW8r4R4SMqHK5d8

 

I'm doing a seating plan for the arena I'm working at. And the file isn't too complex yet, size around 50mb.

I've also shot the Task manager as well, so you can stats while I'm cliking about. I'm not doing to much stuff here as you can see, but still really slow.

 

Please let me know why occure and if there's some kind of fix to it.

 

Many Thanks!

INFO:

VW 2020, SP5, 64-bit

Windows 10 Pro

CPU: Intel i7 9700 3,00GHz

16GB RAM

NVIDIA GeForce RTX 2060 Super

Share this post


Link to post

Recommended Posts

  • 0

Please double check that VW is actually running o the RTX video card and not on an internal graphics on the motherboard. If it is running on the RTX card, check and make sure you have the most current drivers.

 

HTH

  • Like 2

Share this post


Link to post
  • 0
On 9/4/2020 at 5:46 PM, Pat Stanford said:

Please double check that VW is actually running o the RTX video card and not on an internal graphics on the motherboard. If it is running on the RTX card, check and make sure you have the most current drivers.

 

HTH

Thanks Pat! I'm not really a PC user (use Mac all the time but on my work computer), so, how do I check this on a Windows 10 machine?

Cheers!

 

EDIT: Google helped me out, sorry for my ignorance. Still no change though... 

Edited by MartinBlomberg

Share this post


Link to post
  • 0

Why editing your viewport point of view using crop and not camera ?

My model does also lag if I edit the point of view with Edit/Crop but not at all when using Edit/Camera

Share this post


Link to post
  • 0
15 hours ago, MartinBlomberg said:

how do I check this on a Windows 10 machine?

 

You can go to task manager, then select your GPU. Move a bit around in vectorworks and see if the gpu gets any workload.

 

image.thumb.png.d31cf6801ca325029147949a8222347b.png

 

 

Or you can check per application in the task manager:

image.thumb.png.0bed00e1e81847edfabfd3f4dbffd7fc.png

 

 

I also find vectorworks really slow. especially when there're many section viewports in your file. 

 

Edited by Bertf

Share this post


Link to post
  • 0
2 hours ago, Frederic_Vbc said:

Why editing your viewport point of view using crop and not camera ?

My model does also lag if I edit the point of view with Edit/Crop but not at all when using Edit/Camera

That's probably my lack of knowledge in the software, will change this behaviour of mine 😃

Thanks! Though, my trouble still exist, check the video down below in next thread.

Share this post


Link to post
  • 0
2 hours ago, Bertf said:

 

You can go to task manager, then select your GPU. Move a bit around in vectorworks and see if the gpu gets any workload.

Or you can check per application in the task manager:

I also find vectorworks really slow. especially when there're many section viewports in your file. 

 

Thank you! I did this, shot a video when I made an example of a curtain wall. 

Please check this clip out and tell me what you think. More then a minute to change the thickness of a wall? What's up with this?

I know OBS is taking some power of the CPU as well, but it's the same when I don't record.

 

Cheers all! 😃

 

 

Share this post


Link to post
  • 0
6 hours ago, Frederic_Vbc said:

Can you share your file ? or just what we can see on that layer if there's some sensitive info.

Sure! No sensitive info at all, just some Swedish classes and stuff. For this I've deleted references and deleted some other info that would've dragged down the speed. 

Thank you for taking a shot at this!

 

Curtain wall slowness.vwx

Share this post


Link to post
  • 0

Well I've got the same results as you. The operation takes ~50s to perform.
Looks like it's handled by only one CPU  so hopefully this kind of operation will be improve in 2021 with performance enhancement on multi tread.

Also you can reduce your waiting time by getting the right setting on a smaller sample of your curtain wall (or just one side). That's a lot less geometry to process -> much faster to perform. That's my best advice 😕

 

Share this post


Link to post
  • 0
9 hours ago, Frederic_Vbc said:

Well I've got the same results as you. The operation takes ~50s to perform.
Looks like it's handled by only one CPU  so hopefully this kind of operation will be improve in 2021 with performance enhancement on multi tread.

Also you can reduce your waiting time by getting the right setting on a smaller sample of your curtain wall (or just one side). That's a lot less geometry to process -> much faster to perform. That's my best advice 😕

 

Thanks Frederic for  your checkup on this! 

 

I think this is ridiculous, to put it mildly. So, this is obviously the performance you could expect from VW2020. Wow.

 

The file I'm working on isn't big at all, the operation isn't anything super special and it's even a built in feature. Still, a minute to make a curtain wall thinner? Seriously? 

 

To the staff at Vectorworks:

For future versions of Vectorworks, please just make the software stable, responsive and quick. No more features that will take forever to perform and might just crash on you (happens more then any other software I've bought, ever). I love the event design part of VW, that's the sole reason I bought it. But to work with a software that's this unresponsive isn't gonna be a keeper.

 

Thanks for understanding!

 

 

  • Like 1

Share this post


Link to post
  • 0

Hello @MartinBlomberg,

 

I see that you have specified TitleBlock as a tag for this thread. Does this really have anything to do with Title Blocks or not? As I see you are not making any interactions with Title Blocks in your recordings.

Also, if you think that the issue is related with Title Blocks, could you send me a test file so that I can investigate the issue?

 

Best Regards,

Nikolay Zhelyazkov

Share this post


Link to post
  • 0
31 minutes ago, Nikolay Zhelyazkov said:

Hello @MartinBlomberg,

 

I see that you have specified TitleBlock as a tag for this thread. Does this really have anything to do with Title Blocks or not? As I see you are not making any interactions with Title Blocks in your recordings.

Also, if you think that the issue is related with Title Blocks, could you send me a test file so that I can investigate the issue?

 

Best Regards,

Nikolay Zhelyazkov

 

I used the Titleblock tag since I'm doing the editing when the titleblock was present. 

Maybe it was not necessary, not sure 😃

Share this post


Link to post
  • 0
34 minutes ago, MartinBlomberg said:

 

I used the Titleblock tag since I'm doing the editing when the titleblock was present. 

Maybe it was not necessary, not sure 😃

 

I have tested this with the file you have attached with the Curtain Walls. Deleting the Title Blocks does not change the results, so I think that this is not Title Block related.

 

Best Regards,

Nikolay Zhelyazkov

  • Like 1

Share this post


Link to post
  • 0
6 minutes ago, Nikolay Zhelyazkov said:

 

I have tested this with the file you have attached with the Curtain Walls. Deleting the Title Blocks does not change the results, so I think that this is not Title Block related.

 

Best Regards,

Nikolay Zhelyazkov

That's good to know.

Though, how come it takes aprox 1 minute to change the wall thickness? 

I thought all this was some kind of bug, but it's obviously the same for you guys. This is way under what you could expect imho.

 

Is there going to be a change to these kind of issues in the near future?

 

Thanks!

 

Share this post


Link to post
  • 0
6 minutes ago, MartinBlomberg said:

That's good to know.

Though, how come it takes aprox 1 minute to change the wall thickness? 

I thought all this was some kind of bug, but it's obviously the same for you guys. This is way under what you could expect imho.

 

Is there going to be a change to these kind of issues in the near future?

 

Thanks!

 

 

This seems to be a performance issue of the curtain wall when it is joined with other walls. If you change the thickness of a standalone curtain wall, it is taking just a few seconds.

 

We are constantly working on improving speed and reliability, which you can see in the teaser Tuesday videos for VW 2021 too. Having your feedback here helps us know where we have to improve.

 

Best Regards,

Nikolay Zhelyazkov

  • Like 2

Share this post


Link to post
  • 0
17 minutes ago, Nikolay Zhelyazkov said:

 

This seems to be a performance issue of the curtain wall when it is joined with other walls. If you change the thickness of a standalone curtain wall, it is taking just a few seconds.

 

We are constantly working on improving speed and reliability, which you can see in the teaser Tuesday videos for VW 2021 too. Having your feedback here helps us know where we have to improve.

 

Best Regards,

Nikolay Zhelyazkov

I'm happy to hear you're working on improvements, looking forward to that.

But still, I should be able to join curtain walls without this experience? I mean, walls usually stand together in a construction and not alone.

This same latency goes with seating sections. I takes more or less forever to make a seating plan for the arena I'm working at. 

Every single moment I do need some processing. Click, wait, click, wait. It's driving me more or less insane. 

It it's not working smoothly, just delete the feature. I think I speak for a lot of people in the VW-community when I say we need a more responsive and easy-flowing software. 

 

I'll have a look at the new features of 2021 now.

 

Cheers.

  • Like 3

Share this post


Link to post
  • 0
On 9/7/2020 at 7:54 AM, Frederic_Vbc said:

Why editing your viewport point of view using crop and not camera ?

My model does also lag if I edit the point of view with Edit/Crop but not at all when using Edit/Camera

 

I tried your camera option solution on another project I'm working on. All I'm trying to do here is pan from left to right.

This takes  f o r e v e r . Sure, it's a bigger project for sure, but still, this is totally unacceptable. For a freeware maybe, but after spending thousands of bucks? No way.

 

Here's a video showing how slow this thing is. Come on now, I must do something wrong here, because this can't be the way it's suppose to be, right?

 

Cheers,

Share this post


Link to post
  • 0
On 9/4/2020 at 5:46 PM, Pat Stanford said:

Please double check that VW is actually running o the RTX video card and not on an internal graphics on the motherboard. If it is running on the RTX card, check and make sure you have the most current drivers.

 

HTH

Hi again Paul,

 

Would you mind taking a look at the files and videos I posted here? Since you're far more expert then I'll ever be, can you please make sure that I'm not missing anything?

For the time being I just can't work with projects for my clients, it's more or less impossible with graphic latency like this. 


Thanks again mate! 😃

Share this post


Link to post
  • 0

Have you tried this setting:

 

kuva.thumb.png.16818ca358e5edfccb58aead28ba0033.png

 

If that doesn't help, try to replace your chair symbol with something extremely simple, like two boxes for the seat and backrest, and see if that makes any difference.

 

For the curtain wall I get the same result as you, about a minute.

 

 

Share this post


Link to post
  • 0
2 hours ago, JMR said:

For the curtain wall I get the same result as you, about a minute.

 

 

Well,

I thought VW Curtain Wall execution was working in slow motion

since it was released. For me it was always impractical so I just

avoided to use them.

  • Like 2

Share this post


Link to post
  • 0
11 hours ago, MartinBlomberg said:

 

I tried your camera option solution on another project I'm working on. All I'm trying to do here is pan from left to right.

This takes  f o r e v e r . Sure, it's a bigger project for sure, but still, this is totally unacceptable. For a freeware maybe, but after spending thousands of bucks? No way.

 

Here's a video showing how slow this thing is. Come on now, I must do something wrong here, because this can't be the way it's suppose to be, right?

 

Cheers,

What I meant is when you have a perspective viewport and you open the edit panel, there is that option 'Camera'  that you can use to modify your point of view (even when you didn't set up a camera.. I know it's a bit confusing).
But as for your case it does look really painful ! Are you working in Open GL to move around ? Textures are the next suspect to check. I tend to move around in Wireframe if I ever use a camera. Very rare thing..
I usually don't even touch the camera or use the rendering tool of VW. The gap with Lumion or Twinmotion is just too big. VW is great for lots of things but rendering...Haha. I think they already gave up actually. No one can be good at everything I guess !

Edit Viewport.png

Edited by Frederic_Vbc

Share this post


Link to post
  • 0
On 9/9/2020 at 3:49 PM, JMR said:

Have you tried this setting:

 

kuva.thumb.png.16818ca358e5edfccb58aead28ba0033.png

 

If that doesn't help, try to replace your chair symbol with something extremely simple, like two boxes for the seat and backrest, and see if that makes any difference.

 

For the curtain wall I get the same result as you, about a minute.

 

 

Hi, thanks for the reply!

It's already set on "Low" actually.

I can try the symbol change, but that doesn't cut it when I'm about to present it to the client.

And I want to be able to make adjustments with the original chairs present. 

Share this post


Link to post
  • 0
On 9/9/2020 at 6:26 PM, zoomer said:

 

 

Well,

I thought VW Curtain Wall execution was working in slow motion

since it was released. For me it was always impractical so I just

avoided to use them.

That's really sad to hear. To release a slow motion-product isn't really optimal, imho.

Share this post


Link to post
  • 0
On 9/11/2020 at 1:54 PM, MartinBlomberg said:

Hi, thanks for the reply!

It's already set on "Low" actually.

I can try the symbol change, but that doesn't cut it when I'm about to present it to the client.

And I want to be able to make adjustments with the original chairs present. 

Using a simple box etc. for chair geometry can help diagnose the reason for the slowness.

 

If the culprit indeed is the chair geometry, you can set up views and renders with that faster geometry present and change the symbol to the final, proper chair before issuing and rendering to the client. While not exactly what you want, at least you can work faster.

 

If simplifying the chair geometry does not help at all, then the reason for the slowness is somewhere else.

  • Like 1

Share this post


Link to post
  • 0
On 9/13/2020 at 3:24 PM, JMR said:

Using a simple box etc. for chair geometry can help diagnose the reason for the slowness.

 

If the culprit indeed is the chair geometry, you can set up views and renders with that faster geometry present and change the symbol to the final, proper chair before issuing and rendering to the client. While not exactly what you want, at least you can work faster.

 

If simplifying the chair geometry does not help at all, then the reason for the slowness is somewhere else.

I followed a tip from another member here on the forum. The tips was to consolidate geometry, make symbols of repeating objects and so on.

I did, I replaced 2662 extrusions to one symbol i.e. I guess that's great but the flow is far from good, not even close I'd say.

 

Any more suggestions from anyone? I'm kinda desperate here since this is dragging my work down... 

 

Cheers all for your time and support!!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...