Jump to content

Class visibility problem

Recommended Posts

I have some structural members which were created mistakenly in a class called dimension. I select the objects and change the class to Beam - Dropped. If I turn off all classes except Beam - Dropped, the beams disappear. they only show when the class dimension is turned on. I copied the beams to a new file and have the same result. As a new user, this kind of thing drives me crazy. I can't find any way in which the dimension class is sticking to the beams. Any answers out there.

Share this post

Link to post

Tried creating several other objects (walls, doors, slab) in the dimension class and then changing them to another class. They display correctly depending on which classes are turned on. Created two more beams (structural member), one in the dimension class and one in the beam-dropped class. Changed the one in the dimension class to the beam-dropped class. The beam created in the dimension class doesn't display correctly according to which classes are turned on. There seems to be an issue with the structural members class display.

Share this post

Link to post

Tried cut and paste on the buggy beams, pasting them into the correct class. This did not work. The dimension class stayed stuck to the beams.

Tried create similar on the buggy beams and that worked correctly. The beam was created in the right class and displays correctly. I think the structural members have a bug.

Share this post

Link to post

The Beams are probably "container objects."  For objects that "contain" other objects (like symbols, groups, and it sounds like beams) to be visible, the class of both the "contained" and "container" objects must be visible. If the class of the contained and container are the same, then only that class needs to be visible.


If you right click on a beam, do you get edit options? Something like Edit Path and Edit Profile? Or Edit 2D and Edit 3D?  If so, try those options and I would bet there are objects there that were put into the Dimension class when the beams were created. Change the class and exit the edit mode and you should be OK.


I don't have VW open right now to test this. 


If you still have the problem, paste one or two of the beams into a new blank file and we can take a look.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...