Jump to content

Unopenable file: error message "This is an unrecognized file. It may be a...."

Recommended Posts

I'm having difficulties opening a vectorworks file stored remotely on a server. It refuses to open, and when I attempt to open it I get the following dialogue box:

"This is an unrecognised file. It may be a VectorWorks file created by a newer version of the application, it may be a very old miniCAD file, it may have been created by another application, or it may have been corrupted by a hardware or system error."

I have tried the workgroup referencing trick, but again I get the same error message before anything can be imported.

I am running

VectorWorks v11.5.1

Mac OS X v10.4.1

Fortunately I have an older version of this file which opens so I havn't lost too much work, but this is the second time this has happened in the history of this drawing, so something is wrong.

The last time this happened I copied and pasted all the drawing info from the backup file to a new drawing and purged to try and oust any buggy elements.

The file contains some data imported from an AutoCAD drawing, with addditions from my own VW work, and I'm the only one to have worked on the file.

Incidently everyone else in my office is running VW v11.5, and they cannot open the file either.

I'm am afraid this might happen again with more serious consequences..

Any ideas?

Link to comment

The file is on a Mac server. I've changed the extension to .mcd, but the file remains unopenable, as before. I've just checked the file size too...only 4kB on the disk instead of around 500kB, so it looks like it must have corrupted. Bad disk sector?

I'll take a deep breath, and go back to drawing it again...

Link to comment

Katie, in reply to your query-

Quoting Finder:

Kind: Vectorworks 11 drawing

Size: 4KB on disk (Zero bytes)

it's almost as if the file's basic info was written, and then the write was interupted.

FYI, no one else has had this problem in our office yet, and yet it has happened to myself twice...


Link to comment


we have experienced the same as laurence two times. and we have lost two days of work. [Frown]

We got the same message when we tried to open the files. And the saved files were zero kb instead of around 10 mb.

It seems like a weak point of vw12. Now we don?t dare to work directly on the files on our network anymore.

it?s a pitty. It would be better if we could work directly on the files on the network.

Any suggestions?

Link to comment
  • 2 weeks later...
  • Vectorworks, Inc Employee

Hi everyone,

We think it might be the case that, when you get the "unrecognized file" message, the file is not really corrupt at that point, and it only becomes corrupt when you shut down VectorWorks. When you get the message, if you copy the file in the Finder before you shut down, or if you Force Quit VectorWorks, the file might be ok. Please let me know if you get a chance to try this out.

Were looking for some common threads here. Can anyone tell me if they had just updated the OS on their Mac server right before this problem started happening? Which of the following methods do you use to open VectorWorks files:

- double click on the VW file

- drag the VW file onto the open VW app window

- drag the VW file onto the VW app icon

- use the File Open command from within VectorWorks

Laurence, when you say "no one else has had this problem in our office yet", are your colleagues also opening files from the same server? If so, can you identify anything that's different between their setup and your setup?

Any additional information you could give us regarding this problem would be greatly appreciated.


Mark Farnan

Core Technologies Manager

Nemetschek NA

[ 03-09-2006, 03:25 PM: Message edited by: Mark Farnan ]

Link to comment


I use the double click in finder method to open files. I'm not sure if the server OS has been updated recently, I'll need to check with our tech guy who is not in the office today.

My colleagues, like myself, are all opening files from the same Mac server. Some of us use tiger some on panther versions of OS X. I am the only one who is running VW 11.5.1 the others are running 11.5.

I have no other hardware attached to my iMac apart from the good old VW USB dongle, a mouse and a keyboard, and we are all wired up to our LAN which is a cabled gigabit ethernet variety. I have the VW autosave feature turned on, and for this file both the original and the VW backup exibit the same unrecognised file and 4kB size symptoms. I have tried copying both the original and the backup onto my desktop and opening but with the same resulting error message.



Link to comment

What I posted in a related topic:

For those having problems, what is your current open space on your share_point? We have had this(or a remarkably similar) issue on and off since version 9. I believe we found and solved this issue. We are currently a mix of 10.4.4 and 10.4.5 with 10.4.5 Server. and a mix of VW 11.5.1 and VW 12.01, and as I point out below we haven't seen the problem for nearly 15 months.

I sent following information via email a while back to NNA.

I found that without fail if the sharepoint's drive being saved to got beyond 85-90% full we would experience widespread file corruption. The corruption would occur, even though our staff was very careful to never close or save a file until the print was completely transfered to the printer. Also to never close a file and use the standard Save warning to save the file, rather to save the document first and then close the file.

We found that 99.5% the corrupted file was the main working document, and that the backup copy saved a few operations before was fine. There were a couple of times where both the main file and the backup were corrupted, but I never could answer to my satisfaction if staff had opened the backup without making a copy, so I have no concrete cause and effect for those rare situations.

This occurred three times, in a little over two years. During that time, we had two 60Gb drives, one was our startup drive, and user accounts, and the other our data drive. In all three occurrences I hadn't monitored data drive space closely enough. The first realization I got that something was wrong, was a day where 10-15 files were corrupted. Once I cleared enough space of the data drive the new corruption of files would cease, though it was usually a three week process of finding all the files corrupted while the drive was too full. After the third occurrence, I increased our storage dramatically, and we haven't seen the same widespread corruption since, about 15 months now.

The particulars:

xserve Dual G4 1.0 Ghz/ 1.5 Gb RAM (depending on the time(120 - 420 Gb HD space, Mac OS X Server 10.2.x - 10.3.9)

100bT ethernet network

16 workstations all Macs, a mix of G3, G4 & G5s, running the current version of Mac OSX, usually adopted office-wide around the 10.x.2 or 10.x.3 release

Only in office access was allowed, no remote access of files.

So for me on our original drives which were 60 Gbs, I started to see widespread corruption as the open space passed under the 6Gb mark.

So take a look at how much overall capacity you have on the drive and compare it to your free space. If you have other questions, I am happy to follow up.


Ion Webster

VW Designer 12.0.1/Renderworks

PM G5 dual 1.8 2nd Generation

OS 10.4.5

ATI Radeon 9800 SE

Link to comment

We have experienced the same problem here in our office. We are running Mac G5's all around with VWA12. We are using a tape drive back up system that runs once a week on our network. We will be changing now to run daily, because this morning we lost two files to this problem. VW crashed while the drawings were both open. After relaunching we discovered both files to be damaged and were not able to be recovered. They are both zero Kb now and the message displayed is the same as other have seen here in this posting.

Link to comment

Our office is using New G5 Mac's with both OS X Tiger 10.4.5 and Panther 10.3.9 with the latest version of V12.0.1 (53930). We have experienced problems with "unrecognizable file' and unable to re open this drawing as contents of drawing information removed to create an empty file. We are saving to back up and retrieving corrupted files but in the past have lost substantial amount of work. This problems seems to occur regardless of the method we use to open the file.

Link to comment
  • Vectorworks, Inc Employee

Thanks for deatils everyone. For each site, can you tell me if these problems have been happening at the current rate for a long time, or if they've have become more frequent since your server or local machine has been upgraded to use MacOS 10.4.5.?



Link to comment

We are currently running OSX Server 10.4.5 Our file corruptions occured while running versions 10.2.x - 10.3.9. I increased our server storage before upgrading to 10.4.x

We have seen no corruption on any version of server 10.4.x.

Most people work directly on the server, over the network.

Link to comment

I had this problem starting last Friday, any VW file opened from certain folders would result in an error message (this file is corrupted . . .) and then open with big chunks missing. Pretty scary.

While thinking about it over the weekend, and reading Mareks thread, I didn't clue in that I had a similar problem.

I checked my disk usage and to my surprise I only had 4 GB free on a 55 GB harddrive. After trashing about 20 GB of files I don't need, OSX went nuts defragmenting the drive and re-indexing it. After that all finished everthing is fine.

Looking over the drive contents, I found a 5 GB 'Previous Systems' folder created on Friday. I did a system update, it must have created an entirely new system folder and archived the old one.

Keep your drives less than 75% full. clear out the cruft on a regular basis. watch out for mystery jumps in drive usage.

Link to comment
  • 17 years later...

So, at 17 and a half years on, does this problem still exist for many? I have only been a Vectorworks user since January 2022. It seems since the support expired on my licence, I have been having similar issues. Although this maybe because I have not needed to copy files across from a server onto my mac. 


Each time I open a document which is the correct file and working on other machines, the error of "This is an unrecognised file. It may be a Vectorworks file created by a newer version of the application, it may be a very old MiniCAD file, it may have been created by another application, or it may have been corrupted by hardware or system."


Click okay, and then another dialog box opens up which says "This file was created with an older version of Vectorworks. It will be converted and opened with the new name:... 

Then it just doesn't open. Any further advice or fixes since 2006? This only happens with files that aren't made using my version of VWX.


Thanks in advance 🙂 

Screenshot 2023-09-26 at 15.02.50.png

Screenshot 2023-09-26 at 15.02.42.png

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...