Jump to content
  • 0
richard2020

Walls always showing see through

Question

Hi there,

I feel ridiculous asking this, but I can't get my walls to show with any fill or texture. I've tried for 2 hours before reaching out here, I've trawled the university and google, but to no avail. There are hundreds of posts on this, but none that seem applicable as far as I can understand it. Apologies if I've missed it, but if someone could hep i'd really appreciate it.

 

As per diagram below, I have lots of external walls, but on a view all I can see is the edges, not the solid. I've tried tools -> organisation, choosing textures, I've tried render -> Open GL, and pretty much every other technique I can see. But my walls are stubbornly remaining just a collection of edges with no fill. I'm sure it's simple, but I just can't find it.

 

Help gratefully received.

 

Thanks

 

 

Screen Shot 2020-08-01 at 11.08.06.png

Share this post


Link to post

15 answers to this question

Recommended Posts

  • 0

Objects need to have a fill for the texture to appear on. So check the walls have a fill.

 

If the walls have no components then just check that in the attributes palette the fill style is not set to none. If the walls have components then check in  the component settinha that at least one component has a fill.

Share this post


Link to post
  • 0

Hi Boh,

 

Thanks for the reply. In all other objects I use the attributes box to set fill, but when I click on the wall the attributes are greyed out and set to none. So I can't change them there. Is there another setting somewhere that is relevant?

 

Thanks

 

 

Screen Shot 2020-08-01 at 11.32.22.png

Share this post


Link to post
  • 0

If you are using a Wall Style, which has components, you may need to edit the wall style itself and each component to ensure it has a fill. If you would like to post the file here, I would be more than happy to take a look.

Share this post


Link to post
  • 0

Hi Tamsin,

 

Thanks for helping. In terms of wall style, I just followed what the BIM section of the university said. I've since tried my best but the screenshot above I think shows all of the settings on this wall. To the left is the attributes tab showing fill greyed out. To the right shows the OIB with class texture set. Is there somewhere else I should be looking? In the tools -> organisations I have 4 wall classes, all of which are set to solid fill. The file is 36mb so may take a while ........ 

Share this post


Link to post
  • 0
Posted (edited)
18 minutes ago, Tamsin Slatter said:

If you are using a Wall Style, which has components, you may need to edit the wall style itself and each component to ensure it has a fill. If you would like to post the file here, I would be more than happy to take a look.

If I am using a wall style it is unintentional. For now after 3 hours I'd settle for showing a white wall. I'd prefer a texture, but a white wall would be significant progress!

 

Thinking about it, wall is made up of components, so yes - I did put components in it so my comment above isn't right. When I made them I did set the components to each have an image - hatching or similar. I created a new style for it. I've attached a screenshot of the style.

 

Thanks

Screen Shot 2020-08-01 at 12.14.50.png

Edited by richard2020
Incorrect info from me.

Share this post


Link to post
  • 0

May I see the file? It would be really easy for me to work out what's wrong and help then...

You can attach it here. Or, if you prefer, upload it somewhere like Dropbox and send me a link in a private message to retain confidentiality on the file.

Share this post


Link to post
  • 0

I'd rather not send the file. I wouldn't be comfortable uploading it here, and I don't use dropbox only we transfer. Where else are there settings? It seems so complex just trying to make a wall.

Share this post


Link to post
  • 0

Ok - so how about this... create a blank file and copy one of your walls into it. Save that file, and upload it here. Then I can look at the makeup of the wall, without needing to see the entire model.

Share this post


Link to post
  • 0

P.S. I will need to do this in the next half an hour - other weekend activities will take over then!

Share this post


Link to post
  • 0

OK - so it looks like you have created a style called Audley, which contains a number of components. These are set up with different fills which will show in a section view.

However, the basic attributes for the wall has a fill style of None, and this is what's causing the textures not to display.

 

Here's what to do:

  1. On the Resource Manager, click the Home button to ensure you are looking at the resources of the active file. 
  2. Locate the Wall Style definition, named Audley.
  3. Right click on this and choose Edit.
  4. At the top of the dialogue box, above the list of components, click Edit Wall Attributes.
  5. Change None to Solid and then choose the base colour you would like.
  6. Click OK and choose to replace the style.
  7. Now, the wall is set to render By Object (in other words, not render each individual component) and to get that texture By Class. The wall is in the class Wall-Exterior. So, now, edit that class and on the Textures pane, choose the texture you would like to apply to the left and top of the wall. 

In my example, I have put a stone texture on the left (outside) and the top, leaving the interior of the wall showing the solid white fill that I applied in the style.

 

image.png

 

image.png

 

image.png

tamsin.vwx

  • Like 1

Share this post


Link to post
  • 0

Hi Tamsin,

 

Thank you so much for your help on a saturday. It worked perfectly. Thank you very much! 

 

 

  • Like 1

Share this post


Link to post
  • 0

Actually I spoke too soon. It worked brilliantly in the dummy copied version I stripped out, but then when I applied it to the main model no joy. Still no visible walls.

 

What I have in the model is as follows:

 

The walls in question are in class Wall Style 1. Wall style 1 as per attached pic has class set to fill colour white. So thats as it should be I think.

 

Within the style, I have selected the style in resource manager, right clicked it, clicked edit, then clicked edit wall attributes, and as per screenshot, the fill is set to solid.

 

Yet still no walls. It worked fine in the dummy file. So there must be something else here too. Any help gratefully received.

 

Thanks

 

 

Screen Shot 2020-08-01 at 14.19.50.png

Screen Shot 2020-08-01 at 14.24.03.png

Share this post


Link to post
  • 0

Ok everyone - final update - the final setting was that even though I had set the model to open GL, when I had made all the other changes it had gone back to wireframe. So actually with the suggestions Tamsin had made it was working, but the render was set to wireframe. I must have changed it back when I was trying everything yet in the copy I made for Tamsin it had reverted to open GL so all seemed to work there.

 

So in summary to get white background for walls suitable for elevations if you have components in walls then:

 

1) Style fill set to solid through resource manager

2) Class fill set to solid through tools -> organisation - > classes

3) Render set to open GL through view -> rendering.

 

 

  • Like 1

Share this post


Link to post
  • 0

I'm so glad it's working.

You can set OpenGL as the default render mode here:

image.png

If you don't have the option available on the Quick Preferences bar, click the lower down arrow (at the right of my screenshot) and enable the option.

 

Looking forward to seeing your progress when you feel ready to share!

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...