Jump to content
  • 0
MartinBlomberg

No1 noob question regarding class

Question

Ok, this is me on a Saturday morning, can't figure out what I'm doing wrong.

 

1. Draw a recangle

2. Extrude

3. Change layer and class (I don't use Class styles)

4. I want to change the appearance of the extruded object, but it won't change.

What. Am. I. Doing. Wrong? See image for reference.

 

Thank you all!

image.thumb.png.14403a031c7a735a0e17568d4fe6f129.png

Share this post


Link to post

14 answers to this question

Recommended Posts

  • 0

Images are only for 2d. You can either use a solid fill with a colour to get different colours or better use a texture. Do you have renderworks?  Textures are for 3D work. You can make a texture from an image.

Share this post


Link to post
  • 0
13 minutes ago, Boh said:

Images are only for 2d. You can either use a solid fill with a colour to get different colours or better use a texture. Do you have renderworks?  Textures are for 3D work. You can make a texture from an image.

Thanks! I shifted to Top/Plan but it's just hollow. See image bellow.

Unfortunately I don't have Renderworks. How do I access the textures easily? 

This workflow seems quite off for me, thanks for the help!

 

Martin

 

image.thumb.png.6e0724cf1a52ba7d10180d9229f866eb.png

Share this post


Link to post
  • 0

Extrudes are just 3D, they only show as wireframe in 2d top/plan and without renderworks you can’t use textures unfortunately. For 3D you can only use solid colour fills.
 

If you need to see the objects fills in 2d as well as 3D then you cld turn the extrude into a symbol and then add a  2d component. The 2d component could have the image fill. The 2d Objects would need to be placed on the screen plane in the symbol definition. This would make it a 2d/3D hybrid symbol. It would be one object but the 2d and 3D components are independent of each other.

 

If however, as in your screenshot, you are just making simple extrudes vertically then you could instead use the floor tool. This is a 3D object but has a 2d component built in. The “floor” could be any thickness you want.
 

I hope that helps. This can be a bit confusing when you’re starting out. 

perhaps if you explain what the project is we cld offer some better advice?

Share this post


Link to post
  • 0

If the object is hollow (No Fill) when you extrude, you will get the sides only and no top/bottom surfaces.

 

Without Renderworks I don't think you will be able to use textures, so you will have to use colors only.

Share this post


Link to post
  • 0
On 7/25/2020 at 6:21 PM, Pat Stanford said:

If the object is hollow (No Fill) when you extrude, you will get the sides only and no top/bottom surfaces.

 

Without Renderworks I don't think you will be able to use textures, so you will have to use colors only.

Thanks Pat! Alright, so do I need to change to only colours?

When I do that it doesn't change a thing, unfortunately...

Share this post


Link to post
  • 0

Are you sure you don't have renderworks? If there is a texture applied to the extrude then the 3d colour won't change. 

Share this post


Link to post
  • 0

@MartinBlomberg If no colors are changing, then make sure that the fill in your attribute pallet is set to "solid" for the object (not "none"). 

 

608871621_ScreenShot2020-07-27at3_49_20PM.thumb.png.44c391a5397361e726dcbf11ae5cc6a0.png

 

@Boh I thought that OpenGL rendering was available for non-renderworks users.  In which case, you would access the rendering mode via the Menu: View>Rendering>OpenGL

 

... after assigning a texture to the object.

Share this post


Link to post
  • 0

OpenGL is available, but I don't think you have access to textures without Renderworks.  BUT I think Renderworks became an automatic bundled part of VW in 2019 (or was it 2020). I know it is now included with all versions.

Share this post


Link to post
  • 0

As I recall, Renderworks has been included with all Vectorworks modules since Vectorworks 2017. You can find out if your license includes Renderworks by opening the 'About Vectorworks' window via the Vectorworks menu on Mac and the Help menu on Windows. Look in the line, 'Licensed Products.' 

 

image.thumb.png.17b9e48062bb5d01062423146d7bfe31.png

  • Like 1

Share this post


Link to post
  • 0
On 7/28/2020 at 12:54 AM, Taproot said:

@MartinBlomberg If no colors are changing, then make sure that the fill in your attribute pallet is set to "solid" for the object (not "none"). 

 

608871621_ScreenShot2020-07-27at3_49_20PM.thumb.png.44c391a5397361e726dcbf11ae5cc6a0.png

 

@Boh I thought that OpenGL rendering was available for non-renderworks users.  In which case, you would access the rendering mode via the Menu: View>Rendering>OpenGL

 

... after assigning a texture to the object.

 

Yep, I've set it to "Solid" and disabled the texture in the OIP->Render->Texture so it now says "None".

Still hollow in Top/Plan. Is this the way it's supposed to be?

 

Thanks all!

Share this post


Link to post
  • 0

Yes, as it's now a pure 3D object, it does not have an automatic 2D appearance. You can create the 2D view that you want, using either of the following methods:

 

1. Draw over the top, with 2D objects, then fill and class those as you desire. Select all, including the extrude, and run Modify > Create Symbol. This will create an object that has both 2D properties and separate 3D properties.
2. Select the Extrude, and run the Create Auto Hybrid command. This will automatically generate the 2D view for you.

The Auto Hybrid command is in different places in different workspaces, but if you hunt through the menus, you'll find it.

 

Share this post


Link to post
  • 0
On 7/31/2020 at 12:39 PM, Tamsin Slatter said:

Yes, as it's now a pure 3D object, it does not have an automatic 2D appearance. You can create the 2D view that you want, using either of the following methods:

 

1. Draw over the top, with 2D objects, then fill and class those as you desire. Select all, including the extrude, and run Modify > Create Symbol. This will create an object that has both 2D properties and separate 3D properties.
2. Select the Extrude, and run the Create Auto Hybrid command. This will automatically generate the 2D view for you.

The Auto Hybrid command is in different places in different workspaces, but if you hunt through the menus, you'll find it.

 

Thank you Tamsin for helping out! 

I'll try that one out, but still... For me this whole procedure seems a bit upside down. I mean, to have two different options that claims to be able to can change the appearance of the object, the Render tab in the OIP and then the Attributes pallette. But they won't do the trick this time. Might be me, I'm more then sure, but just seems a bit off, that's all. 

 

Thanks for all support!

 

Share this post


Link to post
  • 0

You're very welcome. The beauty of the hybrid approach is that the resulting object can have both 2D properties, so look lovely in plan view, and separate properties for a 3D view or visualisation.

If you don't need the plan view, you can stick to a purely 3D view, and just model elements. If you choose a Top view instead of a Top/Plan view, and render with OpenGL, you will see the textures that have been applied.

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...