Jump to content
jeff prince

hardscape texture issue using aligned hardscape

Recommended Posts

I just created an aligned hardscape and my texture looks strange.  Is this normal behavior?

Kind of looks like the mapping needs to be reset, but I don't see how to do that with a hardscape.

 

Here's the plan view with the offending hardscape highlighted.  It's using the same texture as the hardscapes adjacent.

658763902_ScreenShot2020-06-22at4_38_46PM.thumb.png.82c7bb8fe2508ac298b78328bda4ec67.png

 

looks bad from any angle too.

1621540749_ScreenShot2020-06-22at4_44_22PM.thumb.png.124534be71718b7def29f7cd04e3c7b4.png

Share this post


Link to post
Posted (edited)

FYI, It exports to c4d with the no texture applied to the aligned hardscape.  Is that typical?

Edited by jeff prince

Share this post


Link to post

Just a thought - My experiments with the aligned hardscape show that the texture stretches to stay confined within the shape. At least that's my interpretation.  eg if you apply a brick or other grid texture it pulls the image around like a rubber sheet.  The "grout" lines become wider or narrower.  Interpolated option for the hardscape smoothes the  hardscape shape, but does not correct the texture stretch.  One workaround is to extract the top surface of the hardscape and apply texture to that new NURBS surface. Or extract the long edges and loft.  Might require disable texture and fill on the hardscape to prevent z fight interference between the new NURBS and the orig.

 

-B

  • Like 1

Share this post


Link to post

@Benson Shaw thanks for the tips, I’ll have to experiment with these aligned hardscape more and will try your work around.  I might have to suggest a wishlist item if this is actually how the tool works, could get ugly patching hardscape on a large project with many of these objects.

Share this post


Link to post

I managed to correct this by editing the object's render settings in the OIP.

In the render tab, I changed the part to "main slab texture..."

This gave me access to the typical ability to change the map type settings, I changed it from default to auto-align.

This fixed the problem.

I then set it back to overall class texture so it would behave like my other hardscapes.

No stretching and looks the way it should 🙂

 

 

539745350_ScreenShot2020-06-23at6_38_04PM.thumb.png.df023ee9a8b099ac6c9e3a76fb6914f3.png

  • Like 4

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...