Jump to content
Don Seidel

Mac Silicon OS and VW

Recommended Posts

I have VW 2021 only on M1.

 

I did not have that reawakening with Enterprise ever before

on Trash Can with Big Sur or earlier OS.

 

Usually I have the old Space Navigator connected to Mac.

And that is so sensitive that it would awake the Mac when

I slightly knock on the desk ....

 

But preventing from going to sleep is a total new experience

for me. So far Enterprise was problem free.

Share this post


Link to post
On 2/18/2021 at 12:17 PM, zoomer said:

 

 

 

Oh, that won't be that easy !

(Although not impossible)

Officially there is only support for 2 external Monitors on M1 Mini.

(1 external Monitor each for MB Air and Pro)

 

This may help :

https://www.macrumors.com/2021/02/15/displaylink-manager-native-m1-support/

 

I've now got three monitors working just fine.

The hard bit was working out which cables/adaptors to buy.

One of them arrived in the post half an hour ago, I plugged it in, downloaded the Displaylink manager from their website, and it worked first time. Maybe I was lucky.

 

When I look in the mac's "system report" the three displays are listed as normal; I thought that maybe only the natively connected ones would show here, and the other one would be hidden behind some kind of DisplayLink interface but it's not. I can arrange all three as normal in the Mac settings. Maybe I am yet to discover some bugs but I'm impressed with how well this works. As you'll see from the screenshot, none of my monitors are 4k, so it is not the most challenging setup.

 

For the record for anyone else interested in trying this, here is how I have them connected:

- Main monitor direct to the HDMI port in the Mac mini

- Monitor 2 is connected "natively" but via an adaptor (this one https://www.startech.com/en-gb/cards-adapters/dkt30chvcm £15 for a secondhand one on eBay) on the VGA port. That adaptor is plugged into one of the Mac mini's USB-C ports.

- Monitor 3 is plugged into a docking station (this one https://www.startech.com/en-gb/cards-adapters/usb3sdockhdv £40 secondhand on eBay) and this is the one that uses DisplayLink. That docking station is plugged into the USB3 port on the other adaptor (I didn't really think this would work but it does) and that means that I still have a free USB/thunderbolt port on the M1 which I will very likely use for a fast external SSD (because I went for the M1 version with only 256gb SDD).

 

1459306244_Screenshot2021-02-22at11_31_23.thumb.png.46ac3a8e384cba4a5e864ac8d482d4dc.png

Edited by line-weight

Share this post


Link to post

Unfortunately I have to put my transition to M1 on hold for now, because of the problems I'm having with the 3dconnexion spacemouse.

 

I've tested VW2020 and VW2021.

 

There is the problem of random jumps to space, that has been described by others.

 

But there's a more general problem, that navigation using the 3dconnexion device is just a bit unpleasant because it is jerky and not smooth. If I use it for a while, and then go back to my old mac pro running VW2018 and Mojave, my old machine feels much superior just because it allows me to smoothly navigate in 3d.

 

I'm not sure if the problem lies with Big Sur, with the M1, or with Vectorworks. I am a bit tempted to point the finger at Vectorworks, because when I tried VW2021 on my old machine, I also felt the navigation was jerky.

 

A bit frustrating, because there seems to be nothing I can do except wait until there's a sign that things get fixed. This is not the first time the 3dconnexion device compatibility has caused me problems upgrading - there were various problems that showed up with VW2017 if I remember correctly.

Share this post


Link to post

In the past I never noticed any differences between Mouse or 3D Navigator's

View Navigation. But in the last 2 years, so long before Big Sur or Apple Silicon,

I sometimes saw in very crowded files, that one or the other input method lagged

while the other works smooth.

I think ist started with mouse input lagging while 3D navigator was still smooth.

 

Lately I saw it the opposite way, mouse no issue, 3D Navigator nearly unusable.

 

I just can't remember when and where, if VW, Bricscad or Modo, Windows, Big Sur or M1, ....

Share this post


Link to post
11 hours ago, zoomer said:

In the past I never noticed any differences between Mouse or 3D Navigator's

View Navigation. But in the last 2 years, so long before Big Sur or Apple Silicon,

I sometimes saw in very crowded files, that one or the other input method lagged

while the other works smooth.

I think ist started with mouse input lagging while 3D navigator was still smooth.

 

Lately I saw it the opposite way, mouse no issue, 3D Navigator nearly unusable.

 

I just can't remember when and where, if VW, Bricscad or Modo, Windows, Big Sur or M1, ....

Hm, it's something I see in VW2020 and VW2021 (but not VW2018) when I try on my Mojave mac pro. And then on the M1 it seems worse again.

 

So, is it something I just have to live with if I move on from VW2018.

Edited by line-weight

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...