Jump to content

VW imageprops texture export issue or something more nefarious?


Recommended Posts

This is such a vexing problem, I had to run through some more experiments before retiring for the night.

 

All of my effort had been around creating image props, so I started there.

I then decided to make a new Plant Object using the same texture I had been using all along, only having VWX make the imageprop as part of defining the new plant.

 

This yielded a successful result, though it does not solve the greater problem I identified earlier in this thread with regards to how VWX exports alpha channels applied to 3D model textures and standard user created image props.

 

I have no idea of what is going on under the hood, but maybe there is an explanation that can be offered?

Still, the 3D model issue is unresolved, so I hope to hear something on that @Dave Donley when you have a chance.

 

322056125_ScreenShot2020-06-19at1_29_03AM.thumb.png.3cdbbba1db737404717ab9e35ccd49b5.png1851711232_ScreenShot2020-06-19at1_29_35AM.thumb.png.98d6cff2c74668e0b6cd44063fbdd15a.png

  • Like 2
  • Confused 1
Link to comment
  • 2 weeks later...
  • 3 weeks later...
  • 2 weeks later...
  • 10 months later...

Hey,

 

This was a year ago, you've probably nailed this by now... but if not maybe this is helpful?

 

https://twinmotionhelp.epicgames.com/s/question/0D52L00003bNsLISA0/hi-i-am-trying-to-apply-a-alpha-transparency-map-to-a-leaf-material-but-only-get-the-attached-result-i-have-checked-the-opacity-setting-in-twinmotion-but-still-dont-get-the-transparency-any-help-appreciated?language=en_US

 

I'm trying to find a youtube video I saw on this.....

 

Pretty sure it's a Twinmotion quirk rather than a VW quirk, although the direct export to datasmith seems to be pretty good on the projects I've been playing with. Apart from the glass... but that's probably me!

  • Like 1
Link to comment

Also, as backward as it sounds, grab objects / materials / textures from Quixel Bridge, and bring them into VW.

 

I'm really hoping that VW partners with Quixel, so we can use the same assets from start (VW) to finish (TM). Redshift has already done this, and they're part of the same software family so it's not that far of a stretch.

  • Like 1
Link to comment

Twinmotion doesn’t understand the opacity map, the black and white image used to create the transparency, in VW.

 

I also believe that quite a few of the shaders that can be used when creating textures are specific to Renderworks and don’t export out, hence the reason some textures come out looking different. So if textures made by VW in the resource browser use these, they also won’t export out the shaders.

 

It’s quite easily fixed in Twinmotion with no issues, this guys vid is quite good, though I’m sure I saw another one somewhere but can’t find it right now.

 

I don’t think there is anything to fix. The two programs just work differently for transparency as far as I can tell….

 

 

Link to comment

@JazzLX appreciate your interest in the problem, but that's not the issue.  Your video shows how to make a PNG with a transparent background.  I already have those, 1000s of those and do not use the black and white opacity map 🙂  Twin Motion is not using the black and white opacity map either, you can delete them from the C4D export and it has no effect on the Twinmotion import.  The problem is Vectorworks is adding a black background to my carefully crafted PNG textures during the export via C4D.  Interestingly enough, Vectorworks does not vandalize the textures that shipped with the software, just user created ones, even when they are built exactly the same as the stock textures.  Perhaps the software is just being vindictive for having the audacity to use my own textures?  I did post a laborious work around in this thread, but I have yet to hear a reason why Vectorworks treats user textures differently than default textures provided with the software.  Any ideas on that?

Link to comment

I don't think that VW has turned into Skynet just yet.... maybe in future updates?

 

Perhaps, rather than it being the export that is screwing with the textures, it is the way it imports and sees the alpha, converting it to the black/white opacity map for use within software, therefore that's what it exports?

 

I highly doubt that VW differentitates between user textures and shipped textures, so they must not be built in exactly the same way, probably something under the hood somewhere.

 

It clearly isn't just the VW import into Twinmotion, as there are quite a few videos dealing with the issue in Twinmotion. Out of curiousity, have you tried using the direct export to datasmith function? Maybe it's fixed there...?

Link to comment
4 hours ago, JazzLX said:

I don't think that VW has turned into Skynet just yet.... maybe in future updates?

 

Perhaps, rather than it being the export that is screwing with the textures, it is the way it imports and sees the alpha, converting it to the black/white opacity map for use within software, therefore that's what it exports?

 

I highly doubt that VW differentitates between user textures and shipped textures, so they must not be built in exactly the same way, probably something under the hood somewhere.

 

It clearly isn't just the VW import into Twinmotion, as there are quite a few videos dealing with the issue in Twinmotion. Out of curiousity, have you tried using the direct export to datasmith function? Maybe it's fixed there...?


Based on your responses, its clear you have not gone thru the exercise of exploring this specific issue.  It’s not a twin motion issues, it is a Vectorworks problem with how it exports.  Datasmith and videos on the internet don’t fix it either.

  • Like 2
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...