Jump to content

How to get rid of decimal places with #Landscape Area#.#area# on a data tag

Recommended Posts

Hi all. I am still having trouble with decimal places on the data tag, especially with #Landscape Area#.#area# and plant quantity.


The problem: Too many decimal places on a data tag. I want to get rid of all decimal places. Pretty obvious this is not governed by the overall units setting.



I followed the solution in another thread (See below) to remove decimal places for plant quantity. But similar approach didn't work for #Landscape Area#.#area#. No matter which Number Format I choose, the decimal places remain on the data tag.


Any idea?





Screen Shot 2020-05-15 at 18.09.11.jpg

Link to comment

I believe you have to add the formatting into the data tag itself.


Either Edit the Tag Style or if you only want to change it for a single tag convert it to Unstyled and then edit the tag.


Bottom of the OIP click the Edit Tag Layout button.

Select the text block that represents the field you want to change the formatting for.

Botton of the OIP click the Define Tag Field button

In the dialog box that opens

    delete the "formula" that is currently in the Current Tag Definition Field

    set the units to something other than Document Preferences

    set the Precision to the number of decimal places you want.

CLICK THE ADD TO DEFINITION BUTTON (Yes, I am yelling because about 90% of the time I forget this step and have to do the whole thing again). ;-)

Click OK

Click Exit Tag Layout Edit


Once you figure out how it works, you can actually just type for format you need into the Current Tag Definition field.



  • Like 1
Link to comment
  • 7 months later...

I’m trying to do the same thing with Area and Function in the Space Tool Label (not a data tag):




For Area, I would like to add a separator.


For the function (Mac Occupancy), I would like to remove decimals.


However, I can’t seem to edit the Record Format Connection. Text, Number, and Integer seem hardwired in there… 


Link to comment

OK, I’m sure it’s only a matter of time before this bites me in the arse but here’s a workaround:


1. Change document units for Area > Unit Mark to a [space] (highlighted in light blue below):




2. Add “sq ft” (or ft² or whatever you want) to the end of the Data Tag formula for:

  • Gross Area
  • Net Area
  • Load Factor



That solves everything except the thousands separator which I believe is a much deeper rooted issue:



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...