Jump to content
Developer Wiki and Function Reference Links ×

In search of Lost Plugins Utility Classes …

Recommended Posts



Maybe the subject has already been discussed, but I didn't find it on the forum.


I had once found on http://www.vectordepot.com some very useful plugins to manipulate or manage Classes.
Especially those by Petri Sakkinen and Katerina Panagiotakis.
Today these plugins are mostly obsolete with the 2020 version and I miss them in my production process.


Two plugins in particular are obsolete. They are "Assign obj attrs to class.vsm" and "class, set object default.vsm".


The first one allows to modify the attributes of an object and once the result is satisfactory, to apply these attributes to the class of the object. This was very useful and efficient when you regularly create new non-standard classes from existing classes.


The second plugin: "class, set object default.vsm", was "simpler", but very practical, it allowed to give the default class attributes to an object at once (you can do it from the attributes palette, but you can't put a shortcut in it).


These plugins are obsolete, especially because new attributes (transparency, shadow, gradient, ...) have appeared and are not managed by these plugins.


I don't know if anyone has something similar in store? or wants to put their fingers in the code, but "Assign obj attrs to class.vsm" was really a very productive plugin and I would be willing to offer a few liters of coffee to whoever could give it back to me 😉


I didn't find @Petri Sakkinen on the WEB, but I attach his plugins and his notice for those who would be interested.


Thanks in advance.





Peut-être que le sujet a déjà été abordé, mais je ne l'ai pas trouvé sur le forum.


J'avais trouvé jadis sur http://www.vectordepot.com des plugins bien pratiques pour manipuler ou gérer les Classes.

Notamment ceux de Petri Sakkinen et Katerina Panagiotakis.

Aujourd'hui ces plugins sont pour la plupart obsolètes avec la version 2020 et ils me manquent dans mon processus de production.


Deux plugins le sont plus particulièrement. Il s'agit de "Assign obj attrs to class.vsm" et de "class, set object default.vsm".


Le premier permet de modifier les attributs d'un objet et une fois le résultat recherché satisfaisant, d'appliquer ces attributs à la classe de l'objet. C'était très utile et efficace quand vous créez régulièrement de nouvelles classes non standard à partir de classes existantes.


Le second plugin : "class, set object default.vsm", était "plus simple", mais très pratique, il permettait de remettre d'un coup les attributs de classe par défaut à un objet (on peut le faire depuis la palette des attributs, mais on ne peut pas y mettre de raccourci).


Ces plugins sont obsolètes notamment car de nouveaux attributs (transparence, ombre, dégradé, …) sont apparus et ne sont pas gérés par ces plugins.


Je ne sais pas si quelqu'un a quelque chose de similaire en magasin ? ou a envie de mettre les doigts dans le code, mais "Assign obj attrs to class.vsm" était vraiment un plugin très productif et je serais prêt à offrir quelques litres de café à qui pourrait me le rendre 😉


Je n'ai pas retrouvé Petri Sakkinen sur le WEB, mais je joins ses plugins et sa notice pour ceux qui seraient intéressés.


Merci par avance.


• Set Object to Class Defaults • Older Plug-Ins I Vector Depot 20200514 205746.png

Assign obj attrs to class.vsm class, set object default.vsm Class struggle.txt

Link to comment
  • 8 months later...

Hello @Peter Vandewalle ,


I come back to you about this great plug-in.

I now use it regularly and there are three points that are not working exactly right :

1) Transparency: when the surface transparency and the line transparency have been separated, it is the line transparency that takes precedence over all the transparencies when using the plug-in;
2) Drop shadow: the custom drop shadow characteristics are not applied to those of the class when using the plugin;
3) 3D textures: when the plugin is applied to a 3D object with or without a Renderworks texture, the default 2D surface of the class switches to "without attribute" mode, therefore empty.


There you go, otherwise the plugin is really great and saves me time when creating new classes or modifying existing classes.
I invite VectorWorks users to give it a try. It also works with the 2021 version of VectorWorks.


So if you have a little time and ideas to improve on these three points, that would be great.


I remain at your disposal for any further information.


Best regards.


Link to comment
56 minutes ago, Peter Vandewalle said:

Maybe this one will do...


@version: 2021.01

@change: Peter Vandewalle 02-02-2021

  - added opacity for pen and fill

  - added dropshadow

  - forced every object in class to follow class attributes

  - fixed texture application


Object Attributes to Class_2021_01.zip 4.33 kB · 1 download


Thank you @Peter Vandewalle ,
Super reactivity 👍🏻
I test all of this and tell you if it works well.


Link to comment

Hello again @Peter Vandewalle,

I tested the modifications.
- Problems solved with 3D textures on volumes 👍🏻;
- No problem for the attributes of faces and surfaces 👍🏻;
- For the opacity, functionality taken into account, just a problem of inversion of the opacity values between the line and the surface when you activate the plugin. 100% -80% becomes 80% -100% (if you apply the plugin twice, it's OK 😉);
- For the drop shadow, is there a multiplying factor which 'applies to the values entered? And the color is not picked up correctly. I took screenshots of the values before and after applying the plugin.


Initial state :



Modifications applied:






If you need other usage feedback, let me know.


Kind regards.

Edited by Edgar RAMEL
Link to comment
  • 2 weeks later...

Hello @Peter Vandewalle,


Thank you for your work 👏🏻


Here are the results of my test.


The problem of transparency is solved, bravo 👍🏻


For the drop shadow, the problem is always there.


After using the plugin, the values are multiplied by 1000 when I use the meter as a unit.
The problem disappears when using my millimeters, so with unit 1000 times smaller ... I think the solution is on this side ...




On the other hand, the color of the shadow changes according to a process that I can't understand ...?


And then, a last question. When we apply the plugin, it changes (almost well) the native attributes of the class area, which is the desired goal.
However, it applies these default attributes to all objects in the file, and even overwrites custom and voluntarily modified attributes on some objects. Is this behavior forced or is it possible to consider impacting only the class parameters?


So much for my conclusions, don't hesitate to tell me if I haven't been clear (Google Translate plays tricks and sometimes betrays what we want to say).


If you can figure out how to solve this, it would be great 🙏🏻


Thanks again for your investment and help to non-programmers (I tried to get into Python with the Mimo and Py applications, but either I'm too old or it's not in my DNA 🙄).


Have a nice day.
Best regards.

Plugin Class.vwx

Edited by Edgar RAMEL
Link to comment

Hello @Peter Vandewalle,

No worries about the delay, I have no complaints, there are homemade bugs of
VectorWorks that have been waiting to be solved for more time 😉

👍🏻 Great, it works perfectly now! 👏🏻
This feature should be natively integrated into VectorWorks!

I didn't have any problems with the units with my tests.
I went from meters to milimeters and vice versa without any bugs.

Maybe it's just the fact that the plugin modifies well the characteristics of the class, but at the same time it overwrites the customizations brought 'manually' out of default to the objects corresponding to this same class.

As a result, if you had customized or removed the shadow of an element, changed its color, etc., the plugin would not have been able to do so. They automatically take over all the default characteristics of the class ...

But maybe we can't do otherwise ?

Thank you, thank you again very much for your time and work, I owe you.

Have a nice day.
And see you next time.

Best regards.




Edited by Edgar RAMEL
Link to comment

Hello @Edgar RAMEL


I solved the issue withe the units in the script, that's why it's working as it does. I just wanted to explain why the previous version was wrong.


The fact that the command changes the selected object's settings to class settings was also a choice that I made because it seemed logic to me. You can always remove the class attributes by hand afterwards.

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...