Jump to content
DaviesTheChair

Mirror (duplicate) Node giving strange results in 3D

Recommended Posts

Hi, I have been trying to mirror (and Duplicate) 3D items e.g. a left door and handle mirrored around the centre of a carcase to create the right door and mirrored handle. Everything works fine in 2D pla, but mirrored duplicates of the 3D extruded versions drop 50mm or so below the original. When I use the debug tool to select the input strings, everything jumps into place as expected.

 

Is this a bug, bug or simply my implementation is wrong? I'm providing Point3 x, y, z inputs with same x and different y (to create a top-plan vertical axis) and same Z=0. Using Point2 input makes no difference.

Share this post


Link to post
Posted (edited)

Thanks Marissa.

 

File attached (via separate private message) with two test Marionette versions.

The bottom one is the problem with the Mirror node.

 

The top one is my attempt to do the same with Duplicate and Move and Flip nodes - which I am also having some issues with, but that is probably just my lack of Mrionette experience getting in the way.

 

Edited by DaviesTheChair

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...