Jump to content

V12 observations - bugs?


Recommended Posts


I've recently installed 12 on my pb g3 500 640 ram 10.3.9 and i have a few quirks. Maybe it's my ancient system maybe not.

1. There is a slowness when starting shift selecting where if I press the buttons at the same moment the initial object is deselected. It seems I have to press the shift key either before or after the mouse click, not at the same time. (never a prob with vw 9)

2. The modifier keys U, I, O. Sometimes if I change the modifier to the second or third, etc position it will be stuck there for all other tools. Example: If I'm using the 2d reshape tool with the add vertex mode selected and then switch to zoom, the zoom tool will be in the interactive mode instead of the marquee mode.

3. There seems to be a general overall slowness that I did not experience in 9.

I'm going to try 12 on a newer computer see if there are any differences.

Link to comment

Did that, didn't change a thing. VW 9 is more efficient.

I really don't understand the problem with the zoom which is really agrivating. I do a lot of space bar + command zoom and to have it constantly flip on me, well it's boring.

Also snapping isn't as precise (maybe this is due to the slowness)

Frankly as far as 2d drafting is concerned (i haven't yet tried out the 3-d in 12) I don't see any huge improvements. actually for me it's a step back. I hope I'm not obliged to spend 3 grand on a new machine because it's just not in the picture at the moment.

In any case thanks for the quick reply Katie.

Link to comment

Even with VW 9, multiple select requires the shift key to be pressed before clicking on the second object - even if it's a nano second.

It could be the machine you are usisng that is causing the delay with some of the things you are doing.

I haven't heard that any version of VW post version 9 is slower than VW 9 was. I would be interrested in looking at one or two of your files.

Would you mind sending one to me and I can test it with a similar based machine ?

Link to comment


I know how to shift select. I have been doing it for about 8 years now. When I make the same movements as I make in Vw 9 as well as other programs I don't get the same results.

A few more thingys?

When I apply a fill to an object, say a rectangle, i can see the fill occuring from top to bottom. Also when I shift select the selection handles "blink"

I tried out 12 on an ibook and what a difference!!!!!

Link to comment

I figured out the mode key issue: it seems that the space bar + command zoom picks up whatever mode the current tool is in. Is there anyway that the zoom tool can remember its own state?

or is there a way to deactivate the interactive mode altogether?

This doesn't seem to be a problem with other tools.

Link to comment

I found a few more things:

Snap to distance will always default to percentage. Even after entering a fraction, hitting return or tab the radio button for percentage stays selected.

Working with viewports I can snap to points on lines, circles etc, but not polygons/polylines. With these I only get an edge snap, no vertex snap.

Does anyone else have problems with the mode buttons like I have mentioned earlier?


Link to comment
  • 2 weeks later...


We have just upgraded to VW12 and are also experiencing the same frustrations with the zoom tool switching states. I also use the 'space + apple' shortcut to zoom in and 'space + apple + option' to zoom out.

I have found that if you select the zoom tool from the palette instead of by using the 'space + apple' key the tool remembers its state so you can work around this problem by assigning new keyboard shortcuts to zoom in and zoom out. However the stardardisation of panning and zooming between VW and Adobe products is missed.

Did you find any other solutions?

I have also found that sometimes the 2D selection tool toggles the interactive scaling option on and off. I would assume this would be a similar issue of the tool remembering a state from a previous tool but so far havent been able to pinpoint exaactly what it is.

Hope this is of some help


Link to comment


I was able to get my mouse wheel functioning so I've stopped using the space bar zoom. Even though it's faster. Aparently even though my machine is above the minimum standards for vw12 2d drawing Nemetschek cannot tell me why vw12 is so slow compared to 9.5.3. which is slower than vw 8

Yi Chen in tech support said that the mode switch should not be happenning other than that tech support is absolutely no help on these issues. The response is always "ask someone else"

Have you tried volumetric properties? or the snap to distance or snapping to vertexes of polylines in viewports?

What kind of system are you running?

Good luck,


Link to comment


Volumetric properties seem to work ok although on more complex solids the centre of mass option gets greyed out.

Snap to distance contraint works with either the fraction/percentage or the distance you specify in the options.

I found that I could snap to the corners of polygons but not polylines that were in viewports. However if I double clicked the viewport to annotate it I could snap to anything as if I was on the design layer.

I currently have a mac mouse so no scroll wheel and I also have found that the dynamic zoom is frustratingly slow.

Im running a 1.8 Ghz G5, 1Gb ram on Mac Os 10.3.9 with VW12 Architect Australia.



Link to comment


I can't seem to get the engineering properties nor the volumetric properties to work. What's the trick?

The snap to distance problem I have is that you have to actually click on the radio button to change to fraction, percentage or distance. Simply entering a number in fraction doesn't change the property. Tabbing doesn't work either.

Also, could you forward your slowness problem to tech support (Yi Chen) I've been saying the same thing but they seem to think it's my aging machine.

Happy Holidays

Link to comment

For people experiencing slowdowns on old/slow machines, did you enable any of the open-gl acceleration / vector caching options to acelerate 2D performance?

Because I'd assume that on hardware that old the video card/vram would slow you down more than speed you up with those options enabled.

Also for zoom while drawing, I've always used command-1 and command-2, I don't have VW12, but I assume (and hope) that still works

Link to comment


I've got my card accelerated and 12 remains slow. Bear in mind all previous versions in recent history upon initial release, are slow. Subsequent .01 and .5 releases show noticible improvements in speed. The issue, despite postings on this board to the contrary, lies not with the configuration of user hardware but with the code. History proves that mid-version releases are simply the most stable and the fastest. Like others, I buy the upgrades to show support for the new features they offer but I continue to use the previous faster more stable version to earn a living. I still have scars from the 9.0 nightmare release so you'll have to excuse me for being a little gun shy.

Link to comment

jnr, I appreciate that, the 9.0 thing is the reason I didn't buy 12 yet.

My post was a hunch based on nothing but what was posted and my experience with those settings in 11. Even on my 1.33 GHz PowerBook, enabling the OpenGL option slows down VectorWorks. (don't get me started on that pathetic fx5200go in my 'pro' machine)

Link to comment

We just switched the company to 12 Architect today, and have noticed a couple things that I figured I would bounce off of this forum.

1) I did a batch convert from a Mac. We have some files that we created on Windows, which utilized the Sans Seriff font. We did not have this font on the Mac during conversion. After conversion, when the files were opened on the Windows machine, the text in that box was gone.

2) Spreadsheets which have a border set to none on the design layer do not show a border in Vectorworks, but do show a border when creating a PDF. I had to set the pen color to white in order to get rid of the border.

I am sure I will be adding more once we discover more.

Link to comment


Originally posted by jnr:

Like others, I buy the upgrades to show support for the new features they offer but I continue to use the previous faster more stable version to earn a living. I still have scars from the 9.0 nightmare release so you'll have to excuse me for being a little gun shy.

I remember when softwrae companies took the time to optimize their code and do basic bug testing before they shipped their software instead of setting some artificial "release date" and shipping the product, bugs be damned.

Seems to me if more customers held out waiting for a stable version instead of forking over another wad of dough just because a software company announced another update, the companies would take the time to get it right from the get-go.

Link to comment
  • 2 weeks later...


Originally posted by PVanderVossen:

2) Spreadsheets which have a border set to none on the design layer do not show a border in Vectorworks, but do show a border when creating a PDF. I had to set the pen color to white in order to get rid of the border.

If we turn off Quartz imaging this problem goes away. However sometimes (I haven't been able to reproduce this myself) if Quartz is off, schedules have other troubles printing. Apparently sometimes the lines don't show up, and sometimes they don't appear at all. It seems like their are some bugs in the way schedules and quartz interact.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...