Jump to content
  • 0
zsaunders

Instrument Class Color/Shading

Question

Hello all,

 

On multiple projects I'm working on, I have lighting devices and 3D objects which are colored/shaded improperly when the Lighting class is visible.

 

I created a new, blank document to demonstrate this behavior.

In this document is a Lighting Device and a 2D white filled rectangle that I extruded.

Whenever the Lighting class is invisible, the color/shading of other objects appears normal.

1670418418_LightingClassInvisible.thumb.png.14b9a85c9601ccef252b59dcb8eec4d5.png

Whenever the Lighting class is enabled, the color/shading of other objects is affected.

The rectangle's color now appears gray even though the attributes panel shows that it is set to white.

995325846_LightingClassVisible.thumb.png.3ad7e422907be3d48e3782d46253c5bb.png

 

Any idea why this is happening and how I can prevent it?

Thanks,

Zack

Lighting Class Visibility Color.vwx

Share this post


Link to post

3 answers to this question

Recommended Posts

  • 0

Hi Zack.

I don’t use spotlight but I would guess that when your lighting class is off there are no other lights so the openGL rendering uses a default ambient light which is a non directional “even” light setting. When you turn the lighting class on the default ambient light is replaced with the light produced from your lighting device.


I’m not a lighting expert but it looks like you need to put some ambient light into your model. You can just place a Heliodon into your scene which will help but that will  still be directional and cast shadows etc.

 

You could try turning your lights off vid the visualisation palette This should allow you to have the lighting class on but the light device not produce light.

 

Anither option is to try playing with your lighting settings or putting in a renderworks background to provide more ambient light to balance the contrast you currently have. 
 

Note also that if you have renderworks then the render texture of objects is what controls the 3D colour/texture of objects.  You can play with textures of objects using the render tab of the object info palette.

 

The attribute palette controls 2d attributes and 3D colour if renderworks textures are not being applied. 

  • Like 1

Share this post


Link to post
  • 0

@zsaunders The lighting device contains a Vectorworks light object.

When there is a light object in the drawing the default document lighting is automatically disabled.

 

  • Like 1

Share this post


Link to post
  • 0

Hello all,

 

I've found out that if I were to turn on the light and point it at the extrude, it is indeed white!

1872222005_LightFocused.thumb.png.92d352ce251ca3a7683f5d4490ee463a.png

For my drawings where I don't want to deal with turning lights on, I'm able to adjust the look in View>Set Lighting Options...>Ambient Info>Brightness.

I bumped the ambient brightness up to 90% and that did the trick when the Lighting Class is visible at least. But when the Lighting class is invisible, everything is very bright. This solution is good enough for me right now.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...