Jump to content
Pat Stanford

PIO Parameter Problem

Recommended Posts

I don't know if I have bad memory, there has been a change in behavior of PIOs, or if I have a different problem.


I created a simple PIO with 2 parameters. Worked great.

 

Using the Plug-in Manager I then added a third parameter but it did not show in the OIP.  Edited again to change the order of the three parameter and only the first two showed in the OIP.

 

Reset All PIOs. No change.

 

Eventually after trying lots of other things I edited the workspace. After saving the workspace all of the parameters showed up in the OIP.

 

VW2020 SP3.  I don't remember this behavior the last time I played with PIOs.

 

So all of you gurus out there help me out:

 

1.  It has always worked like this. You are losing your memory.

2.  It didn't use to work like that, but when I just tried it the behavior has changed. Let's file a bug!

3.  It doesn't work like that for me. You just have a personal problem.

 

Thanks,

Pat

Share this post


Link to post

It sometimes behaves like this Pat but I just tolerate the quirkiness and restart VW, Edit/Exit the WS Editor, etc. until it works. Typical of VS though. You steam along making great progress then something like this of another odd result stops you in your tracks. 

Share this post


Link to post

If memory serves me, right-clicking on the PIO and choosing Properties will force the OIP to refresh. I think I filed this as a bug a while ago, but it doesn’t affect event based or SDK PIO’s, so haven’t encountered it in a while. 

Share this post


Link to post

Hi Pat,

   You forgot option 4.

...`

4. Everything you observed is spot on; it didn't always work this way; and you are losing your memory.

 

which is consistent with programming too long and  ....  losing your memory.  : p

 

I am having similar occurrences to what you and Julian observe while editing a PIO I am currently developing. For the most part, making changes to the PIO code does not create any wrinkles, but edits to the parameter list, either adding or subtracting (and possibly reordering) parameters, results in very odd behavior – like all of my OIP buttons failing to display, and / or ControlPoint fields that I've explicitly hidden now show up. I have not been able make the PIO rectify itself, so I restart VW without even trying to cajole it to behave. 

 

I've not tried what Josh suggests, but I will when I edit my parameters again and if I get a favorable result I'll post back. 

 

Raymond

 

PS - If you do file a bug, I'll vote it up.

 

 

 

Share this post


Link to post

Thank you all. I have restarted VW and the OIP still does not update.

 

Per Josh, Right Clicking and choosing Properties shows the new parameters, but in VW2020 SP3 it does not cause an update of the OIP

 

The only thing I have found so far that causes an update of the OIP is to Edit the workspace.

 

Bug submission in Progress.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...