Jump to content

Hello Community!

This Saturday, April 11, from 9am – 1pm EDT we will be performing maintenance on the Vectorworks Community Board. During this time, the site will be unavailable.

Daniel B. Chapman

Vectorworks 2020 - Multicircuit Issues

Recommended Posts

I had a friend reach out to me for help inserting a multi-circuit symbol and getting it to work with a database and this doesn't seem to be working properly. 

 

I used the `Selecon Aurora Cyc 3` as a test case and it doesn't insert properly (it treats the light as a single). I realized this is because it has a light info record so I created my own symbol out of the parts without the record:

 

image.thumb.png.77221d8c96143e689d7bba431592dee3.png

 

When I insert this I end up with just the center cell:

image.thumb.png.3eb1cdee7324e9a3d1917fa2cbc00a31.png

 

The help pages don't indicate a new workflow so I'm perplexed as to what is going on here. The multicell unit created using the menu commands works as expected but it would be nice to have this work with instrument insertion.

 

Can someone point me in the right direction?

Share this post


Link to post

OK

 

Using the Convert to Multi-circuit will not work with what you want to do.

 

To make a multi circuit instrument, the process should go like this:

  1. Align all your lighting instrument symbols how you would like them to finally appear. They must be symbols with the Light info record attached. Do NOT convert them to lighting devices.
  2. Add a 3D locus at each end of the strip and make sure they are both at z=0
  3. Select all three symbols and the loci and Go to Top/Plan
  4. Convert to a symbol
  5. From the resource manager attach a light info record to the new symbol. You do not need to fill it in.
  6. Finally, edit the symbol and go to a left or right view. You will need to make sure that the 3D loci AND the hanging points are at Z=0. (This shouldn't be necessary if you make your symbol when in Top/Plan)

You're done.

 

Double-clickl the new symbol in the resource manager and you will (hopefully) see a 3 part multi-circuit instrument on your plot!

 

I hope that works for you

 

 

 

 

 

Share this post


Link to post

Multi-Circuits are still inserting correctly for me in SP3. If you find a symbol in the Content is not inserting as a Multi-Circuit, please report that symbol to Vectorworks — the bug is with the way the particular symbol is constructed, not with the Multi-Circuit process.

 

To answer the question a little differently than @markdd, in order for a symbol to insert as a multi-circuit lighting device, the following must be true:

- The symbol must contain only symbols. Use the Symbol Insertion tool to insert each cell as a symbol, not a Lighting Device.

- Each symbol must have the Light Info Record attached.

 

Attaching the Light Info Record to the composite symbol has the following advantages:

- Double-clicking on the symbol in the Resource Manager will activate the Lighting Instrument insertion tool (otherwise, you will need to select the symbol via the mode bar menu of the tool).

- The composite symbol will be available in the Instrument Summary

Share this post


Link to post

Mark,

 

Thanks for the information. I think the 3D loci are an extraneous step. I ran into a lot of issues while trying to edit a symbol afterwards and I gave up on it. I was also unable to reproduce the buggy behavior after creating some new symbols...despite the fact I was able to reproduce it consistently up until that point. I'll chalk it up to a memory error/cache of some sort and just walk away from it.

 

@JBenghiat Thanks, this is what I expected to happen the first time I created the symbol but it ended up stacking everything on top of itself. I didn't think the 3D loci were necessary and they are not. I personally don't use the multi-circuit instruments as I've always found them buggy and silly (and a simple duplicate array is good enough, but when I'm teaching someone else I like to show them the preferred workflow).

 

If we recreate it I'll file a bug report.

 

My workflow was (2D only):

 

  1. Insert the parts as symbols, not instruments
  2. Select them all and make a symbol
  3. Attach the Light Info Record from the Resource Browser
  4. Insert

The broken library symbol is the Altman `Light Instr Selecon Aurora Cyc 3`. I deleted the clamps, cleaned it, made it from scratch and it works now, but I can't seem to fix it even by editing the symbol and removing everything but the light symbols. Any additional insight is welcome, honestly this isn't that high a priority, but it is quite frustrating.

Share this post


Link to post

The Aurora symbols don't have loci inside them (like any other 3D Lighting Instrument Symbol) which they will need to have in order to work properly. The hook-clamp is also a red herring and should not be there. 

 

The extra Loci are something I had to do to make a multi-circuit device work once a while back. Since then I have always done it. Maybe that was a bug that is now fixed....

 

Share this post


Link to post
Posted (edited)

I have remembered the rationale for LOCI

 

If you create the multi-circuit instrument without loci, the resulting instruments will lose the ability to focus (pan is disabled anyway)

 

I have no idea why exactly, but I seem to have picked up tha advice from somewhere. Probably from @klinzey at some point who has drip-fed me with nuggets of info over the years!

 

This is also the case with lighting devices that you want to group together with the Convert to Multi-circuit... command on. Add a loci either side of the grouping and the devices will continue to focus. Otherwise they will lose all of that functionality.

Multi-circuit test.vwx

Edited by markdd

Share this post


Link to post

Ah, a good amendment to the rules. (I usually don't bother with 3D for most of my multi circuits)

 

The rules above still stand for the minimum requirements for a multi-circuit composite symbol, however:

- If you want the 3D component of the multi circuit to tilt to a focus point (or the default angle in Spotlight settings), add two 3D loci through with the lighting instrument's tilt axis passes.

 

Multi-circuits seem to assume a two point attachment and only tilt. There's a few cyc units out there that can pivot from a single clamp, but that seems to be outside of what VW can model.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...