Jump to content

Video Camera Tool

Recommended Posts

I am in the process of creating a library of Video Camera setups that our company uses and have run into what I feel is a bug.

I spent 30 min on the phone yesterday with Service Select Technical Support and was told that the Video Camera Tool is working as intended. I am reaching out to other users so that maybe someone can offer me some insight and knowledge as to why what I view as an issue is considered “working as intended”.



-Create new blank document

-Select Video Camera Tool from Tool Sets

-Select a Lens, Select a body and Select a Stand from the Tool Bar

-Click once in the Drawing Area and Click a second time to set the plugin object

-In the OIP make changes to settings if necessary

-With the plugin object selected, In the Menu Bar select Modify Create Symbol.

-A Dialog window opens, Give the symbol a name and select convert to plug-in object and click ok

-A red symbol is created.

-Double Click to acquire the red symbol in the resource manager

-Click once in the drawing space and Click a second time to set the symbol and all is good.

-in the Menu Bar Click File, Click Save into any one of the multitude of library folders that Vectorworks has given us(Vectorworks Libraries, User Libraries, Workgroup Libraries)  and Close the file.

-Click on the Action Button in the resource browser and Click Refresh Libraries or restart Vectorworks


I now have a red symbol in my Library with all of my settings. Now I can now save time in all of my future drawings by NOT having to follow that process of setting up a camera again. One would think!


Next Process:

-Create new blank document

-Find my newly created red symbol in the resource browser

-Double click on it to acquire the symbol

-Click once in the drawing space and Click a second time to set the symbol and all is NOT good.


The OIP is completely loaded with all of the correct information but the graphical representation of the object is completely gone and replaced with a rectangle that has 2D and 3D geometry.


In order to fix this issue, you have to reselect your lens, body and stand.


I have tried different forms of insertion such as copy and paste and importing the red symbol into the document first before placing it. All with the same result.


I guess I am frustrated more on the fact that a Service Select representative told me yesterday that the tool is working as intended and the process that I should follow is to import the symbol elements of the plugin symbol and the record formats that go with my red symbol first before inserting my symbol. I feel this defeats the purpose of having a Plugin Symbol.


Also, one other item I noticed is that while I am working in an imperial document all the OIP information is in metric. I thought that Vectorworks automatically did all of the conversions.


If I am out of line here and having a knee jerk reaction to this, or this has already been discussed on the forum somewhere, can someone please let me know, It would be greatly appreciated.

Link to comment

I've had the same experience working with red symbols and the Video Camera tool. Thanks for bringing this up, I really thought it was me.


@RMDiekmann have you experimented with custom camera stands as well? I created one that places the camera at a more realistic height for event industry use in a long throw situation. I find that the 3D locus used for camera body placement seems to mysteriously disappear when I import the red symbol.



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...