Jump to content
t-bud

SetRField and Lighting devices

Recommended Posts

I have some scripts that place data into Lighting Device Parameter Fields.  

 

WIth VW2020 SP2.1, the changes do not seem to be written into the .XML for export into Lightwright.  I have to do a complete export for the updated information to be sent to LW.  

 

I did not notice this behavior in VW2019.  Is there a function that I need to call now for VW to register the changed data for inclusion in the .XML?

Share this post


Link to post

Thanks J,

 

ResetObject() does the trick.  

Is there documentation anywhere that you know of, that describes the Export Type options of the SL_Export Procedure? 

Share this post


Link to post
3 hours ago, t-bud said:

Is there documentation anywhere that you know of, that describes the Export Type options of the SL_Export Procedure? 

 

Not that I know of, though I'm guessing the options are probably full and regular export, so 0 and 1 or 1 and 2.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...