Jump to content
  • 0

"The cells you are trying to change do not allow pasting"

Anthony Reed



I'm using Vectorworks 2018 SP6 (Fundamentals, Spotlight, Renderworks). For the last several months I've been maintaining a manual link between Vectorworks and Excel by going through a process of importing a CSV made from Excel as a worksheet and pasting values one column at a time into a database worksheet linked to a symbol record format. I made a couple of other posts with problems I had when I was first getting started with this project but unfortunately got no help. Once I finally got it working, albeit cumbersome, it had no real issues. I haven't needed to update either the Excel file or the Vectorworks file for a couple months but now I have new information to incorporate. All of the steps leading up to this point have been identical to what I did for months, but now I get an error message when I try to paste cells into this worksheet: "The cells you are trying to change do not allow pasting." I've never seen this before, doing it this way has always worked up to this point. 


Here's my troubleshooting process so far:

  • Close without saving and restart computer
  • Check it's the exact same number of cells copied as attempted to paste into
  • Check file isn't accidentally open read only somehow (I can change anything else)
  • Make sure correct Excel file was opened (I even opened an older version but got the same error)
  • Try copying small groups of cells, which worked but only sometimes (also isn't a realistic option for 17 columns and nearly 2000 rows)


Not sure what to try next. Any help is appreciated, thank you

Link to comment

2 answers to this question

Recommended Posts

  • 0

Solution was quite simple and I'm a little embarrassed I didn't think of it, but I'm leaving this post up in case someone comes along looking for the same answer.


A handful of symbols across several layers had accidentally locked along with some reference geometry when the file was last open. I made a custom selection vectorscript to select all objects with that record format and ran it on each layer to look for symbols with the grey selection boundary. 

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...