Jump to content
  • 0
Christiaan

Data Tags going blank

Question

I'm experiencing a bug where some of the Data Tags in my Section Viewports go blank. I've noticed if I drag the handle with the yellow exclamation mark slightly it will regenerate the text. Has anyone experienced this and figured out a way to regenerate the text to all Data Tags at once?

 

1286412096_Screenshot2020-01-24at09_47_42.thumb.png.7d0c80fef321343b182cc2dc957c2c3d.png

 

585888706_Screenshot2020-01-24at09_51_20.thumb.png.c4037b01bb50973f9d3a1e731f56b817.png

Edited by Christiaan
  • Like 1

Share this post


Link to post

5 answers to this question

Recommended Posts

  • 0

Same here,... and I am also experiencing that data tags are not reliable on refreshing.

I am having issue when source data is changed (in this case it is class description information change) existing data tags in drawing will not update class description change immediately ....? 

Share this post


Link to post
  • 0

Any idea what is triggering the tags to go blank @drelARCH. I wondering if editing the object Style does it. What kind of objects are you experiencing it (going blank) with? Windows? Or other objects too?

Share this post


Link to post
  • 0

Next time you see this, see if this script resets the DataTags.

 

Procedure ResetDataTags;

{January 22, 2020}
{©2020 Patrick Stanford pat@coviana.com}
{Licensed under the GNU Lesser General Public License}

{Script to reset all DataTag objects in the drawing.}
{Edit criteria to limit scope}
{No warranty expressed or implied. Use at your own risk.}
{Backup and test for suitabilty for your use.}
{Here be Dragons. For external use only.}


	Procedure Execute(H2:Handle);
		Begin
			ResetObject(H2);
		End;
		
Begin
	ForEachObject(Execute,((R IN ['Data Tag'])));
End;

Run(ResetDataTags);

 

  • Like 1

Share this post


Link to post
  • 0
7 hours ago, Pat Stanford said:

Next time you see this, see if this script resets the DataTags.

 

Thanks Pat, I thought you might pop your head in here. The script didn't regenerate the tag text. It seems it's not enough to reset them but that they have to be re-attached to the object, which is presumably un-scriptable, unless there's a way to script the dragging of the end of the leader slightly.

Edited by Christiaan

Share this post


Link to post
  • 0

Try this. Change the Reset Object(H2); in each line to UpdateStyledObjects(GetPluginStyle(H2));

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...