Jump to content
  • 0

Objects disappear when rendering


Tanner Shelton

Question

A very big issue I have been having recently. I was working in a file and everything appears just fine in Open GL, but when I render, half of my objects disappear and are no longer visible. They are still there, because if I hover over them, their outline is highlighted. Then I go back to Open GL and they are still there (This is all from the normal 3d view, not a viewport) There aren't any classes hidden. It gets progressively worse every time I render again. The only way to fix it is to close vectorworks and reopen the project. Then it'll work just fine for the first render, then have issues right after that.

 

I usually use realistic interior fast or realistic interior final, but I have also tested it with fast renderworks and final quality renderworks with the same issues. I have a lot of geometry in the scene, and a lot of lights, but it still should be able to handle this. I've had this issue in multiple files recently. Any thoughts?

Link to comment

8 answers to this question

Recommended Posts

  • 0

What happens if you put the render view into a viewport on a sheet layer? Do you then still have these issues?

 

How much is a lot of geometry? 10,000+ objects, 100,000+, 1 million+?

 

What kind of geometry? If the objects are quite complex and you have a lot of those I can imagine that this may cause issues in certain cases.

 

If things get progressively worse with each render it might be a memory issue where memory is not properly released after a exiting render and just keeps filling up to the point you have to restart VW. The GPU shouldn't be the issue in your case (at least not in theory).

Link to comment
  • 0

The render works perfectly as far as I can tell in a viewport. I haven't noticed issues there. For geometry, I'm not sure exatly, I have some complex ceiling pieces and then quite a few trim pieces along the walls. I also have a lot of lights. It isn't the most I've ever had and one that had probably twice as much geometry didn't have any issues. I have 32 gbs of 3200 ram.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...