Jump to content

Wall lines and Display Extents above cut plane

Recommended Posts

Ok I'm stuck. I'm trying to get dashed wall lines to draw in a viewport with Display Extents above Cut plane active. 

So In the Door settings I'm selected a class with a dash style and checked "show wall lines" I get a nice dashed line in TOP/PLAN in the Design layer (fig 1). I have various objects at different heights in the she model--some completely below the cutting plane, some above, some passing through. I've used the clip cube to generate a horizontal section viewport. In the setting I have checked "Display Extents above cut plane" and in the object Display by Class window I've set the "Above" to hidden line and set it to a fine dash.  

All good. Update the viewport and it looks exactly like what I want--solid no fill for objects below, default black fill for objects cut through and fine dash for the objects overhead. 

Except! I can't seem to get any settings that show the dashed lines in the Hidden line viewport. The wall dash only seems to appear in Top/Plan on the design layer. 

Is there some setting somewhere that can allow this to show in the viewport? 

DL Top Plan.JPG



Link to comment

Answering my own question again. 

Here's what I did. I deselected "Display 2D Components" from the OI. That made the door object disappear. Then I applied the same settings for the class with the wall and door as I did for the others and I got my dashed archway.  BUT, What if I want a shutter in there? I went back to the design layer and added a door to the archway. The door is invisible unless I re-check "Display 2D components" I get the door symbol but the dashed wall lines disappear again.

So I deselected Display 2d again. Back to the DL and checked "Show 3D open" in the 3D settings. Update the viewport and I've got the wall dash again and the open door but no arc swing. 

Lots of tick boxes and settings to fiddle with. I got close to what I wanted but is there and easier way? 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...