Jump to content

Reshape handles are missing


MHBrown

Recommended Posts

Objects I click on do not show the little blue handles. Nor do they stay enclosed in an orange outline (which I'd LOVE to disable somehow). Please see the attached screen shot that shows, I think, that I am not in the oft-triggered "disabled" mode by clicking "u" my mistake. I am in a mode that should allow selections. Also, note that my cursor arrow is white. It should be black. Why is it white? I'm finding VW 2020 to be pretty buggy and I'm not happy. Can someone tell me what I'm doing wrong? I need to know when I have selected something. MacBook Pro 16", Catalina, VW 2020 SP latest version (today's).482328799_ScreenShot2019-11-26at3_05_50PM.thumb.png.a58da33a4a88129f910ecc2291e8c905.png

Thanks,

Mike

Link to comment

I think it must be a file corruption bug @PVA - Jim as if I create a new file the reshape handles show up fine. Here is an example screen grab video. As you can see, its not my selection tool settings and it is really annoying when trying to work with site pad objects as you have to guess where the handles are for editing the slope. Why does this always happen to me when I'm trying to get finished for a deadline...😭

Edited by Will
Mention Jim.
Link to comment

Update on this for anyone else experiencing the problem. Export the file to VW 2019 open the file in VW 2019 then make a minor change e.g draw a line. Save the file. Re-open the file in VW 2020. Reshape handles are back. It is apparently a bug and they are looking into it.

Link to comment
  • 1 month later...

Will, this is not a "bug" as in some minor inconvenience. It makes VW 2020 unusable. Un-usable as in "not able to be used." Imagine a car that has a "bug" in that the engine has been filled with cement and, for good measure, set on fire. It that a "bug" with the car? No. It is a serious problem. At the moment I'm looking at creating a curved metal tube chair leg using a carefully constructed NURBS curve consisting of bends and straight sections. It has to be right. Now, why don't you tell me how I'm supposed to manipulate this--or another object--without seeing the control handles? I might as well turn off the monitor. I do not have another version of VW on my computer, nor should I have to. It has been over a month now since your post above and I have not seen any action on this major, major problem. "Bug" indeed. All of VW's great tools are essentially neutered while I wait or struggle, blindly monkey-clicking all around the vicinity where the handles should be, but. are. not. As you can tell I'm a little upset by this and I apologize for my stern affect, but I feel I need to light a fire under someone. Please fix this.

Link to comment

This problem apparently appeared in 2010, nearly a decade ago. It will probably never be fixed. Here is a file that has all the problems: objects are still shown in groups, The paths of the chair leg extrudes have no handles. They are NURBS curves, but any poly line has no handles. Control handles are missing on 2D and 3D objects (just the annoying yellow outline that I WISH I could turn off.)

 

Please do NOT say that this is all because it is a file created in an earlier version. EVERY file from EVERY user except those new to VW was created in an earlier version.

 

Stacking Chairs, Sonic A1.vwx

Link to comment
1 hour ago, MHBrown said:

This problem apparently appeared in 2010, nearly a decade ago. It will probably never be fixed. Here is a file that has all the problems: objects are still shown in groups, The paths of the chair leg extrudes have no handles. They are NURBS curves, but any poly line has no handles. Control handles are missing on 2D and 3D objects (just the annoying yellow outline that I WISH I could turn off.)

 

I can confirm that the file exhibits all the things you describe. These are exactly the types of issues I see all the time and the reason for this wish years ago -

And also this wish about beta testing in user submitted files - 

 

 

I've filed a lot of bugs over the years, but things like you're file exhibit are hard to submit and are almost impossible to reproduce. They definitely come from the conversion process of moving a file forward into a new version.

 

Not sure what to suggest but I definitely sympathize.

 

Kevin

 

 

Link to comment
  • Vectorworks, Inc Employee

Thanks for the file, Mike

 

I played around with the file and found a way to get them to show on my system.  Please try toggling Multiple View Panes on and off and let me know if it corrects the issue for you.  Hopefully this will help you deal with the issue and it may help the engineers find the cause.  If you ever notice what triggers a file to get into that state, please let us know as well.

  • Like 1
Link to comment
  • Vectorworks, Inc Employee
12 minutes ago, Kevin McAllister said:

Wow, good sleuthing Matt! That worked on my system..... The handle system hasn't been moved over to the VGM yet, has it?

Kevin

 

I have no idea about the handle system and the VGM.  I'm not sure this is a VGM thing.

 

13 minutes ago, MHBrown said:

Thanks, Matt. I'll try that. I never use multiple view panes, but lately I've entered into it by mistake a couple of times. Maybe that is it. I'll try it out.

 

10 minutes ago, MHBrown said:

Hmmm...that seems to have brought the handles back.

 

Good news!  Yeah, I was wondering if I could reproduce the problem somehow by using Multiview.

 

10 minutes ago, MHBrown said:

Thanks! I wonder if it will help with the fillet tool suddenly saying my extrude is locked and cannot be executed.I'll check and see if it helps the Other Objects in Groups problem.

 

Hmm... This I have no idea.  Worth a try though.

 

Link to comment
  • Vectorworks, Inc Employee
1 hour ago, Will said:

Hi @Matt Panzer, I filed a bug through bug submit back when I made my original comment, with an example file uploaded. Not sure I have a copy of the file in that state anymore, but it should be in your system somewhere.


Thanks Will.  I’ll look into it when I get back to the office later this week.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...