Jump to content
Charlie Winter

Vision on macOS 10.13+ not executing commands on mouse click.

Recommended Posts

I've frequently encountered issues with mouse clicks not registering when attempting to execute commands such as [Select; Flyover; ellipsis in Properties window] in Vision 2020 on my iMac. 

 

@bbudzon Is this a known issue?

Share this post


Link to post

I've seen two issues related to mouse clicks. One is clicking in the viewport and the other is clicking UI elements. It seems like the issue you are experiencing is with UI elements. I think we have a ticket internally for the viewport but not for the UI.

 

One deep rooted design choice that was made well before VW acquired ESPVision is that our renderer runs in the same thread as the UI. This means that when the rendering slows down, the UI does as well. We've been meaning to address this for some time but I'm not sure management has placed a proper priority on this. I'll pass your information along in our next meeting. The more users that are experiencing this, the more of a priority this issue will receive!

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...