Jump to content

Hello Community!

This Saturday, May 30, from 9am – 12pm EDT we will be performing maintenance on the Vectorworks Community Board. During this time, the site will be unavailable.

  • 0
willofmaine

Polygon Paint Bucket Doesn't Work in Section VPs

Question

Oh no!!  It seems that in Vectorworks 2020, the Polygon Paint Bucket (the "2D Polygon Tool: Inner Boundary Mode") does nothing in Section Viewports?...  In Vectorworks 2018 and all previous versions, it works fine, where I've used it extensively to "punch" my building elevations.  PLEASE FIX THIS!!!!!!!!!!!!!!!!!!!  (Or, if I'm missing something, let me know what it is...).  VWIS173

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 0

I'm not able to reproduce this. I created a simple section which looks at some walls, doors and Windows, and I have been able to use the Polygon tool in Inner Boundary Mode without any problem.

 

I had another customer who reported a similar problem. When I examined the file, it turned out that his geometry was a huge distance from the internal origin in the file. Once the geometry was cleaned up (there were plenty of things in the file that were a huge distance from the model itself and were not required in the file at all - we deleted them) and centered (we used TOols > Origin > Center Drawing on Internal Origin), the tool behaved perfectly.

Share this post


Link to post
  • 0

Hi Tamsin,

 

In both of the above attached files, the user and internal origins are coincident, and the geometry straddles 0,0.  In the VW 2018 file (using VW 2018...), the Polygon Tool > Inner Boundary works as expected.  In the VW 2020 file, nothing happens.  Not even a spinning beach ball like it's trying to do something.  Both of these files were created from scratch using the "blank document" option in their respective versions of Vectorworks.

 

Thanks!

Share this post


Link to post
  • 0

Hi @willofmaine, What version of 2020 are you using? I noticed this in 2020 when it first came out but the issue has been resolved in SP1 I believe. Have you tried updating to the latest version?

Share this post


Link to post
  • 0

Hi Tony,

 

I'm using 2020 SP1, build 512839.

 

This issue also seems to apply to the Outer Boundary Mode as well.  Vertex mode is fine.

 

And for both the Inner and Outer Boundary Modes, it seems to apply both for objects drawn directly in the viewport's annotations space, as well as for geometry that's on the design layer and rendered in the viewport.

 

Thanks!

Edited by willofmaine

Share this post


Link to post
  • 0
48 minutes ago, willofmaine said:

In both of the above attached files, the user and internal origins are coincident, and the geometry straddles 0,0. 

 

Were there files attached to your post? I don't see any.

 

Kevin

 

Share this post


Link to post
  • 0

If I blow away the Vectorworks Preferences in Application Support and try again, I can get the Outer Boundary mode to work on a couple of rectangles drawn in the viewport's annotations.  But Inner Boundary still doesn't work, and neither works for geometry from the design layer...

Share this post


Link to post
  • 0

Actually, when I go back to my original preferences, that's all still the same: the Outer Boundary mode will recognize two overlapping rectangles but, otherwise, neither mode seems to work.  So I guess changing the preferences actually made no difference at all...

Share this post


Link to post
  • 0
43 minutes ago, Tamsin Slatter said:

It's working perfectly for me in your file. Not sure what else to suggest.

 

Tamsin, which version of OSX are you currently running (is your signature correct)? It doesn't work for me here in VW2020 but it does work in VW2019. I am running 10.13.6 which is the same as willofmaine. It may be an OS compatibility issue.

 

Kevin

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...