Jump to content
  • 0
Anthony Reed

Import worksheet command - problem with cells that start with "E-"

Question

Hello all,

 

I'm trying to import a CSV into my VW 2018 file via File>Import>Worsheet. Up until this point my workflow has been working fine, but I'm now trying to import the latest version of this CSV generated by Excel that now has cells that start with "E" and have a digit or two after, sometimes with a hyphen.  Unfortunately, it appears that VW tries to do math on those cells and replaces them with 0e+000 and displays them as 0 if there's a hyphen (see "Worksheet View of Imported CSV.PNG) or some negative number if there isn't a hyphen

 

What I've tried so far:

- Restarting Vectorworks and my machine. Doesn't seem like the kind of problem to be resolved by this but it was worth a shot.

- Using a Tab delimited worksheet instead. Same problem.

- Checking that excel exported the data properly (see "Excel view before exporting CSV.PNG" and "Notepad++ view of imported CSV.PNG"). The exported file opens in other programs just fine.

- Changing the cell format in the VW worksheet via Format>Cells... Doesn't help, and changing them to text just makes them display "0e+000" instead of 0.

- Manually typing the data into the cells (due to the volume of cells that will eventually be involved in this, it's not a long term option but just as a test). It did work though if I first changed the cell format, but otherwise didn't work. 

 

Is there a setting somewhere for reverting all cell formats to text when importing CSVs? Do you know of another setting somewhere that might cause this or some workaround I could consider?

 

I appreciate any help you can provide, thank you for your time!

Excel view before exporting CSV.PNG

Notepad++ view of imported CSV.PNG

Worksheet View of Imported CSV.PNG

 

 

EDIT - If it helps, a friend suggested I try to recreate the problem from scratch, so I made a new csv and vwx, imported it as I had been and got the same problem.

 

test1.PNG

test2.PNG

test3.PNG

Edited by Anthony Reed
adding more information

Share this post


Link to post

1 answer to this question

Recommended Posts

  • 0

To anyone who happens to stumble upon this post looking for the same answer, I haven't found a setting to disable the automatic-math that's happening, but I have found a workaround:

 

File > Import > Worksheet

Select all cells (or at least the cells that exhibit the problem)

Format > Cells... > Number tab (default tab) > Select the "Text" radio button > OK

Select cell A1 only, then reimport the same worksheet the same way

 

I'm not certain exactly how it works, but it appears that importing a worksheet while a worksheet is open overwrites the worksheet from the selected cell. Unfortunately, you can't overwrite a database worksheet this way, as that would completely solve another problem I'm having. 

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...