Jump to content
CharlottePea

Wall texture/colour either bleached out or darker

Recommended Posts

Hello,  

 

I'm pretty new to vectorworks and I'm trying to apply an image of wallpaper onto 3D walls, which I think I have managed to do by importing the image into render works textures and applying it as a class texture for wall objects.  My problem is that on one side of the room the walls are appearing way darker than the image is, and on another side of the room the wall is bleached out and just appearing white. I'm pretty sure the image I've imported is applying because when I apply a different texture the effects are the same just more pronounced.  For instance the vectorworks texture "polysilicon RT" which is a dark red brown is appearing bright red on the washed out wall and almost black on the dark wall.  And weirdly either side of the chimney breast comes out bright red but the rest of that wall black. I have put lights in the room - could that be causing this?  And if so how do I stop it happening?  Any help would be so very gratefully received.  I've attached an image which shows the wall differences with the colour the texture should be showing in the object info palette.  Thank you in advance.

 

 

Screen Shot 2019-09-09 at 12.57.45.png

Edited by CharlottePea
typo

Share this post


Link to post

Do a quick check to make sure you do not have more than one wall in the same place. Also with the wall selected make sure the texture is on the correct part; this means the right, left etc. and not on overall. Select the wall layer or class and turn off the visibility on everything else and see what it looks like with nothing else interfering (lights for example).

 

 

 

 

Share this post


Link to post

Hi Barkest,

 

Thank you so much for your advice. I have followed it and sure enough the walls look fine when they are on their own.  I then eliminated everything else to discover it is definitely electrical devices-lighting that's causing the problem.  So how can I adjust or completely turn off the illumination coming from the lights so that I still have the fitting in the picture, but it's not bleaching the walls!  Some of the lights have a light brightness scale in the object info palette.  But some of the lights I've put in don't seem to have that.  I have played around with the ones that have this and I managed to make it look a bit better by having them all on 100% brightness (see attached image), but there is still a real difference between the two walls.  I tried putting them all at 0 and it just looked like it did before. Is there a way to control the other lights?  Or an overall way to control this?  I need the lights but I'd also like the walls to not be black!  

 

Thank you so much for your help.

Screen Shot 2019-09-09 at 13.54.09.png

Share this post


Link to post

When you say you cannot adjust the light brightness it is possible that the light is part of a symbol. Right click and chose Edit 3D component

 

2.thumb.JPG.d9e5f6a69072ca041f6cd889443ccdf6.JPG

 

Once inside the component then select the light object and adjust as required. It could be that it also is inside a nested symbol  in which case right click and keep travelling down until you can isolate the light. If you find it is part of a group (group will show in the OIP) then double-click and keep going again until you isolate the light object

Share this post


Link to post

Thank you so much barkest.  You are right, they are a symbol.  I haven't managed to change the brightness of these, but I tried just deleting them temporarily and they make no difference to the problem.  Is there a way to keep the lights on the drawing but just turn off their light other than the brightness scale in the objects info?  Because as it stands I just can't seem to get the walls to not be completely different colours with them on.  And it's worse if I put all the lights I can alter down to 0 brightness.  

 

Here are the three states I can achieve:

 

The first picture is when all the lights are at 0 brightness and the symbol lights have been temporarily deleted

The second is how it looks with all the lights on 100% brightness

The third is when I turn off all the lights through organisation-classes

 

Ideally I'd obviously like to be able to control the lights properly and get rid of the extreme light and dark walls.  But in the absence of that (which seems to be where I'm at!) I'd like to just have no illumination but still be able to see all the lights because they make up part of the design.  Is that possible?  If that's not then can you suggest anything else to try and fix the lighting issue and make all the walls look roughly the same?  

 

Thank you so much for all your time to help me.  It's so appreciated.  I'm finding this hard!  

 

Charlotte

Screen Shot 2019-09-10 at 13.15.50.png

Screen Shot 2019-09-10 at 13.18.44.png

Screen Shot 2019-09-10 at 13.24.39.png

Share this post


Link to post

You can control the on/off of all lights via the visualisation pallette

 

1.thumb.JPG.af870559b2d346c2da3c1c6660890215.JPG

Share this post


Link to post

Oh wow that's brilliantly helpful, thank you. I think by turning some of them off I've managed to achieve something I can work with.  Thank you so much for all your help.  I have one last question if that's ok?  If I turn them all off the room is much darker than it is when I turn the lighting class off.  Do you know why that might be?  

 

Images attached:

1) lights turned off in visualisation

2) lights class disabled

 

Lights class disabled is much closer to the correct colours. Is it possible to just put a bit of daylight in the first one now I've turned off the lights?

 

Thank you

Charlotte 

 

Screen Shot 2019-09-10 at 13.48.39.png

Screen Shot 2019-09-10 at 13.47.44.png

Share this post


Link to post

Maybe you have some lights not in the class.

 

Also look at:

 

2.thumb.JPG.b8463ad1c0cc3bbfbcba19e4e1189405.JPG

 

5.thumb.JPG.5981f80d6dde81133ba76b0aa72ba852.JPG

  • Like 1

Share this post


Link to post

I just wanted to say thank you so much for all your help with this.  I'm already back on here re reading it all for a different room!  So thank you for sparing the time to help me out. Have a good day.

Share this post


Link to post

The other thing to look at is what the ambient illumination is set to, when all other sources are off.

Screen Shot 2019-09-16 at 10.41.43 AM.png

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×