Jump to content
Carl Burnett

Video Screen Sizing/Scaling

Recommended Posts

Hello All,

 

I have finally sorted a capture card that works with vision. 

I now want to know how I size or scale the screen or image so it doesn't duplicate as in  the picture attached, you can see that the bottom of the image also appears at the top.

 

Any help is appreciated.

Thank you

Carl1089738418_Image27-08-2019at15_56.thumb.jpg.95e6344bd6f44fdd9086e8f1ad199342.jpg

Share this post


Link to post

I'm glad you have video inputs working!

 

I'd need to let someone who knows more about VW chime in here (I'm a Vision developer), but you can adjust texture scaling in your VWX on the VW side of things.

If you are using MVR, you can simply export and overwrite the old MVR file and merge these changes via MVR into Vision. If you aren't using MVR, you should look into it!

Share this post


Link to post

Thanks bbudzon,

 

MVR? not sure what the is, so i guess I'm not using it 🙂

Im just exporting straight out of VW to Vision.

 

Thanks again for responding

 

Carl

 

Share this post


Link to post

Check out this post! MVR is pretty frickin' amazing, especially for VW/Vision users 😉

 

Share this post


Link to post

I'm having a similar issue as the OP.  Has anyone managed to resolve scaling issues with video playback? 

I've drawn a 16:9 LED video wall in VW with dims of 16' x 9'.  When I export via MVR to Vision and configure the NDI input my content shows up 1.85:1. 

The source is 16:9 ratio via VLC using NDI.tv tools as the encoder.

Any suggestions?

Share this post


Link to post
On 1/10/2020 at 3:28 PM, jeff_farrow said:

I've drawn a 16:9 LED video wall in VW with dims of 16' x 9'.  When I export via MVR to Vision and configure the NDI input my content shows up 1.85:1. 

The source is 16:9 ratio via VLC using NDI.tv tools as the encoder.

Any suggestions?

 

I would try adjust the Texture Scale/Offset H/Offset V in Vision to start. If this gets you even remotely close to the desired look then it seems like the texture coordinates coming into Vision are off. These texture coordinates come from the modeling program, in this case VW. If the texture coordinates are off in VW, it would be interesting to know what you are applying the texture to. Is this a parametric television or blended screen? Or is this a simple extrude with the texture attribute mapping tool being used to apply the texture to the mesh?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...