Jump to content
  • 0
Amorphous - Julian

Ongoing Project Sharing Issues: A record from one issue to another.

Question

We have getting a chronic project sharing problem . Model objects, viewports and sheets regularly disappear from our shared project file. 

 

No matter the size and complexity of the file, we get this problem.

 

This happens between 1-2 times a week across different projects. 

 

Anyone else getting this issue? Is this something Vectorworks can fix in upcoming releases?

 

----------------------------------------

 

Some background:

- Our shared server runs Mac OS Server 5.2 on Mac OS 10.11.6 El Capitan, with 'SMB Sharing only' turned on in File Sharing.  

- We tried upgrading our server to Mac OS 10.13 and Mac OS 10.14, but permission issues were even more severe (in both SMB and AFP).
- We then downgraded back to Mac OS 10.11

- Previously, when we ran File Sharing on AFP in Mac OS 10.11, this 'disappearing model' issue didn't seem to occur. 

- Due to other services we have to run, we had to switch File Sharing over to SMB from AFP

- Sharing files in Mac OS with both 'AFP and SMB' turned on doesn't work, and not recommended by our Vectorworks distributor.

 

 

Edited by Amorphous - Julian
Changed the title to reflect the evolving project sharing issues.

Share this post


Link to post

Recommended Posts

  • 0

hi @Amorphous - Julian,


Here to share our office experience with Project Sharing. What we’ve learned is that a lot, much more than we could believe, depends on server and network configuration and even more when it comes to save&commit which is a key operation.

We have been operating for a long time in a Mac OS Server environment, since it was still a Os and not a cheap and fragile app, as it is now. In several years - especially at the beginning - we’ve pushed it as much as we could, with advanced configurations (e.g. network home folders) and professions advice on set up and management.

 

12 months ago, planning server hardware replacement, we decided to “downgrade” from a server configuration to a nas configurations, given that we were mostly using our server for file sharing only, having slowly moved any other “service” (mail, calendar etc) to cloud services. After quite a long research (we also came from a long frustrating time with project and file sharing issues on Mac OS server,  which got worse after the new Apple file system was introduced on some clients and smb also pushed on the Apple side also), we moved to a mid-high range Synology NAS, following also testing and suggestions by VideoCom, our localized VW distributor. High range Synology NAS apparently have a better afp/smb file management.

 

Most of our issues, which were similar to yours, have since than disappeared: no more file permission issues, no more save and commit issues, much higher stability. We still find Project Sharing not intuitive in some parts (e.g. when prompting confirmation about updating wall styles to unaware users) but working on detailed drawings in a similar configuration (small firm, max 3 people one file) is much better now.

 

I must admit we still have the “fear” that sharing may not reliable especially under deadlines (due to some unexpected behaviors we experienced in the past, which drove us to crisis situations) but in the last 12 months, after the move, no big issue was raised working with Project Sharing.


Not sure this could help you, but on our side it has been quite a positive surprise, and a big step toward an efficient management of time spent on design rather than on IT technicalities.

 

 

Edited by STR

Share this post


Link to post
  • 0

[UPDATE 23/01/2020]

 

After a rather good run for 2 months, we have the issue of our ENTIRE model disappearing from the Project File again. 

 

At the time of this issue, we had two people working on the model, both Working Files for both users were intact and at around 2GB even after 'save and commit'.

 

When the third person opened the Project File, we realised the there was a problem- Almost everything in the model disappeared. 

The Project File size suddenly went from 700MB to 350MB. Screen shot of the model with all classes and layers turned on enclosed. 


image.thumb.png.5c917201f9433d3f994c3ffa28ef186c.png

 

Share this post


Link to post
  • 0
On 12/29/2019 at 5:33 AM, STR said:

hi @Amorphous - Julian,
Not sure this could help you, but on our side it has been quite a positive surprise, and a big step toward an efficient management of time spent on design rather than on IT technicalities.

 


Hi @STR, thanks so much for sharing this. We too have spent a lot of time on IT technicalities to make Vectorworks work smoothly for our office, which I would love to minimise.


To solve the file permissions issues, we migrated a number of times since 2018 from Mac Mini Server, to Synology NAS server, and back to a Mac Pro Server again.

 

We went from OS X 10.10, to 10.11, to 10.12, to 10.13 and 10.14. And finally reverted back to 10.11 OSX Server. This was a very time-consuming process. 

Our conclusion, like yours, was that the newer versions of Mac OS server were very problematic.


We gave Synology NAS a go with a reasonably good device  at the time (DS1517+). However, we didn't seem to replicate the success that you got. That said, it was back in 2018 and their AFP/SMB permission handling may have changed. 

See post below on all the iterations of Hardware/OS we went through below. Since this is still an ongoing issue, I'd like to look at any options to eliminate the unexpected nature of our workflow. May I ask:


- When you had similar issues, did you ever get file corruption with parts of the model disappearing?
- What Vectorworks version do you currently use?

- What Mac OS version do your terminals use?
- What is the Synology model you currently use? 
- Does your Synology device support 10GBe networking? If so, what save and commit times do you get from it for say 2GB VWXW files?
 

 

 

Share this post


Link to post
  • 0

[UPDATE 30/01/2020]

 

Just as it happened as per my post on 23/01/2020, our 'Full Model' was 'disappeared' from the project file again today.


ie. EVERYTHING suddenly disappeared from the shared project. 

 

Steps prior to the 'crash'. 

(1) I had to force quit the program at one stage today, it was not responding
(2) I used the 'backup' version to reopen 

(3) After 'regenerating 3D', I got the warning that 'some geometries cannot be regenerated'
(4) I save and committed my files, so the permissions are resolved, and then opened a fresh VWXW from the VWXP

(5) The VWXP seemed okay so I continued to work 

(6) After 5 hours of work, I 'save and committed' my work. 
(7) I got the 'this file is corrupt' warning 
(8) The VWXP file went from 1GB to 140MB, the entire 3D model disappeared (this is around the 20th time this has happened to us)
(9) We restore from one of the other user's VWXP (save a new copy and share), each user have to copy and paste lost work back into this new file


Granted, we run small projects with a small team. We can deal with these kind of issues by 'workarounds' we have developed with backed up versions. How should bigger practices with big projects deal with these issues?


We are still frustrated....

image.thumb.png.cb590c91128941af9209a8c51d4842a7.png

Edited by Amorphous - Julian

Share this post


Link to post
  • 0

[04/02/2020]

 

Another day, another fatal crash. 'This file is damaged' message appears upon save and commit again, and the project file suddenly was reduced to 188MB (from over 1GB). All work lost, all model lost. 

 

Reverting back to older version with work lost.

We are now up to Version 320 of this file. Each crash represents a fatal file failure issue. 

image.thumb.png.003b37a3a1e99d5b02168de33454d1ec.png

Share this post


Link to post
  • 0

[Update 10/02/2020]

 

Upon 'save and commit', Vectorworks crashed on one of our team members. 

When we try to re-open the file again, the opening process will only get to the end of 'Reading File' and drop off. No reason given. Video recording follows: 

 

 

This happened to the file v319 in the previous post.

 

And this happened again in our latest file v321, our team member's Working File wouldn't open. Lost the whole morning's work. Anyone who works in the industry knows how tedious it is to repeat 4-hours worth of work that has already been done. 

 

We tried to open this problematic v321 WF on the computer it crashed on, as well as other terminals. We also tried opening its backup. Cannot open. 


So, in less that one week, we have moved from v318 to v322. 

Edited by Amorphous - Julian
Uploaded mp4 for easier viewing

Share this post


Link to post
  • 0

[Second Update for 10/2/2012]

 

Shortly after above post, and after transitioning to v322, that particular computer terminal with the problematic file, which we call Mac 3, still had the same issue (either crashing or stuck on 'updating references' during S&C).

 

In any case, the Working File that is left on the Mac 3 is un-openable. Vectorworks just cannot open the file, but doesn't give any error alert. When the file is transferred to other terminals, this file displays the same un-openable problem. 

So, after the above post, and the persistence of the issue, we took the following actions:
- Uninstalled Vectorworks 2019 (we were on SP6) on Mac 3
- Reinstalled Vectorworks 2019 SP6 on Mac 3
- Ran Disk First Aid from Disk Utilities on Mac 3

- Rebooted Mac 3 
- Started a brand new Project File version (now on v323)

 

Despite the above actions, after using Mac 3 for about 2 hours, and trying to 'Save and Commit'. Mac 3 faced the same issue when doing a S&C. I took the following screenshot to show our network speed at time particular time, so it is clear that we are not experiencing a 'network problem'. Our network speeds are working fine. 

 

578990317_Screenshot2020-02-10at4_13_24PM.thumb.png.9b02a4627b0ce42b4a7ea51511eac74f.png

I want to add a personally important point. Our office have lost 1.5 days of staff time, and at least 0.5 days of my own time over this issue now. By the time this particular issue resolves, I am expecting at least 2.5 - 3 days of total staff time lost. 

This kind of software problem would, in the past, send me into a fit of rage. But the multitude of Vectorworks issues that my office has faced has forced me to train my inner Zen. What can getting angry do?

 

Moreover, having worked with the VW engineers on my reported issues, I now understand that VW engineers are under a lot of pressure (and I must add that they are quite good and helpful). I have observed that VW engineers have to, at the same time: (1) Fix VW 2019 (2) Fix VW 2020 (3) Develop VW 2021. On top of that, they have to do this for Mac plus Windows platforms, in addition to tens of localised versions. They have a job I truly don't envy. 

 

Vectorworks has some deep issues only their Management- in the way they pul back from rushing out new versions on a tight timeframe- can fix. Otherwise I expect this cycle of 'bug chasing' will continue for another 10 years, and I will keep spending a lot of time on posting problems. 

Edited by Amorphous - Julian
Grammar
  • Sad 1

Share this post


Link to post
  • 0

[Third Update for 10/02/2020]

 

Just as we thought the issue in the above posting was related to 'Mac 3' only, the same thing has happened to me, on another computer terminal.

In the middle of an operation (switching between two Vectorworks Tab), Vectorworks crashed. 

 

Now, neither my file, v323, nor its backup will open. 

Another 3 hours wasted. 3 hours between 5pm to 8pm I could have been at home playing with my cat, or cooking dinner, I wasted in front of my computer with Vectorworks, producing NOTHING, thanks to a bug. 

 

Tally for Monday 10th February:

Vectorworks: 1
Amorphous Team: 0

 

We have thoroughly lost to the program, again, today. 

 

VIDEO OF OPENING THE WORKING FILE (note file was modified at 8:03pm)

 

 

VIDEO OF OPENING THE BACKUP WORKING FILE (out-of-screen, but the file was modified at 8:02pm)

Edited by Amorphous - Julian

Share this post


Link to post
  • 0

[UPDATE 14/02/2020] 

 

We worked through the above problem with a very helpful VW engineer, who traced the 'non-opening' files back to a corrupt auto-hybrid object. 

 

For safety, we proceeded to delete the problematic object, but the 'crash and unable to open' issue happened again today.

 

Strange thing about this behaviour is, no matter what time a backup was saved, the backups (as well as the original file) will not open. 
 

It will only show 'reading file..' until the end of the progress bar and then drop out. 

 

1209721810_theoriginalfile.thumb.png.6e7a75046b4d33efc8f61533be74abd6.png841361694_thebackupfile.thumb.png.1ae2843a9013fe0790835cb7bcc8776a.png

Share this post


Link to post
  • 0

[UPDATE 17/02/2019]

 

Today, on a some of our computer terminals, when going through 'refresh' or S&C operation, the 'refreshing file' progress bar just keeps moving.

After 10+ minutes, nothing happens, and we just have to force quit Vectorworks. 

 

This happened in total around 5 times for us today, and hope this problem wouldn't persist. 

Share this post


Link to post
  • 0

[ANOTHER UPDATE 17/02/2019]

 

Suddenly all three users get the following error message during S&C. 

 

(Its a new one- never seen it before)

 

Onto version v325... 

 

image.thumb.png.0c4ac1333365eb0a069ea83ae409eaad.png

 

Share this post


Link to post
  • 0

We often got the above error message when PS "speed-exit-crashed" on one terminal. It's a false error message caused by permissions gone awry due to the crash. Notable for these speed-exit-crashes is that they don't produce any crash dumps. That's why I call them speed exit crashes. Disclaimer: The cause may be different in your case of course.

 

Man, I'm afraid to start using PS again when the time comes...

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...