Jump to content

Get rid of popup every time I exit Plug In Manager

Recommended Posts

Everytime I exit Plug In Manager I get a pop up that says "Only Plug-in Objects in the active document have been updated. You must close and open the other documents to update them".  How do I get this this warning to stop appearing?


Not having a second VW file open is not a useful answer...

Share this post

Link to post

I think this isn’t a warning you can opt not to show again, as it only arises in specific circumstances. 


Are you frequently entering and exiting the plug-in Manager? A better consideration might be how to avoid this. Using include files, turning on developer mode, and turning off caching (there should be some discussion of this in the archive) helps avoid regularly entering the plug-in Manager. 

Share this post

Link to post

Mostly just pop in and out when I'm testing snippets of code, or setting up a new tool. 

Share this post

Link to post

I just have this inside the plugin manager:


import <name of py-file>

<name of py-file>.<name of routine to run>()





The py-file contains the complete script, so you hardly ever have to enter the plugin manager...

Share this post

Link to post

In addition to enabling developer mode in Preferences>Session, add this line to your include:


vs.SetPref(412, True) #Turns off include caching


If your include includes other modules that you are modifying (for example common include libraries), you need to tell Python to reload the included modules:


import imp

import externalLib

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.