Jump to content
Phileas

Rendering Viewports - OpenGL bugging

Recommended Posts

Hey guys I'm trying to render an exterior elevation of a building I've modeled.

 

I'd like to use OpenGL as a main rendering mode so I can display shadows and colours for the site model, and Hidden lines as a secondary rendering mode to emphasize the linework.

 

However, whenever I change the main rendering mode to OpenGL, the building disappears and only the site model remains. when I hover over the building's location with the selection tool, some geometry outlines in grey and I get points to snap to, so the building is obviously still there, it simply doesn't show.

 

Layer and class visibilities are all absolutely normal, and when I enter the viewports by double-clicking and choosing "edit objects in section" (I make my exterior elevations using sections at the bottom end of the wall), the building reappears and shows normally. Exiting back to the Viewport deletes it again.

 

Has anyone experienced similar issues?

Share this post


Link to post

Hi Phileas

Have you made a sheetlayer with viewports? It is mush easier to adjust rendering and visibilty in viewports

Share this post


Link to post

@Hans-Olav yeah I created this "presentation sheet" (or however it is called in english), gave it A2 dimensions and a 300DPI resolution, and created the viewport on that sheet.

I didn't create a design layer if that answers your question.

Google tells me this is called a sheet layer in english. That's just the standard way of creating viewports isn't it?47452584_Capturedecran2019-06-26a15_33_08.thumb.png.4a3d295aff88637271269ed217c79ebe.png

1473022772_Capturedecran2019-06-26a15_32_56.thumb.png.9e759268dbce826a0f74fe55b79fd925.png

Edited by Phileas

Share this post


Link to post

Thats the right way to do it.

On the sheet layer, choose the viewport of the exterior and adjust the rendering settings in the OIP. choose Open GL for background rendering and hidden line for the front.

Share this post


Link to post

@Hans-Olav Exactly what I did.

Except you can't have openGL as the background render (the option doesn't show in my OIP, only hidden lines is possible).

So I have OpenGL as the front and hidden lines as the background render.

 

I'll show you my problem:

here's the setup you described. You'll quickly notice there are no shadows showing and no other openGL components like colour either. I't just a plain hidden line render, despite OpenGL beeing the front render.

I skipped the VP update, here's a screenshot of the end result:

26983996_Capturedecran2019-06-26a16_10_38.thumb.png.794bf457506b3633447657c0fb009547.png

no shadows, no colour, just  hidden lines. Something's obviously wrong with OpenGL.

 

watch this and if you understand anything of what is going on please help me. I just don't get it.

All my viewports behave like this.

 

File in Attachement:

EXE CR59.vwx

Share this post


Link to post

@Hans-Olav no problem thx mate.

 

I figured out I had a few objects with infinite XY coordinates, and rebuilt those. Now it seems to work fine.

Share this post


Link to post

You should also test if there is objects far from the origin 

make all classes and layers visible and fit to object

Share this post


Link to post

@Hans-Olav that's the method I used to find out all my stairs had a weird 3D loci associated to them at around 2e98 Z value... Any idea how this could have happened?

Share this post


Link to post

I dont (-:

 

I tried also to reduce the DPI of your sheet layer.

When using hidden line as foreground render, the background shadows doesn't need to be so sharp , 150 dpi is often enough and speeds up rendering 

Share this post


Link to post

@Hans-Olav Thanks for your help man

 

I've played around a little with the options I have, and came out with this:

842448541_Capturedecran2019-06-27a15_33_08.thumb.png.da2bb1b4a8e8f25f30759f175533dc6f.png

 

I like the design like this, I'm really happy with it 🙂

 

I drew above the site model with polys to get rid of the triangulation of the 3D polys making the mesh, and drew polys with a "Shadow" class above the shadows of the openGL model with 600DPI to get vectors (polygons/polylines) as shadows instead of pixelated ones 🙂

Share this post


Link to post

Looking great 

 

you can adjust the triangulation in the hidden line settings

60 degrees is usually good 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...