Jump to content

Plant tag shows zeros after decimal


Recommended Posts

  • 4 weeks later...
  • 3 months later...
  • 3 weeks later...

Same problem here. Buggy version much, VWX 2020? How can you buy anything other than multiples of 1 plant? Someone at vwx needs to think about how plants are sold!

toggle mass plants on and off - no good.

setting file units to "no fractions" - no good.


This workaround is ugly, but it works (not our office standards, either - but the plans need to go out!)



- set your tag attributes as you wish (ID + QTY in my case). You'll get 2 decimal places, but this is the only (timewaster!) way to select the attributes you want!

- Set tag bubble to "RECTANGLE".


Wait for vwx to put the correct things in the rectangles. You'll still have the decimal counts next to the  boxed attributes



- Set tag top, center, bottom display to "NONE".


this should make the redundant data disappear.



Setting the bubble alone does not eliminate the decimal places.


Haven't published or printed, so we'll see if it works on export... what a mess.


Link to comment

I found this solution to work around the problem for the moment.
By modifying the properties of the "sum" field of the "plant record" database by indicating a numeric format without a decimal point, this eliminates the problem in the labels.
Hoping that it will not create any more ...
My screenshot is on French VW 2020 SP1.1 to see for the US version.
Good evening.

Astuce pour contourner virgules dans #Somme# 'Plant record'.JPG

  • Like 3
Link to comment
  • 3 weeks later...



I have kind of the opposite problem. I'd like to add decimals to my plant's price in the plant record. Is that possible ?

As you can see in the screen shot, my plant's unit price is 39,16 in the plant style but only 39 in the plant record. When I have a few hundred or thousand plants, that difference adds up and my estimations are completely off. 


Is there a way to edit that ? 

I must add that I'm completely lost when it comes to plant database. I tried to follow the steps given in the link below to find the plant record but had to give up.



I hope someone can help.



Screen Shot 2019-12-12 at 11.27.27.png

Link to comment

The last service pack fixed the decimals in the plant tags.


This is on the Mac version of vwx 2020, but I imagine the PC version is similar enough.

I do this formatting in the worksheet.

Select the header row with the prices (or whatever you want to be formatted to currency, 2 decimal places)

Click on Format - Number

Set decimal places to 2

Set leader to $ (ou € pour vous en France ou ailleurs en Europe)


You only need to do this in the header row, it will propagate down in the summarized data.

For calculating the extended cost (qty x price) put the formula (= qty * cost) in the header row as well, and it will propagate down.


The fast way to get a total price is to reference the summed price field in the database header. This way you control how it looks, and it's visible even if the header is hidden.

Screen Shot 2019-12-12 at 09.59.44.png

Screen Shot 2019-12-12 at 10.04.11.png

Screen Shot 2019-12-12 at 10.13.43.png

Link to comment

Hello @Vlaval ,

Here in pictures how I do it (here with a V.2020 US from VectorWorks).

I do not know if it's very orthodox, but it works for me ...
I don't know what the developers think about it?

Formerly on the old versions of VectorWorks, the plant database was editable with the data from the object info palette and also from the spreadsheet. Now it's locked and suddenly it has become quite heavy and painful to edit the characteristics of the plants (SKU, price, remarks in particular).

At your disposal and disposition to improve this plant tools that could be a real bomb, but whose complexity and randomness must repel a lot of landscapers who use so "simple" symbols ...



Sorry if the syntax is not very good, but I am French-speaking, it is our friend Google who speaks for me in the language of Shakespeare... 😉

01.Database Record Format Connection.JPG

02.Database Record Format Connection Plant Record.JPG

03.Database Record Format Connection Plant Record Et voila!.JPG

04.Database Record Format Connection Plant Record Its done.JPG

  • Like 2
Link to comment


I think between vwx 2019/windows 10 and my vwx 2020/Mac that the menus have changed. My system of modifying worksheets seems to work great, and I can sum by categories, too (as long as I remember to modify the referenced cells to add). But it looks like vwx 19 + Win 10 is another story?



Je pense qu'entre vectorworks 2019 sur Windows 10 et mon version 2020 tournant sur Mac les panneaux ont été modifié. Je n'arrive pas trouver les mêmes fenêtres!


Mon système de modifier le tableur (worksheet) marche très bien, et en plus je peux grouper les plantes par catégorie (il faut cependant modifier le formule pour additionner les sommaire de quantités correctement). Mais il me semble que vwx 19 sous Windows 10 est une autre histoire.




- j'ai horreur de Google Translate. Il rend la langue de Molière aussi moche que la langue de Shakespeare!


Oh, and I was tempted to really write like Shakespeare, middle English and all. But that would be anachronistic!


Screen Shot 2019-12-14 at 14.07.44.png

Link to comment
  • 2 months later...
  • 2 months later...
On 5/4/2020 at 2:50 PM, twaikin said:

Want to report that the VW2020 OZ(Australian) SP3.1 version still has the same issue with plant quantity data tag showing two decimal places. Edgar's method solved it.


Follow up: The bug comes back every time I open the same file again and make changes.

Link to comment
  • 2 months later...
On 7/3/2019 at 8:56 PM, Tamsin Slatter said:

I have also noticed this, but not with every file. It is intermittent, but I wanted to confirm that I have listed this with our engineers who will look into it.

It's been over a year and it's still happening. Where are your Engineer's at with a solution for this.

I'm having the same issue.
Solve it with Edgar's workaround. Then the next time I open the file, it's gone back to 2 decimal places.
It's very frustrating.

Link to comment
  • 2 months later...

Below is how to fix the plant quantities displaying to 2 decimal places:

1. Go to the Tools menu > Database > Record Format Connection.

2. Locate the Plant Record in the list, select it then click Edit.

3. Select the Quantity field then click Edit.

4. Change the Type to Integer and set the default value to zero.

5. Click OK 3 times.

6. Set opacity to 100% (I know, madness but this refreshes the display).

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...