Jump to content
Cheeselog

Basic selection tool questions

Recommended Posts

I'm a very, very new user. I've watched all of the "getting started" videos through the 2D modeling section. Yet when I try to practice the techniques I've watched demonstrated, I continue to fall on my face. I feel like there are very basic things I'm missing, and I think the most basic of them is using the selection tool. The videos supplied in the getting started guides on here seem to talk about selecting solid objects, but are not helpful for selecting a simple line that is not a solid object. I'm able to select solid objects, so I don't think it's a hardware issue.

I made a brand new blank drawing. Class: none. Layer: design layer 1. No visibility options changed, no layers or classes locked.
I made a rectangle. I chose the selection tool. I moved the cursor toward my rectangle. As I got close, the border of the rectangle went from a solid line to a dashed line. The outline of the rectangle turned orange as the cursor moved to within the boundaries of the rectangle. I clicked inside the boundaries, and the "object window" went from blank to chock full of information about the object selected. I pressed delete, and it disappeared. So far so good.
I make a line. I click on the "selection" tool. I take my mouse and move the cursor toward the line. As I get the cursor close to the line, the line takes on a dashed appearance, and a little text box shows up that says "object." I click, and the line doesn't become selected. I press delete and nothing happens.
What am I doing wrong? 

Also it's really, really confusing that the solid object I want to select turns orange as I hover over it, but when I select it there seems to be absolutely no graphical representation that the object has been selected other than the object info window suddenly becoming populated up in the corner of my workspace. Is there any setting in the program to have visual feedback on when something is selected? Perhaps change the color from orange to... any other color else once the item is actually selected? I'm not sure of the terminology, I'm sorry. I poked around the visual settings and there was an option to change the "pre-selection" color but it seemed to have no effect on this so maybe it doesn't mean what I think it means.

Share this post


Link to post

Well, cheeselog, I'm wondering about your handle.  It's hard to wrap my head around that.

 

To answer your questions:  the first effect you are seeing is pre-selection highlighting.  It tells you what object you are about to select if you left-click.  You can turn that off in Vectorworks Preferences dialog box (Interactive tab), and there you can also find a link to the detailed settings for highlighting colors & effects.  When you select an object, the highlighting CAN be different if you have selected something different in the Interactive Appearance Settings dialog.  I have set my preferences to not show pre-selection highlighting, and things are only highlighted if selected.  You should also see little blue squares at key points on an object when it is selected - those are points you can grab to reshape an object.  Also, pay attention to the actual shape of the cursor.  It is an arrow when you are not "within range" to select any object, a white triangle when you are within range (a left-click will select), and a cross symbol when you are within snap radius of a smart-cursor point (like an endpoint, for example).  You can also set your snapping "sensitivity" in Vectorworks Preferences Interactive tab by chosing the appropriate selection box and snap box sizes - it's intuitive, play around with it.

 

If you are used to AutoCAD selection, try to wipe that out of your mind.  Marquees will not select an object in VW unless it is totally encompassed within the marquee.  (Unless you hold down the "Alt" key).

Share this post


Link to post

Thank you. That pre-selection highlighting being the exact same color as the selection highlighting was utterly confusing. Now the item changes to a different color once selected. I might just turn off pre-selection at a later date, but I can see where it might be helpful in a crowded drawing. 
I also figured out how to disable the reshaping of an object when trying to move it or select it. I will very, very rarely freehand the reshaping of anything.
I'm trying to unlearn just about everything from AutoCad. I'm used to selecting a command before selecting an object, and Vectorworks doesn't seem to allow that easily. I miss being able to click drag left or right for different selection options, but I guess I'll get over that. What I really miss from AutoCAD is just the simple move tool and copy with base point. In Vectorworks I find myself often accidentally moving things I didn't mean to move, and it's frustrating. I never had that issue with AutoCAD. 

Oh well. Onward and upwards. Thank you for your input. Just being able to know when I have something selected is a huge, huge help.

Share this post


Link to post

I don't know what version of VW you are working with, but since several years ago VW implemented the move-by-points tool.  It's in the Basic Toolbox, and looks like the highlighted icon:

 

image.thumb.png.f4d58d5b2a937a3f8865cfe57708960a.png 

It works just like ACAD, in that you can select an object, then select the tool and click on any two points anywhere to define a move.  There are lots of options, so check those out (number of copies, keep original object or delete, distribute across the vector or repeat the vector for each copy).

Share this post


Link to post

I watched the training video on Move by Points, and I don't understand the logic behind it. It seems like the Array tool in AutoCAD, but I don't want to array the object, I just want to move it. The only mode that doesn't array the object is the Reference Point mode, and it does not seem to produce predictable results. I select the object, use the little data entry box to tell it how far to move and at which angle to move, and.... it doesn't move it to that, it opens up a dialogue box with my designated move distance as an offset distance. Now if I click "ok" and don't change the value in the text field, nothing will move. If I want to move it to the parameters I've already typed, I have to select an offset distance of 0. Which is just.... bizarre to me. If I wanted to offset the object, I'd use the Offset tool. I just want to move the object using a corner of the object as a reference point. 

Share this post


Link to post
Posted (edited)

To simplify:  change the settings (in the top bar on the left) to "Move mode," Object retention off, 1 duplicate:

image.thumb.png.04b68e05279460d3c4de9dd0f6843979.png

Then click on two points on the screen and the object will move by the distance and direction (vector) defined by those points.  That's exactly what ACAD move by points does.  Using the data box is not doing a move by points.  Selecting 2 points is a move by points, the first of which can be on the object if you so choose.  Is it possible you are stuck on the Move command, which is different from the Move by Points tool (see my previous post)?

Edited by P Retondo

Share this post


Link to post

My typical flow goes like this:

Realize I want to move an object. Look at the toolbar and find one that seems like it would move an object. Move by points seems to be what, I want to do. Select the tool. Try to select the object I want to move, and get confused why I can't select it. Remember that it's AutoCAD that lets you select the tool first, and Vectorworks won't let you do that. Hit the escape key. Select the object again. Realize that escape doesn't escape you out of the move by points tool. Select the selection tool. Finally succeed in selecting the object. Then select the move by points tool again. Try the first mode: move mode. Sounds promising, that's what I want to do. Select the edge of the object I want to move, select the point I want to move it to. It moves the object to where I want it, but creates an array of duplicate objects. That's not what I want, control z undo. Try the second mode: distribute mode. I don't really want to distribute anything, but there's only 3 options so try it anyways. Choose the point on the object, choose the destination. It also moves the object to where I want it to be, but also creates an array of duplicate objects that's a different pattern than the first mode. Control z, that's not what I need either. Try the third option: reference point mode. Yes, that's what I want to do! Move an item by a reference point of my choosing! Finally! Choose the point on the object, choose the destination, and a window pops up asking me to enter an offset value. The data entry field is prepopulated, so I assume that's the distance I want to move it. Looks good. Hit ok. The popup window closes, but the object doesn't move. Try it again. Window pops up again, this time you realize that the data entry field is asking for an offset value. I don't want to offset it at all, do I? No, I'd use the offset tool to offset objects. Why are there offset options in the move tool? I want to move by points, not offset by points. Whatever. I click in the text entry field and enter an offset value of 0. Click ok, and the object goes where I want it to go without making any duplicates.
That's the end result I want, but it's so many steps to do what used to be a 3 click, no typing operation in AutoCAD. Maybe if the default value in that offset box was 0 it would go a little faster, but I haven't found a way to do that.

I tried the way you suggested, changing the number of duplicates and all. That seems to work, but it seems like an awful lot of work just to move something. I wish there was a mode to just move things without duplicating them and without having to dictate an offset value of 0. 

As far as the move command, I'm not exactly sure what you mean. What's the difference between a command and a tool? Are there other, more simple move functions in the program that aren't the Move by Points tool?

All I want to do it take a line, select an end of the line as my reference point, and move that same reference edge of the line I selected to a point of my choosing without duplicating it or offsetting it or anything. Is there a simple way to do that?

  • Like 1

Share this post


Link to post
Posted (edited)

It's time to let us know what version you are using.

 

To select an object after first selecting the tool, hold down the "Alt" key and click on the object.  It is more efficient to just get used to the VW way of selecting objects first, then choose your operation.  To just move the object, change the settings in the "Move by Points" tool the way I previously suggested (see graphic above).  Those settings will stick unless you change them.

 

You should not be duplicating the object unless you want to use the "Move" command (see below).  To use the "Move by Points" tool to both move and duplicate with the settings I have suggested, hold down the "Ctrl" key (or Mac equivalent) while making your two clicks, and it will temporarily override your settings from "move without retaining" the original object to "move and duplicate" (retain original object).

 

You can get rid of offsets when duplicating by editing VW Preferences (Edit tab) and unclick "Offset duplications".

 

"Tools" are in set in boxes, usually on the left.  "Commands" are from dropdown menus on the top bar.  There is a "Move" command that brings up this dialog box:

 

image.thumb.png.c42d383978c2e0a927a7118189a0bf74.png

PS:  to increase your speed, get used to using keyboard commands.  That is the next stage in your development.  Most veteran ACAD users use keyboard commands, ACAD used to be a command-line program before they started using visual icons to select operations.

Edited by P Retondo
  • Like 2

Share this post


Link to post

I'm sorry, I have no idea what happened there. And I have no idea how to delete my posts on here. 

Thank you. All of this is quite helpful. Much more so than the "getting started" section of the Vectorworks site. I didn't even know there were more "commands" up in the menu. Another thing the "getting started" and the introductory modeling videos left out, I guess.

As for the selection first workflow order... old habits are hard to break. I was on AutoCAD for 17 years and I've been on Vectorworks for about a week. I'll need to get used to that, but it's going to be a struggle for a while. 

I'm using Vectorworks 2019 SP3 with Fundamentals, Spotlight, and Renderworks.

The Vectorworks site training videos thus far seem to be... less than helpful. But I recently discovered their Youtube page and I found a skatepark creation tutorial for Vectorworks 2015 that seems to be more informative than anything I've found for 2019. 

Share this post


Link to post

The inconsistency of operations order is a perplexing thing as well. To move an object in Vectorworks, the user must select the object first and then the move command or tool. But to fillet or chamfer, the user must select the operation first and then the impacted objects.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...