Jump to content
Phileas

Pad Modifiers disappearing

Recommended Posts

I've got a pretty annoying bug going on on my site model.

 

I have a lot of "Pad with vertical edges" site modifier objects, and I edited the retaining edges to fit the terrain I want to create.

 

However, and this is the second time this happens, after a few hours of working without touching these pads by any means, I want to go back and just move one vertex of the retaining edge. but no matter how often I double-click on the pad site modifier to get into the adjustment tool and be able to move the vertices, I get into the tool, but I don't get any handles to modify them.

 

Thinking this must be a simple displaying issue, I decided to modify that one vertex using the OIP controls. Guess what: entering the "edit retaining modifier vertex" mode in the OIP completely deleted the site modifier. Updating the site model showedit simply "stopped existing". No pad, no site modifier, nothing.

 

Now, here comes the annoying part: when I was working on that site model the first time, it already happend, but I only had a few pads an no particularily edited retaining edges, so I didn't bother reporting it and simply redrew every site modifier from scratch, and got the blue editing handles back.

 

But this time I have about 2 or 3 hours worth of work of site modifiers, and all of them are impossible to edit. I don't have the time to rebuild them all from scratch and would really appreciate some help.

Share this post


Link to post

Hi Phileas, any chance you could attach your file here, and post a short screen capture video of your workflow?  You're on 2018, right?

Share this post


Link to post

@Mike Lamb yeah right I'm on VW2018

 

Here's the screen recording showing exactly what I explained. I've already redrawn a few of the modifiers, like the one I show in the beginning that shows the adjustment handles.

 

 

And here's the file:

EXE CR59.vwx

 

Share this post


Link to post

@Phileas - I was able to reproduce this using 2018 on my Mac, but not in 2019.  It's much easier to select the site modifiers in a 3D view now as well in 2019.  Unfortunately we've stopped releasing service packs for 2018 at this point, so this will not be fixed in 2018.  If you would like to try this in 2019, you can go here for a free evaluation copy:  https://www.vectorworks.net/trial/

Share this post


Link to post

@Mike Lamb - Glad to hear you've improved the site modeling in VW 2019.

 

However, I don't have the possibility to upgrade (despite really wanting to), because this is the computer of the Office I'm currently working in, and my boss refuses to get the upgrade.

 

Guess I'll have to redraw all the modifiers by hand 😞

 

Or, did you manage to "repair" them by opening the file in VW2019? If that's the case, could you share the repaire file so I can try and see if I can get them back?

 

Share this post


Link to post

@Mike Lamb Thanks for your help!

 

unfortunately, the same pad modifiers keep bugging, so it didn't work... But thanks for trying anyways

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×