Jump to content
KroVex

Alert Dialog and Attribute Popup

Recommended Posts

Hi all

 

I have two questions about Marionette:
1. Is there a way that only an alert dialog appears when a "true" or "false" arrives the Input from the alert dialog-node?

2. I have made e specific Class-Generator. Is it possible to generate an attribute popup, which allows me to choose the fill color and pen color/thickness in the OIP?

Greetings KroVex

 

 

Share this post


Link to post

For #1, you can use a valve node before the alert dialog to determine if it shows or not.

The only current issue is that nothing past the valve will run if the input is false, even if the network converges somewhere later.

 

for 2, we don't have any OIP controls like that, so I am going to guess no.

A workaround would be to modify your own popup controls with possible values, but I don't think we can display color at this time, it would have to be text based.

  • Like 1

Share this post


Link to post

Hi KroVex,

 

1) You can simply use a valve node for this purpose. By default it passes the item when True and blocks the output when False. If you need it the other way round (pass when False, block when True), you can use the not node to invert the boolean value.

2) I have no answer for this one, but I would like to see this in Marionette as well.

  • Like 1

Share this post


Link to post

The Vale-Node Works fine, thx.

Another Question: 
Since Vectorworks 2019 you can assign tag's to classes.
Are these Tag's Class attributes? Or how can I add Tag's to Classes with Marionette? 

 

Greetings KroVex

Share this post


Link to post

That's wonderful, thanks Marissa. 🤩
It looks understandable, I'll test it 🙂

 

Greetings KroVex

Share this post


Link to post

Hi All

 

I have e question about to add Tag's to Layer:
I have a Marionette-Network which creates several design layers at once. So the output is a list which ends in the node "Layer with Type". Now, if I use Marissa's Node (Set Tags) to add tags to the layers, then only one layer will be tagged. Does anyone know what I'm doing wrong?

 

I have tried several ways:
1204979380_Bildschirmfoto2019-06-13um09_51_39.thumb.png.56e4ecb24f3e3af6cd2639cbac3b016f.png

 

Result:
1213437216_Bildschirmfoto2019-06-13um09_48_48.thumb.png.f7ec55c1d3ce5743dbcb961d5deefbfb.png

 

File:
Tags_to_Designlayer_List.vwx

 

Greeting KroVex

 

Share this post


Link to post

Attached is a file with a revision that should work for this use case, I'm sure there's a reason I didn't go this route initially, but I can't recall why.

 

There's also a chance I had fixed the issue you're experiencing in a more recent node, though I'll have to dig through some files to see what my latest revision was (though I'm sure it's more recent than Nov 2018, as dated in the node you've been using)

Tags_to_Designlayer_List_MFarrell.vwx

  • Love 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...